Feature #17352

Change number of Blufor units required to clear a square, from 2 to 1

Added by Swedge almost 5 years ago. Updated over 4 years ago.

Status:Closed Start date:02/05/2011
Priority:Normal Due date:
Assignee:Fireball % Done:


Target version:0.75
Affected Version: GPU VRAM size:
Operating system: I am using some Mods:
Graphics card: Reproducible for you:
Difficulty: Related to content of DLC:
CPU: Affected ArmA3 version:
System RAM size: Single / Multi Player?:


Insurgency is currently coded so that it takes 2 Blufor units to enter a red square on foot to clear it and turn it green.

One of the biggest problems with Insurgency servers that are unpopulated by players, is getting that initial momentum of players connecting.

There currently isn't a huge deal of incentive for 1 person to connect to an empty server, since they can find the occasional briefcase if they're lucky, but they're unable to change squares to green on their own but to clear on their own.

This setting was presumably added to increase teamwork. I would argue that when the server becomes fairly populated, most players may work as a team anyway, clearing squares together, because otherwise they're going to be without protection and get shot.

It's also unrealistic in that, in real life, there's no magical law of physics that prevents 1 person from clearing a building or grid-square :) Although it's clearly frowned upon in military SOP's and field manuals etc, if there's only 1 player on the server (or in real life) they may have no choice.

Giving more units the ability to clear grid-squares themselves may also increase the pace of the game and ultimately the rate that caches are sought and destroyed.


Updated by Fireball almost 5 years ago

  • Category set to Markers
  • Status changed from New to Feedback

For some reason it IS a coop mission. Even though if you are playing alone, you can get intel and find the cache to blow it up.

I might make it an option (clearing requirement 1 or 2 players), so you can play it as a "single player" mission, but more feedback on that idea appreciated.

Updated by Fireball almost 5 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 0.75
  • % Done changed from 0 to 100

I now made it a mission param, letting you to select between 1, 2 or 3 players needed to clear a square, but still defaulting it to 2.

For those who want to a different default, they can specify this also in their server config.

Updated by Fireball almost 5 years ago

  • Assignee set to Fireball

Updated by Swedge almost 5 years ago

Cool. Thanks Fireball.

Updated by Fireball over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF