Feature #17348

Remove M252 Mortars

Added by Swedge over 4 years ago. Updated over 4 years ago.

Status:Rejected Start date:02/05/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Affected Version: GPU VRAM size:
Operating system: I am using some Mods:
Graphics card: Reproducible for you:
Difficulty: Related to content of DLC:
CPU: Affected ArmA3 version:
System RAM size: Single / Multi Player?:

Description

This doesn't worry me particularly but I thought I'd make a case for removing them.
A lot of Insurgency variations on the net have removed mortars anyway, it seems somewhat popular to do so.

Reasons to remove them:

  • Some Blufor players, from their base, will systematically mortar every building in the suspected cache radius to avoid having to assault the town. They can destroy the cache from the safety of their home.
  • Sometimes the cache will fail to be destroyed by the mortars, but the building around it will be destroyed. Ground forces are then unable to see the cache box beneath the rubble (without crawling on their hands and knees), and gameplay grinds to a halt because the cache cannot be found and players start leaving the server. Many players do not realise that the cache can still surive under the rubble. If they do, when found, the cache can then sometimes require a huge number of satchel rounds to eventually destroy it.
  • More mortars means more destroyed buildings. I read somewhere once that increasing the number of destroyed buildings significantly can increase server lag caused by rubble models. I don't know if that's true or not as I don't have the reference for it.
  • Unrealistic and somewhat 'cheap' for gameplay. Since there's no civilians in Insurgency, Blufor can just continually rain unlimited mortar rounds indiscriminately, from the artillery map, from kilometres away, with no risk to themselves.

History

Updated by Swedge over 4 years ago

Affects v0.72.

Updated by Badger911 over 4 years ago

Swedge wrote:

This doesn't worry me particularly but I thought I'd make a case for removing them.
A lot of Insurgency variations on the net have removed mortars anyway, it seems somewhat popular to do so.

Reasons to remove them:

  • Some Blufor players, from their base, will systematically mortar every building in the suspected cache radius to avoid having to assault the town. They can destroy the cache from the safety of their home.

Non-issue. But could be countered by lowering the probability of intel markers.

  • Sometimes the cache will fail to be destroyed by the mortars, but the building around it will be destroyed. Ground forces are then unable to see the cache box beneath the rubble (without crawling on their hands and knees), and gameplay grinds to a halt because the cache cannot be found and players start leaving the server. Many players do not realise that the cache can still surive under the rubble. If they do, when found, the cache can then sometimes require a huge number of satchel rounds to eventually destroy it.
  • More mortars means more destroyed buildings. I read somewhere once that increasing the number of destroyed buildings significantly can increase server lag caused by rubble models. I don't know if that's true or not as I don't have the reference for it.

I would rather make buildings non-collapsible, not removing weapons that can collapse buildings.

  • Unrealistic and somewhat 'cheap' for gameplay. Since there's no civilians in Insurgency, Blufor can just continually rain unlimited mortar rounds indiscriminately, from the artillery map, from kilometres away, with no risk to themselves.

I forked and added civilians plus a death counter that ends the game once X civilian deads. Forces players to play more realistic, forcing them to use mortar spotters. In beta testing.

Updated by Swedge over 4 years ago

Badger911 wrote:

I forked and added civilians plus a death counter that ends the game once X civilian deads. Forces players to play more realistic, forcing them to use mortar spotters. In beta testing.

That would be cool.

Updated by Fireball over 4 years ago

  • Status changed from New to Rejected

There is no more arty in the original 0.72 which I based my work upon. It's an overkill anyway.

Updated by Swedge over 4 years ago

Fireball, the Mortar referred to here is not the old artillery support radio command that was removed prior to 0.72 but the "M252_US_Bag_EP1" which is in the gear Loadout Secondaries option.
Cheers.

Also available in: Atom PDF