Bug #17313

[Linux DS] Date format wrong

Added by Fireball about 4 years ago. Updated over 2 years ago.

Status:Closed Start date:02/04/2011
Priority:Normal Due date:
Assignee:Dwarden % Done:

100%

Category:Server
Target version:1.63 BETA
Affected ArmA II version:1.63 Beta First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Linux server 77737 has wrong date format.

Obs
There is an error in Linux RPT (log.23**.log) time format:
111/00/31, 21:32:28
111/01/01, 0:18:10

Exp
In Windows RPT file it look like this:
2011/01/31, 20:18:27
2011/02/01, 2:00:31


Related issues

related to ARMA2 Community Issue Tracker - Feature #17178: logFile time stamp format Assigned 01/31/2011

History

Updated by Fireball about 4 years ago

  • Due date set to 05/04/2011
  • Target version deleted (1.58 BETA)
  • Affected ArmA II version changed from Please select... to 1.58 BETA

Updated by Dwarden about 4 years ago

  • Operating system set to Linux

Updated by nomad_man over 3 years ago

Still present in: 1.59.79548 Linux.

In addition the timestamp affects only RPT entries but console messages only have time and no date

Updated by nomad_man over 3 years ago

For more details on requested console message timestamps please refer to this specific post
http://forums.bistudio.com/showpost.php?p=2070933&postcount=15

The entire thread: http://forums.bistudio.com/showthread.php?t=128289&page=2

Updated by Dwarden over 3 years ago

  • Assignee set to Dwarden
  • Target version set to Upcoming version

Updated by killswitch about 3 years ago

The time stamp format error is still present in 1.60.90909. Here's an sample of a few lines from log.2302.txt. Full timestamps were turned on in the server.cfg file:

timeStampFormat=full;

log.2302.txt:

WATCHDOG (12170): [Sun Apr  1 11:09:18 CEST 2012] Starting server (port 2302)...
...
...
...
11:10:43 Mission Warfare BE V2.071 Lite CO - Takistan read from bank.
11:11:00 Roles assigned.
11:11:00 Reading mission ...
11:11:14 Mission read.
 112/03/01, 11:11:15 "[WFBE (INIT)][frameno:8885 | ticktime:116.836] Init_TownMode: Towns mode initialization (world: takistan) - [Done]" 
 112/03/01, 11:11:15 "[WFBE (INIT)][frameno:8886 | ticktime:116.855] Init_Camp: Removing camp NurCamp2 (Nur) since the town is removed in the towns templates." 
 112/03/01, 11:11:15 "[WFBE (INIT)][frameno:8887 | ticktime:116.878] Config_Town: Removing town Chaman (Chaman) since the town is removed in the towns templates." 
  • Note how the actual date was April 1st, 2012
  • The log timestamps have a malformed year output (" 112")
  • The date is off by a month - it looks as if it was was March 1st ("03/01")

Updated by killswitch over 2 years ago

  • Affected ArmA II version changed from 1.58 BETA to 1.63 Beta

The issue is still present in 1.62.98874

Updated by kju over 2 years ago

  • Due date deleted (05/04/2011)

Updated by bebul over 2 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Note: (-: providing the example containing the date April 1st looks like joke ;-)
Fixed, rev.98939
Uploaded to ftp://downloads.bistudio.com/arma2.com/update/a2oa-server-1.62.98939.tar.bz2

Updated by bebul over 2 years ago

I do not want my joke struck through :-P

Updated by kju over 2 years ago

Fixed it with the @ tag for code formatting. ;-)

Updated by kju over 2 years ago

  • Target version changed from Upcoming version to 1.63 BETA

Updated by Dwarden over 2 years ago

  • Status changed from Resolved to Closed

closing

Also available in: Atom PDF