Bug #17212

The Su-25 RU Des laser is pointing at the wrong spot and cant be moved.

Added by Zach over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:02/01/2011
Priority:Normal Due date:
Assignee:Sickboy % Done:

90%

Category:Complex
Target version:1.9
Component: Affected Version:
Close Reason:

Description

The Su-25 RU Des laser aims way low and cant be moved. The Su-25 RU laser can be moved a little, but its not smooth and is not aimed at the cross.

ArmA2OA_2011-02-02_13-35-25-30.png (900.6 kB) conKORD, 02/02/2011 10:41

ace_sys_missileguidance-_17212-fixed2.7z (29.8 kB) Sickboy, 03/01/2011 13:12


Related issues

related to A.C.E. for OA - Feature #11285: Kh-29L FCS - Adjust laser marker position by "arrow" keys Closed 06/16/2010
related to A.C.E. for OA - Bug #20042: kh-29L Laser aim broken (since 1.59) Closed 05/25/2011 06/03/2011
duplicated by A.C.E. for OA - Bug #17219: Su-25 laser designator problem Duplicate 02/01/2011

Associated revisions

Revision 2b8f4f29
Added by Sickboy over 4 years ago

KH29 testfix. refs #17212

Revision 36c2fd62
Added by Sickboy over 4 years ago

~ FIXED: Broken dir/pitch offsets for KH29L missileguidance

Cleanup. refs #17212

History

Updated by Sickboy over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to VKing
  • Target version set to 395

Updated by VKing over 4 years ago

Confirming it doesn't work, but I've no idea what's wrong or how to fix it.

Updated by q1184 over 4 years ago

Probably caused by the changes from #11285.

Updated by Sickboy over 4 years ago

conKORD could ye have a looksy please?

Updated by conKORD over 4 years ago

Laser marker appears here and can be moved.

Test:
1) load mission Proving ground
2) create Su25
3) get in
4) write in console (vehicle player) attachTo [PG_logic getVariable "CORE",[0,0,30]]
5) have fun

And . . . rocko, why are you changed keys to adjust marker position?

Updated by Sickboy over 4 years ago

Thanks, problem is said to be with Su25 des mostly.
Which keys are the adjustment keys?

Updated by conKORD over 4 years ago

My variant:
left - [,]
right - [/]
up - [;]
down - [.]

rocko changed it to
left - [,]
right - [.]
up - [shift+,]
down - [shift+.]

IMHO with arma's viewdistance, that's commonly about 4000m, here is not enough time to play with shift while aiming.

PS laser on "ACE_Su39" also works normally.

Updated by rocko over 4 years ago

  • Subject changed from The Su-25 laser is pointing at the wrong spot and cant be moved. to The Su-25 RU Des laser is pointing at the wrong spot and cant be moved.

Updated by foxwuj over 4 years ago

ACE 469 no other mod running nor (beta patch it won't affect any thing)
tested at utes and Chenarous and takistan

well i had the same problem too so i ran some test it seems like the LAZ ammo like KH-29 aim point is affected by

1: ground elevation (it make LAZ ammo like KH-29 useless at some place or map)
2: distance to target (aim point starting to change if distance is blow 300~ish to ground) which is not a problem its gonna turn off by it self any way

(if u test it around top left NW air field in cherno)
KH-29 aim point go way below the hud, down to some where at the gauges where u can c through

(if u test it in takistan)
KH-29 aim point go below the hud, how far down is depend on where u r at some place aim point go way down to where at the gauges at where u can c through

(if u test it around shore in cherno like say chernogorsk and elektrozavodsk just along that line)
every thing work normally

(if u test it at utes)
every thing work normally

repo step
1 place a jet
2 fly above 1200 hight
3 flaps all the way down slow down to 240 air speed
4 20~30 degree dive
5 level the jet
6 find a fixed target
7 laz at it
8 tap lock c where u actually aimed
9 repeat step 7 until laz automatically turn it self off

note!!!
i believe it was totally fine b4 Zach started this post
and
it does the same thing to custom map
and
all jet laz aim point is affected

Updated by Sickboy over 4 years ago

  • File ace_sys_missileguidance-_17212-fixed.7z added

thanks foxwj, please try with attached fix. (Need latest winrar/7zip)

Updated by Sickboy over 4 years ago

  • Status changed from Assigned to Feedback

Updated by foxwuj over 4 years ago

nope it didn't do it

tested at utes and Chenarous and takistan

all the same higher the ground level lower the laz aim point go, work just fine at sea level

Updated by Sickboy over 4 years ago

  • File deleted (ace_sys_missileguidance-_17212-fixed.7z)

Updated by Sickboy over 4 years ago

Thanks, please retry with attached.
If still issues, hopefully conKORD can have a look.

Updated by foxwuj over 4 years ago

tested at utes and Chenarous and takistan

all working 99% of the time normally laz aim point always stay at the hud regardless of map or ground elevation and that 1% is i got a error message error procssing distance some thing like that, at the top right corner where the lazing info is. no big deal i can always laz again right away work fine, it happen when i adjust the laz point too far, not thing need to be fix.

i can c y Zach report the laz point isn't adjustable, it dose work i could adjust the aim point after laz (cool feature didn't know that until i c this post) regardless of map or ground elevation but some time it doesn't seems to be responding even it is working... any way its working

at last i wonder if its possible to bump up the lockable range to 4k or bit more? it seems current lockable range is about 2.5k now which is very enough for 4k VD higher lockable range is just useless, unless some idiot like me like to tune up his VD to 8k when he is flying. its a pain to be able to laz a target but not able to lock it, well if u laz it but without putting lock on it the thing just fly straight not gonna hit where u lazing... the real thing can shoot 8~10km yeah i know u can't compare sim to real live. it is a blast to kill some 1 at a great stand off range.

Updated by Sickboy over 4 years ago

  • Category set to Complex
  • Status changed from Feedback to Resolved
  • Assignee changed from VKing to Sickboy
  • Target version changed from 395 to 1.9
  • % Done changed from 0 to 90

Glad to hear!
Controlling the laser problems are odd - perhaps conKORD can take a look at that.

The lock-range - will have to confirm with King Homer

Updated by foxwuj over 4 years ago

Controlling the laser isn't a issue. it do work but can't tell y it doesn't show some time. can't spot any obvious sign of what might affect it yet

Updated by rocko over 4 years ago

  • Status changed from Resolved to Closed

Should be available in the about to be released 1.9 RC 3

Also available in: Atom PDF