Bug #1718

In multiplayer, you cannot make AI under your control disembark from a non-local vehicle (one driven by another player or server-side AI).

Added by Sickboy about 6 years ago. Updated over 3 years ago.

Status:Closed Start date:06/02/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

80%

Category:Multiplayer
Target version:1.55.75445
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Steps to reproduce:

  1. Put the attached mission (pbo) on a dedicated Arma II server.
  2. Connect to the dedicated server, load the mission and start it.
  3. You will find yourself in a truck driven by an AI not in your group. Get out.
  4. Now order your team mates to disembark (Select all, then 4-1 "Disembark").
  5. Expected result: your team gets out of the truck.
    Actual result: while your #2 will report "READY", none of them will get out of the truck.

In this case, the truck is driven by a server-side AI, but the same inability to disembark your team is there if another player is driving the truck.

I can reproduce this problem using the Arma II 1.04.60091 beta and

  • A Windows dedicated server of the same version and build.
  • A Linux dedicated server with the 1.04.59962 build. (-mod=beta using the 1.04.60091 beta mod folder files)

Reproducability: http://forums.bistudio.com/showpost.php?p=1256314&postcount=8
(http://forums.bistudio.com/showthread.php?t=71414)

ailocalbugveh.utes.pbo - New Arma2 mission (2.7 kB) lwlooz, 09/22/2009 20:10

bug_1718_mp_disembarking_ai.zip (1.9 kB) killswitch, 11/11/2009 17:18


Related issues

related to ARMA2 Community Issue Tracker - Bug #14134: "assignedVehicle" of remote unit is not updated where the... Assigned 10/02/2010 02/01/2011

History

Updated by kju about 6 years ago

Also reported in the NG with repro and demo mission.

Updated by kju about 6 years ago

  • Priority changed from High to Normal

Updated by alef about 6 years ago

  • Due date set to 07/17/2009
  • Category set to Multiplayer
  • Status changed from New to Feedback
  • Assignee set to kju
  • Affected ArmA II version set to 1.01.57751

If this is in their NG, we will leave this bug in Feedback assigned to nobody. Just update the version, if still reproducible.

Updated by Fireball almost 6 years ago

  • Due date changed from 07/17/2009 to 08/21/2009

Is this still a problem?

Updated by kju almost 6 years ago

  • Due date deleted (08/21/2009)
  • Status changed from Feedback to Assigned
  • Assignee deleted (kju)
  • Affected ArmA II version changed from 1.01.57751 to 1.03.58627

yep

Updated by zGuba almost 6 years ago

  • Due date set to 09/30/2009
  • Status changed from Assigned to Feedback

Still an issue in 1.04?

Updated by lwlooz almost 6 years ago

It is.

Updated by zGuba almost 6 years ago

  • Due date changed from 09/30/2009 to 12/30/2009
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026

Updated by Terox almost 6 years ago

This is a 7 year old bug and is a real pain in the butt on multiplayer coops

Updated by walker almost 6 years ago

I have checked 1.04 and this MP killing bug is still there. This bug was first reported in OFP and is why several features in CoC scripts were never released as they could never be guaranteed to work in MP.

The Locality bug seriously effects team play in large scale MP missions. I also suspect this Locality bug may be the cause of many other issues in MP and why several scripting commands do not work in the way they are supposed to.

I believe that fixing this one bug will solve several others.

Updated by killswitch over 5 years ago

I'm wondering if this issue isn't getting the proper attention due to the somewhat vague title and lack of a full description of the problem and reproduction steps right here in the issue tracker...

In any case, here's another simple test mission that displays the problem in ArmA II:

In multiplayer, you cannot make AI under your control disembark from a non-local vehicle (one driven by another player or server-side AI).

Steps to reproduce:

  1. Put the attached mission (pbo) on a dedicated Arma II server.
  2. Connect to the dedicated server, load the mission and start it.
  3. You will find yourself in a truck driven by an AI not in your group. Get out.
  4. Now order your team mates to disembark (Select all, then 4-1 "Disembark").
  5. Expected result: your team gets out of the truck.
    Actual result: while your #2 will report "READY", none of them will get out of the truck.

In this case, the truck is driven by a server-side AI, but the same inability to disembark your team is there if another player is driving the truck.

I can reproduce this problem using the Arma II 1.04.60091 beta and

  • A Windows dedicated server of the same version and build.
  • A Linux dedicated server with the 1.04.59962 build. (-mod=beta using the 1.04.60091 beta mod folder files)

Updated by kju over 5 years ago

  • Subject changed from Locallity Bug; Multiplayer behaviour not the same as Singleplayer to In multiplayer, you cannot make AI under your control disembark from a non-local vehicle (one driven by another player or server-side AI).
  • Reproduced by another DH user set to No

Updated by zGuba over 5 years ago

  • Reproduced by another DH user changed from No to Yes

Updated by alef over 5 years ago

Video made using bug_1718_mp_disembarking_ai.zip

Situation

  • One player as driver
  • Another as cargo

Repro

The cargo player:
  • order your AI to disembark

Observed

  • AI will not disembark
The driver player:
  • Get out

Observed

  • AI will now disembark

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by IceShade over 5 years ago

Excellent video alef.

Like Killswitch said, even with beta 60141 this can be reproduced. This bug is ancient, has been bugging every coop involving a vehicle and I sometimes wonder whether this will live through Armed Assault 2 as well.

Updated by killswitch over 5 years ago

Apparently, this issue has been resolved in VBS2 v1.3. Note the fourth fix listed in the readme: Readme_VBS2_1_3.txt :

ADDED: Fixes local subordinate units not disembarking from remote AI driven vehicle in multiplayer

Updated by alef over 5 years ago

walker wrote:

I also suspect this Locality bug may be the cause of many other issues in MP and why several scripting commands do not work in the way they are supposed to.

I agree. I've made yesterday a repro for another old locality bug: reload, repair or refuel a cobra with pilot and gunner on different clients. One of them hosts the mission.

The vehicle changes locality to the pilot/driver client, as expected. But if the initiator of the action (gunner) is not local as the vehicle, the conflict happens.

Result: vehicle refueling or reload get stuck, and can't be resumed anymore. Plus other side effects, like missiles get loaded only if # > 0. More when posted, I'll probably relate that to this issue.

Edit: #6367 and #6383

Updated by Fireball over 5 years ago

  • Assignee changed from Dwarden to Luca

Updated by kju about 5 years ago

  • Due date changed from 12/30/2009 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Luca)
  • Affected ArmA II version changed from 1.04.59026 to 1.05 BETA
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Still valid in 1.07 / OA?

Updated by alef almost 5 years ago

I've didn't the very same report as here, but in another repro I'm doing similar to this, just with mount instead of dismount.

I noted that the assignment of vehicles is not propagated correctly to and from a remote vehicle, at least as reported by assignedVehicle and assignedVehicleRole. "Correctly" seems that the update happens after the mount, or later, or never.

More in a new ticket, but just to share the new maybe someone could already have a look.

Updated by kju almost 5 years ago

  • Due date changed from 07/14/2010 to 10/14/2010

Last chance for feedback before expiring.

Updated by lwlooz almost 5 years ago

Good News everyone! This bug has mutated.

Killswitch's Repro (Using "bug_1718_mp_disembarking_ai.zip"):

This currently appears to be fixed in the 73968 beta
Following Killswitch's Reproduction Steps one can observe the expected result

Original Repro (Using "ailocalbugveh.utes.pbo"):

This currently appears to be differently broken in the 73968 beta
Steps to Reproduce:
  1. Load ailocalbugveh.utes on a Dedicated Server OA 73968
  2. Let two players join . One as the Soldier(First Slot) and one as the Squad Leader(Second Slot)
  3. The Soldier gets into the Truck as a Driver. The Squad Leader then orders his subordinates to get into the truck (In the back/as Cargo)
  4. The Squad Leader issues the "Get Out" command
  5. After all subordinates have disembarked , the squad leader orders his man to get back into the truck as before
    Expected Result: The subordinate AI will get back into the truck
    Observation The subordinate AI runs to a spot away from the truck and is stuck at that spot and does not get in.

It appears that the old "Local-Bug (Dismounting AI)" is gone completly currently(as of 73968) for remote AI driven vehicles , and one can also get AI out of player driven vehicles , but there is this bizarre side-effect of them not being able to get back into the same vehicle afterwards.
This new bug displays the same characteristics as the bug originally described here in that it can be fixed by the player driving the vehicle leaving said vehicle.

Updated by kju almost 5 years ago

  • Due date changed from 10/14/2010 to 12/01/2010
  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • % Done changed from 0 to 80
  • Affected ArmA II version changed from 1.05 BETA to 1.55 BETA
  • I am using set to CO (A2+OA)
  • Reproducible for you changed from No to Yes

thanks. hopefully BI can sort the new issue related to it.

Updated by kju over 4 years ago

  • Due date deleted (12/01/2010)
  • Status changed from Assigned to Closed
  • Target version set to 1.55 BETA

[74952] Fixed: Subordinates would ignore their leaders' GetIn/GetOut commands in some MP situations.

Happy to report that the initial report and the update from looz work fine
for me with the latest beta (client + server).

AI does get in and out and so forth as expected.

Updated by kju over 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Also available in: Atom PDF