Bug #17145

ATOC smudge effect on tree LoD

Added by Fireball about 4 years ago. Updated about 3 years ago.

Status:Closed Start date:01/30/2011
Priority:Normal Due date:04/30/2011
Assignee:Dwarden % Done:

0%

Category:Rendering
Target version:1.60.87580
Affected ArmA II version:1.58 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

The default ATOC level 7 gives me a smudging effect on higher LoDs of trees in Takistan, making them look like very low quality:

zoomed, same position

arma2oa_2011-01-30_03-16-00-32.jpg - unzoomed (195.7 kB) Fireball, 01/30/2011 16:28

arma2oa_2011-01-30_03-16-02-64_cr.jpg - zoomed, same position (174.5 kB) Fireball, 01/30/2011 16:28

arma2oa_2011-02-07_00-51-09-32.jpg (247.4 kB) Pauliesss, 02/06/2011 23:56

arma2oa_2011-02-07_00-51-03-28.jpg (214.1 kB) Pauliesss, 02/06/2011 23:56

arma2oa_2011_02_09_21_34_41_849.jpg (1.4 MB) Empath, 02/10/2011 17:15

arma2oa_2011_02_10_14_35_11_854.jpg (1.1 MB) Empath, 02/10/2011 17:15

arma2oa_2011_02_10_14_35_18_079.jpg (1.3 MB) Empath, 02/10/2011 17:15

arma2oa_2011_02_10_14_35_26_556.jpg (1.5 MB) Empath, 02/10/2011 17:15

arma2oa_2011_02_10_18_11_50_552.jpg (774.5 kB) Empath, 02/10/2011 17:18


Related issues

duplicated by ARMA2 Community Issue Tracker - Bug #17701: Graphical LOD issues on ATI 6870 11.1/11.2 drivers Duplicate 02/17/2011

History

Updated by Sickboy about 4 years ago

Can also repro, hd6950 flashed to 6970.

Updated by Fireball about 4 years ago

  • Reproduced by another DH user changed from No to Yes

Specific to ATI only? Any Nvidia user?

Updated by Lester about 4 years ago

Not so much extreme, but also an 'oil-painted' effect on Plants, especially on LODs after the first
All on a NVidia GTX295 !

Updated by Pauliesss about 4 years ago

Yes, it sometimes happen to me too. Nvidia GTX580, newest WHQL drivers.

Updated by Pauliesss about 4 years ago

I thought this problem will be solved by changing ATOC from 7 to 0, but its still there. There is also noticeable performance decrese for few seconds when aiming with scope(for example with USMC Designated Marksman). Try to aim to area with high density of trees and bushes. You should see LOD changing and very noticeable FPS drop. I have this FPS drop when aiming to such areas, with GTX580 and so I dont think its because of slow HW.

PP effects disabled, terrain on normal, shadows on normal, AA on normal and everything else very high. VD is 2011m.

Updated by Empath about 4 years ago

same to me. Here are the pics.
Using ARMA2_OA_Build_77819
I7-4Ghz HT-Off
GTX-580 / 12GB
Win7-64 / SSD

Updated by Empath about 4 years ago

Settings:
Resolution_W=1920;
Resolution_H=1200;
refresh=60;
FSAA=4;
postFX=0;
GPU_MaxFramesAhead=1000;
GPU_DetectedFramesAhead=3;
HDRPrecision=32;
vsync=0;
AToC=7;

Nvidia Driver : 266.58
AF: app controlled
AA: app controlled
Multisample
Max Render Frames : 3
Vsync: on

Updated by Fireball over 3 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.60.87580
  • I am using deleted (CO (A2+OA))

Latest ATI/AMD drivers seem to have resolved this issue, so I can use AtoC=6 (which resolves the grass moiree/raster effect, opposed to 7).

Updated by kju about 3 years ago

  • Status changed from Resolved to Closed

Updated by Fireball about 3 years ago

I actually resorted to AtoC=2 because on ATI cards the Chernarus trees still look fugly.

Also available in: Atom PDF