Bug #1707

Collision problem: Tanks jump and at times fly high into the sky when hitting stone objects.

Added by mr.g-c almost 6 years ago. Updated over 3 years ago.

Status:Closed Start date:06/01/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Movement
Target version:1.55.75445
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

The video shows a tank jumping over a stone and a tree at distance.

Repro:
1) play the attached mission in editor.
2) Notice the tank skyrocket.

3 )There is another unit you can teamswitch to, placed near the tanks start position.
4) You can see that if the scene is seen from this 2nd unit position, the problem doesn't happen.

Another YT Video: Tank apparently placed on Stone before start
http://www.youtube.com/watch?v=9EWa7v3voJ4&feature=related&fmt=18

Edit: alef: YT video of the attached

CIT_1707.utes.7z - mission (882 Bytes) alef, 06/11/2009 12:53

CIT_1707.mp4 - video from player position (696 kB) alef, 06/11/2009 12:53

tank.png (168.8 kB) alef, 06/11/2009 12:53

CO_1707.Takistan.zip - press Num+ to zoom in (1.1 kB) alef, 07/13/2010 20:08


Related issues

related to ARMA2 Community Issue Tracker - Bug #4687: Mi-24 common geometry bug Closed 09/20/2009 12/10/2010
related to ARMA2 Community Issue Tracker - Bug #12043: [AO] Characters and vehicles stick to rocks Closed 07/16/2010
related to ARMA2 Community Issue Tracker - Bug #1829: Can't run over infantry Closed 06/05/2009
related to ARMA2 Community Issue Tracker - Bug #3238: Tank collisions physics broken Assigned 08/01/2009 03/01/2011
related to ARMA2 Community Issue Tracker - Bug #5114: Tank drives over a civilian car without cracking its windows Assigned 10/12/2009 09/14/2011
related to ARMA2 Community Issue Tracker - Bug #3988: Jumping aircraft wrecks Expired 08/25/2009
duplicated by ARMA2 Community Issue Tracker - Bug #4297: Tanks Flip Duplicate 09/06/2009
duplicated by ARMA2 Community Issue Tracker - Bug #2513: Hitting a rock can up-end a tank Duplicate 07/03/2009
duplicated by ARMA2 Community Issue Tracker - Bug #3751: Tanks jumping on stones Duplicate 08/18/2009
duplicated by ARMA2 Community Issue Tracker - Bug #6310: Physics enhancement - Vehicles jumping high - Regdoll fea... Duplicate 11/27/2009

History

Updated by Skeptic almost 6 years ago

Saw T-72 jumping through the air while it was trying to drive through the building. MP game tonight.

Updated by MadDogX almost 6 years ago

Is this problem limited to MP only? I haven't been playing much MP yet and there's been no sign of flying tanks in SP.

Updated by fabrizioT almost 6 years ago

Can confirm the issue (v 1.01 beta), i've noticed it in SP campaign.

Updated by mr.g-c almost 6 years ago

MadDogX, nope i only noticed this in SP so far.

Updated by zGuba almost 6 years ago

I believe it's model geometry related issue. Slighlty increased track component mass decreased such effect in ARMA I.

Updated by rusty almost 6 years ago

confirm. One tank (far in the distance but clearly visible) flying high into the sky, after it fired a shot I presume.
Observed in MP.

Updated by alef almost 6 years ago

  • Due date set to 06/25/2009
  • Status changed from New to Feedback
  • Assignee set to alef

Should be a problem in the collision detection. CD avoids that two object doesn't penetrate each oter. Like a tank and a stone.
If someone put in the editor a tank over a stone, the CD starts with two object overlapping part of the same space. How to solve this? Maybe the RV engine set a force vector with magnitude inverse to the distances between the center of masses. If this is the cause, could be a problem with terrain streaming, where ground details like stones may appears underneath tanks as player position changes? Or with a wrong LOD for collision geometry.

Repro steps for this should include different vehicle (tank) locality. Dedi server too.

Updated by alef almost 6 years ago

This repro is for SP only. The video shows a tank jumping over a stone and a tree at distance.
There is another unit you can teamswitch to, pleaced near the tanks start position. You can see that if the scene is seen from this 2nd unit position, the problem doesn't happen.

Updated by kju almost 6 years ago

  • Assignee deleted (Suma)

Updated by alef almost 6 years ago

  • Due date changed from 06/25/2009 to 09/14/2009
  • Status changed from Feedback to Assigned

Updated by kju almost 6 years ago

Very good report now thanks to alef!

Everyone should take this as an example of a useful report.

Updated by alef almost 6 years ago

  • Affected ArmA II version changed from 1.01.57751 to 1.02.58064

Updated by kju almost 6 years ago

  • Subject changed from AI Tanks still jump and fly high into the sky to Collision problem: Tanks jump and fly high into the sky when hitting stone objects.

Updated by kju almost 6 years ago

  • Subject changed from Collision problem: Tanks jump and fly high into the sky when hitting stone objects. to Collision problem: Tanks jump and at times fly high into the sky when hitting stone objects.

Updated by zGuba over 5 years ago

  • Category set to Model

Properly created Geometry LOD should defeat this bug.

Check this Bradley: http://www.armedassault.info/index.php?game=1&cat=news&id=2678 it works good at least for ArmA 1.

Updated by Fireball over 5 years ago

  • Due date changed from 09/14/2009 to 08/17/2009
  • Affected ArmA II version changed from 1.02.58064 to 1.02.58134
  • Maxmem parameter deleted (Not set)

Updated by Fireball over 5 years ago

  • Due date changed from 08/17/2009 to 09/17/2009
  • Affected ArmA II version changed from 1.02.58134 to 1.03.58627

I still see this happening.

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by zGuba over 5 years ago

  • Due date changed from 09/17/2009 to 10/20/2009
  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026

Updated by Fireball over 5 years ago

  • Due date changed from 10/20/2009 to 12/20/2009
  • Reproduced by another DH user set to Yes

Updated by kju almost 5 years ago

  • Due date changed from 12/20/2009 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Still valid in 1.07 / OA?

Updated by kju over 4 years ago

  • Due date changed from 07/14/2010 to 08/01/2010

Can we get a (set of) demo mission(s) for OA please.
I am pretty sure it is still in.

Updated by alef over 4 years ago

  • File CO_1707.Takistan.zip added
  • Category changed from Model to Movement
  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • Affected ArmA II version changed from 1.05.62017 to 1.53 BETA
  • I am using some Mods set to No

Here a repro for Takistan. This uses camera.sqs and show real time info on the tank jumping around.
If you come near with the camera, the error doesn't happen.

Updated by kju over 4 years ago

tx

one of the most annoying issues for vehicles :(

Updated by alef over 4 years ago

  • Due date changed from 08/01/2010 to 10/27/2010

As by the reason in #2490, please test this again at next beta.

Updated by Suma over 4 years ago

Fixed in 74856

Simplified collision detection, which was causing this, is no longer used. The complex version was optimized meanwhile, therefore using the simplified one had very little effect anyway.

Updated by kju over 4 years ago

  • Due date deleted (10/27/2010)
  • Status changed from Assigned to Resolved
  • Target version set to Upcoming version
  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA

Great news :)

Updated by Xeno over 4 years ago

  • Target version deleted (Upcoming version)

Wow, nice!
Thank you.

Updated by Sickboy over 4 years ago

  • Target version set to Upcoming version

Updated by kju over 4 years ago

  • Target version changed from Upcoming version to 1.55 BETA

Updated by kju over 4 years ago

  • Status changed from Resolved to Closed

Confirm working. Excellent job!

Updated by kju over 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Updated by kju about 4 years ago

a) Community tank model => might be buggy model.
b) Missing demo mission with repro steps.
c) Ticket is closed - create a new one with all required info and without community addons.

Updated by silvercanary about 4 years ago

Hmmm. That is a warrior 2 from the BAF pack in lo-res texture and the map was chernarus. I was using the XRIP (map pack), XRSM (sound mod) and XROPTICS (thermal weapon mod) mod packs none of which i feel would have caused the problem with the warrior, and many other armoured vehicles too. This doesnt happen with wheeled vehicles because they usually just burst a tire or set on fire.

After the fix done a couple of months ago the flying tank situation was a ton better like 90% whereby tanks only now fly 5 m in the air as opposed to 50m before the fixes. I will try to repro this without any mod packs but i seriously doubt that they have caused this.

Updated by kju about 4 years ago

Yep the tank model is not from BI.

Also read b and c..

Also available in: Atom PDF