Bug #16993

M203 smoke grenades have localization issue, don't appear on right location

Added by eViLsTieFel over 4 years ago. Updated over 3 years ago.

Status:Closed Start date:01/26/2011
Priority:Normal Due date:
Assignee:q1184 % Done:

100%

Category:Script
Target version:1.13
Component: Affected Version:
Close Reason:

Description

When firing grenades with the M203 launcher, the grenades appear on another location depending if you are firing the grenades or are any other player on the server (which see the grenade land on exactly the same location). This makes grenades useless for marking enemies or CAS locations, as
a) the firing party believes everybody else sees the marker on target
b) everybody else thinks the firing party is crazy or does not get what's supposed to be marked

Hand smoke grenades work fine, as do M203 HEDP grenades.

I attached a video that illustrates the point and also show the huge gap between where the grenade is seen locally and for everybody else.

smokebug.mp4 (6.8 MB) eViLsTieFel, 01/26/2011 21:10

ace_sys_grenades.pbo (8.6 kB) Sickboy, 01/27/2011 07:08


Related issues

duplicated by A.C.E. for OA - Bug #24351: M203 Smoke range adjustment Duplicate 09/09/2011

History

Updated by tyrspawn over 4 years ago

This is a major bug. I have noticed this several times, one time on my screen I fired a 203 about 450 meters away to mark a target for CAS. Then the A-10 nearly blew me up and those around me because the smoke on other people's screen was directly in front of us.

Updated by Sickboy over 4 years ago

  • File ace_sys_grenades.pbo added
  • Category set to Script
  • Status changed from New to In progress
  • Assignee set to rocko
  • Target version set to 1.9

Please retry with this fixed PBO.

Updated by rocko over 4 years ago

  • % Done changed from 0 to 50

Updated by eViLsTieFel over 4 years ago

Sickboy wrote:

Please retry with this fixed PBO.

Unfortunatelly this does not change anything.

Updated by q1184 over 4 years ago

Might be because GL sight adjustment script uses a local fired EH, which is sufficient for the grenade simulation (turning it on the firing machine will turn it everywhere else), while smoke gren. simulation does not sync direction automatically, and requires setting the new direction on every machine.
If this is the case, setting GL sight to the initial zero (usually 150 m) before firing smoke grenades might be a temporary measure.

Updated by Sickboy over 4 years ago

  • Status changed from In progress to Feedback

Can you reproduce the issue with the sight adjustment addons removed?

Updated by Tasel over 4 years ago

Sickboy wrote:

Can you reproduce the issue with the sight adjustment addons removed?

We tested it again with a couple of grenades. The first one was on different locations (don't know what was wrong with this one) but the others were all at the same location.

Updated by rocko over 4 years ago

  • Target version changed from 1.9 to 1.10

The GL adjustment is disabled when smokeshells are fired for now until a better solution is in place.

Updated by rocko over 4 years ago

  • Status changed from Feedback to In progress

Updated by rocko over 4 years ago

  • Assignee deleted (rocko)
  • Target version changed from 1.10 to 395

Updated by rocko almost 4 years ago

  • Assignee set to q1184

Updated by rocko almost 4 years ago

  • Target version changed from 395 to Arma 3

Updated by rocko almost 4 years ago

  • Target version changed from Arma 3 to 1.13

Updated by Sickboy over 3 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 50 to 100

Probably resolved by disabling the grenades sim addon for the time being. If still issues, reopen after next update (RC5).

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Available in the about to be released ACE for OA 1.13 RC5.

Also available in: Atom PDF