Bug #16981

FSM does not work when it is packed into pbo by Eliteness

Added by test about 4 years ago. Updated over 3 years ago.

Status:Closed Start date:01/26/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Affected Version:

Description

FSM does not work in arma 2 when it is packed into pbo by Eliteness. If FSM was packed into pbo by BinPbo then it works perfectly

hint.pbo - by Eliteness (2.2 kB) test, 01/26/2011 17:47

hint.pbo - by BinPbo (2.2 kB) test, 01/26/2011 17:47

fsm_initialized.png (3.4 MB) Sickboy, 01/26/2011 18:01

hint.pbo - by Eliteness (1.3 kB) test, 01/26/2011 18:05

eliteness-settings.png (31.7 kB) Sickboy, 01/26/2011 18:25

History

Updated by Sickboy about 4 years ago

We use Mikero's PBO Tools with ACE and FSM's and anything else works just fine.
Perhaps you can supply the exact errors, problems, rpt messages etc?

Do you set the PBOPrefix properly?

Updated by test about 4 years ago

No .rpt messages or indications of FSM and other errors. Simply it did not start when I use Eliteness instead BinPbo

Updated by kju about 4 years ago

Please attach the said pbo here.

Updated by test about 4 years ago

Instruction:
Set in game editor a man and start game. FSM must be started ("FSM is initialized" hint is appeared on display)

Updated by Sickboy about 4 years ago

With either PBO.

The PBO's are btw equal.

Updated by test about 4 years ago

Oh, I am sorry. It was both pbo from BinPbo

Updated by Sickboy about 4 years ago

test wrote:

Oh, I am sorry. It was both pbo from BinPbo

I can reproduce the issue with your PBO, however when I unpack that PBO, and then repack it with makePbo, it works fine.
What version of the dll, and applications do you use?
Perhaps it is a problem with eliteness, I have not tried that yet. Can you reproduce it with makePBO?

C:\Temp>makepbo -A hint
makepbo Version 1.75, Dll 3.31 hint
Building entries..
Using $PBOPREFIX$
Creating ArmA style pbo:
Prefix = hint
config.bin
hint.fsm
..
Writing sha key

No error(s)

Updated by Sickboy about 4 years ago

Eliteness 2.82 for me doesn't even output a PBO file.. Select folder, make pbo, ... no pbo.
Ah but you can fix that by un-ticking in options 'output directory' ;-)

Both PBO's I created (eliteness and makepbo) work. Perhaps it's settings or dll/exe version related.
I notice that your hint.pbo (which doesn't work) is smaller.
Yours; 1.283 bytes
Mine; 2.292 bytes
BinPBO; 2.275 byte

Did you enable compression by chance? If that is the case, afaik support for compressed addons has been removed/deprecated since arma1 or 2.

Updated by Sickboy about 4 years ago

Updated by test about 4 years ago

I think problem appears because of "compress files" checkbox is enabled. Sickboy forestalled me

Updated by Sickboy about 4 years ago

Cool! Glad we got the root of the problem :-)
Would be better if arma would warn the user about unsupported (compression) file format :)

Updated by mikero about 4 years ago

compression errors would be news to me. I have no hard info on this. Last 'official' report on lack of compression support was during beta development of arma1 where a croc excuse was made about 'terrain streaming'. turned out to be nonsense. The engine still supports lzss compression for all files. Bis mistakenly identify this type of comression in-house as LZH (i think).

To date, I have never, ever, seen an official bis addon in a1 a2 or oa that uses lzss. that much is true. That said, it is 'quite common' to see missions produced by bis employees WITH compression, which, I understand is because those employees use old, amalfi tools or others from ofp to edit or create their pbos

CWR2 uses lzss compresssion on ALL it's files. Dozens of pbos are involved, we are not aware of any issues.

Again, that said, no-one, afaik, has tested fsm files treated in this manner and it could well be one of the wrinkles we dont know about, until now.

Updated by mikero almost 4 years ago

subsequent to last statement, i have discovered some pac/paa which the engine hates being lzss compressed
the latest dll now wont compress pax files for arma

will ammend the dll to not compress fsm files at the next revision

Updated by mikero over 3 years ago

  • Status changed from New to Closed

fixed at dll 3.69

Also available in: Atom PDF