Bug #16872

AI doesn't shoot or flee when careless

Added by BlackRussian almost 5 years ago. Updated almost 5 years ago.

Status:Rejected Start date:01/22/2011
Priority:Normal Due date:
Assignee:- % Done:


Category:AI Issues
Target version:-
Affected ArmA II version:1.58 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:


I have played the campaign mission Manhattan lately and there is (still) one huge problem which makes the mission much easier and weird.

I usually use the LAV-25 to drive around the island and when attacking the Chedaki sentry posts they do nothing. I can run them over while they are just laying on the ground (and I need several tries until I have all).

Even worse the one AT soldier doesn't shoot at met, at least not in the first 20 seconds or so. Sometimes he changes to the RPG but doesn't shoot even if I miss them on the first run. I have tried to create a editor mission with the same behavior but was not successful until I set the AI to careless.
Maybe it is on purpose but it makes the mission absolutely unrealistic and let the ai look more stupid than it is imho.

And of course it is a bug that the AI doesn't switch from careless back if they are attacked or an enemy is nearby.

So I don't know what exactly the problem of the Chedaki sentry posts AI in Manhattan is because I don't know how to extract the mission but please check it out.

So basically I am reporting two bugs here:

1. The AI should attack in every mode if they are attacked or run over by a vehicle. (Please also check what the exact setting of the AI sentry posts soldiers are in Manhattan. It wasn't careless because they laid down while I was approaching.
2. If the AI is unable to attack the vehicle they should run and in the best case they should run in different direction if this is easily possible with the engine. (Btw in this case the AI would even be able to fight back without an AT soldier because they could attack the wheels but I am creating another report for that)

AiDoesntRunWhenCareless.Chernarus.7z (900 Bytes) BlackRussian, 01/22/2011 09:10


Updated by kju almost 5 years ago

  • Due date set to 02/01/2011
  • Status changed from New to Feedback
  • Target version deleted (1.58 BETA)

Sorry cannot follow your argument here.
Careless mode is made to show this behavior after all.

It is down to the mission designer to set or change the behavior.

Updated by BlackRussian almost 5 years ago

1. I don't know what exactly the problem in the Manhattan mission is but I have described it so everybody who has access to the sqm file of Manhattan should be able to check what is wrong. The careless behavior is just similar to it except of some little differences.
2. Imho careless means that you are careless (not watching around or paying attention) unless something happens that gathers your attention. If somebody tries to run you over or shoot at you you have to be really, really high to just stay their and wait for your near death. They should act similar to humans and not lemmings. Even animals have a survival instinct. :)

Updated by Krycek almost 5 years ago

Careless is what it says,you want different behaviours use aware,combat,stealth or safe for different results.Besides that it functions very well,recently I tested an friendly AI chopper engaging an T72 (tank set to careless) and the T72 opened fire on the chopper.This on 1.57.

Updated by kju almost 5 years ago

BlackRussian I think you are more about a mission specific problem rather than anything wrong
with careless behavior.

Manhatten tends to cause very low FPS for most people. This may be the actual reason
seeing the lack of AI reaction / bad AI behavior.

Updated by BlackRussian almost 5 years ago

This might be it but I still think that careless shouldn't make the soldiers suicidal. Or maybe the AI sees running them over with a car not as a death threat.

Updated by kju almost 5 years ago

AI was never trying to avoid vehicles running them over from what I know.

Updated by BlackRussian almost 5 years ago

I thought so too but they seem to run in my mission (sometimes?!) at least when they are in a standard mode. This might be a random behavior but it looked cool. If they would also spread in different directions it would be perfect. :)

Updated by maturin almost 5 years ago

I can verify that units given Careless Move waypoints in the editor will often ignore enemy fire that's killing their men.

Updated by BlackRussian almost 5 years ago

It seems careless is a special option to prevent enemies attacking the player or its group. But if they are attacked by them the should shoot back imho.

Updated by kju almost 5 years ago

Safe mode is doing exactly what you want.
It is careless mode with AI reacting to enemy fire.


Updated by Suma almost 5 years ago

  • Status changed from Feedback to Rejected

This is by design. The careless behaviour is here so that mission designers can create units which do not respond to any danger no matter whatm, even if this shows suicidal.

Updated by kju almost 5 years ago

  • Due date deleted (02/01/2011)

Also available in: Atom PDF