Bug #1672

Changing fill rate in game menu results in freezes

Added by Skeptic over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:05/31/2009
Priority:Normal Due date:07/04/2009
Assignee:- % Done:

0%

Category:Performance breakdown
Target version:1.02.58064
Affected ArmA II version:1.01.57751 First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

This is very annoying - even slightest touch of the slider freezes game for a second. It also should move in notches like may be with 25% increments.


Related issues

related to ARMA2 Community Issue Tracker - Bug #1671: Fill rate set to 100% in game does not equal screen resol... Closed 05/31/2009

History

Updated by alef over 5 years ago

  • Due date set to 09/14/2009
  • Status changed from New to Assigned

Updated by Fireball over 5 years ago

Confirmed, for a friend it even locked up the game for minutes and he had to kill the process, because it caused some kind of refresh/reload loop.

Updated by Maddmatt over 5 years ago

The game is effectively changing resolution. I doubt anything can be done about the short freezes.

Updated by kju over 5 years ago

You misread the issue here IMO.

He is suggesting that the slider only does 25-50 steps and ONLY
changes once the slider is at the next threshold.

Updated by Skeptic over 5 years ago

Hi kju,

I think Maddmatt got it right - when you change fillrate you experience short freezes. That should be addressed.
Secondly I propose to implement steps that correlate to MSAA 2x, 4x and 8x. If I'm not mistaken those would correspond to 125%, 133%, 150% and 200%. There is no need to be able to set 1% increments.

Regards,
- Skeptic.

Updated by kju over 5 years ago

  • Category changed from Config to Performance breakdown
  • Status changed from Assigned to Feedback

According to the BI devs the values are rounded to valid values by the engine.
So the actual Render_ vs Resolution_ variables are not taken as it is,
yet rounded to 1/1, 1/3 etc.

What we need here is:

a) Screenshots/videos should the visual artifacts.
b) Proper FPS comparison of perfect 100% fillrate vs 95% etc.

Otherwise no meaningful checking of a potential problem is possible.

The ArmA mark 2 mission might be a start to record FPS.
Fraps or perfect repeating scenario using 1 diag_fps, diag_fpsmin and diag_frameno
is way better though.

Updated by alef over 5 years ago

  • Due date changed from 09/14/2009 to 07/04/2009
  • Status changed from Feedback to Resolved
  • Assignee set to Skeptic
  • Target version set to 1.02.58064

1.02 has the "3D resolution" list instead of a slider.

Updated by kju over 5 years ago

Nice. :-)

Thanks for the input lads!

Updated by Skeptic over 5 years ago

OK, with new 3d option it works much smoother now - pause only fraction of a second when you set it. Tested on 1.02 hotfix. Cheers.

Updated by kju over 5 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Skeptic)

gj

Also available in: Atom PDF