Feature #16673

Reduce the default thermal intensity for vehicles without a heatmap.

Added by defunkt about 4 years ago. Updated about 3 years ago.

Status:Closed Start date:01/12/2011
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:Rendering
Target version:1.60.87580
Affected ArmA II version: First affected ArmA II version:
Reproduced by another DH user:No Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using: NGUrl:
Reproducible for you:Yes WIKIurl:
Related to content of DLC:

Description

One of the things that really exacerbates the difference between models with a detailed OA heatmap and those older items which don't (at least don't yet) is that the fallback texture is so bright white all over when 'on'. I feel if this was toned down to half its current intensity the older units wouldn't stick out nearly so badly when viewed through TI. Units with a proper heatmap warm up in patches yielding an overall mid-tone intensity where the all-white all-over fallback is just way too visible.

current.jpg - Current 'Hot' Intensity (49.1 kB) defunkt, 01/12/2011 22:51

proposed.jpg - Proposed 'Hot' Intensity (45.1 kB) defunkt, 01/12/2011 22:51

16673.Desert_E.7z (1.4 kB) kju, 11/08/2011 19:36

picture006.jpg (49.3 kB) kju, 11/08/2011 19:36

picture001.jpg (35.8 kB) kju, 11/08/2011 19:36

picture002.jpg (34 kB) kju, 11/08/2011 19:36

picture003.jpg (34.4 kB) kju, 11/08/2011 19:36

picture004.jpg (51.4 kB) kju, 11/08/2011 19:36

picture005.jpg (50.1 kB) kju, 11/08/2011 19:36

picture001.jpg (38.9 kB) kju, 11/09/2011 19:11

picture002.jpg (38.2 kB) kju, 11/09/2011 19:11

weirdTIFlashing.Chernarus.rar (1.2 kB) kraze, 11/10/2011 11:35

picture001.jpg (42 kB) kju, 11/10/2011 12:19


Related issues

related to ARMA2 Community Issue Tracker - Bug #14276: Z-fighting reappears when player is close to objects Assigned 10/09/2010

History

Updated by Fireball about 4 years ago

  • Category set to Rendering
  • Status changed from New to Assigned
  • Affected ArmA II version deleted (1.58 BETA)

Updated by kju over 3 years ago

Repro provided. Contains US (EP1) vs RU vehicles and infantry.

Updated by kju over 3 years ago

Updated by kotov over 3 years ago

check how they should looks like
http://www.x20.org/thermal/FLIR.htm

Updated by Suma over 3 years ago

Should be improved a lot in 86217

Two fallback textures exist now:

human: 0.8,0.05,0.05,0.35
other: 0.8,0.30,0.20,0.05

Updated by kju over 3 years ago

  • Target version set to Upcoming version

Updated by OMAC over 3 years ago

Confirmed that defunkt's proposed change has been implemented perfectly in 86218. Fallback texture brightness has been scaled back by about 50%. Looks real good.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Marking as Resolved, unless anything bas happens, it may perhaps go to Closed soon.

Updated by kju over 3 years ago

well done

Updated by kraze over 3 years ago

I still see ArmA2 soldiers being perfectly white in 86233
Except that I also have a problem with TI now - I get weird flashing and/or corrupt textures on buildings - this is not the case in 1.59 stable

GTX260 with 285.62 drivers here

Repro mission attached - I get the corruption while looking at that village in front through TI optics (also perfectly white rebels are seen too)

Also try walking a bit backwards and the church will become pitch black in TI but if you'll zoom in (+) it starts looking OK again. When I walk backwards slowly looking through optics more and more objects start flashing - here how it looks for me: http://i39.tinypic.com/t7jq75.jpg

Updated by kju over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

OA soldiers at distance are also that white.
Seems more like a general issue with FLIR.

Also HDR (the sun) influences FLIR and probably causes your flicker - notice the tree branch on your pic.

Other than that there is a lot of z-fighting in your mission.
Unfortunately the fix for it was (partially) broken again shortly after the implementation
(when standing near to objects or laying on the floor). See: #14276

Updated by kju over 3 years ago

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF