Bug #16568

Kh-29L: The AI won't engage

Added by stubs about 4 years ago. Updated about 4 years ago.

Status:Rejected Start date:01/09/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:By design/Not a Bug

Description

I figured this is an already known issue, but the AI won't engage with the Kh-29L.

Results:
Place any Russian plane with the Kh-29L on the map along with a Western or Resistance tank within engagment range.
The plane will engage the tank with it's AA missles.

Expected:
The plane engages the tank with the Kh-29L in its arsenal.

Addons used:
ACE: 452
ACEX: 304
ACEX_SM: 78
ACEX_RU: 31
ACEX_USNAVY: 29

Thanks, Stubs.

History

Updated by VKing about 4 years ago

The Kh-29 is only able to target laser targets, not other vehicles. That means the ai will only fire at other's laser targets as it doesn't know how to use the buildt-in laser designator.

Updated by stubs about 4 years ago

Yeah, I figured that was the problem. Thanks.

Updated by stubs about 4 years ago

Perhaps some perameter could be added where the jet with these missles switches the FCS system when no players are aboard the plane or only when it is purely crewed by the AI.

Updated by rocko about 4 years ago

  • Status changed from New to Rejected
  • Close Reason set to By design/Not a Bug

Also available in: Atom PDF