Bug #16362

Boot Camp 01: Basic Training - MOUT Saber team attacks too early if player is doing Anti-Tank range first

Added by Maetryx almost 5 years ago. Updated almost 4 years ago.

Status:Closed Start date:01/01/2011
Priority:Normal Due date:
Assignee:- % Done:


Target version:1.11.86734
Affected ArmA II version:1.60 BETA First affected build:71612
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:SP Only
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:


Twice, while trying to complete Basic Training in Boot Camp, I have done all of the objectives (obstacle course, first aid, shooting range, driving) and then drove to Shaftoe. Shaftoe tells me to blow up tanks, so I do that with each different weapon. Then he asks what I want to do now? And only MOUT is left. But the MOUT soldiers (Saber team, Shaftoe calls them) have come out of the MOUT area and are attacking me at the tank range, before I can even get ammo out of the crates for my M16!. One time, they attacked me before I even selected MOUT. Once they shot Shaftoe and my Basic Training ended in failure.

Reproduce 1
  1. Choose Boot Camp
  2. Choose 01: Basic Training
  3. Just walk near Anti-Tank range and make some noise there or straight to MOUT area and get immediately shot by Saber team
  1. Saber team acting as enemies will start to move from village when you fire the first rocket (because they hear noise)
  2. About the time you get rifle from US Basic Weapons crates, you hear them fire at you
  3. They will also kill Shaftoe if they see him (Shaftoe can be protected by parking vehicle to shield him and luring "enemies" to stay away from that direction)
  1. Saber team should not kill Shaftoe because he is their training instructor too.
  2. Saber team should know when training should start and not be in full alert all the time (ie. Trigger).
  3. Saber team should be placed more faraway close to the sea so they would not hear Anti-Tank range noise and come to inspect that.
  4. 1 Anti-Tank range and 2 MOUT should switch places (1 MOUT and 2 Anti-tank range) so players would understand to do MOUT always first.
  1. To do MOUT first
  2. Protect Shaftoe with vehicle and to get Anti-Tank weapons one by one and go to west to use them from there (that did not alarm them for me)


Updated by Fireball almost 5 years ago

  • Due date set to 04/01/2011
  • Status changed from New to Assigned
  • Affected ArmA II version changed from 1.52.71612 STEAM to 1.57.76815

You set affected version to 1.52, but I assume your Steam version is in fact 1.57, right (you see this in the main menu in-game)?

We don't make a difference between Steam and Non-Steam anymore in versions, since they're essentially the same, only that specific 1.52 was a version unique to Steam, thus the keyword remained in there.

Updated by Hanzu about 4 years ago

  • Subject changed from MOUT AI in Basic Training - computer sent Saber to attack me at AT range to Boot Camp 01: Basic Training - MOUT Saber team attacks too early if player is doing Anti-Tank range first
  • Description updated (diff)
  • Due date changed from 04/01/2011 to 12/29/2011
  • Operating system deleted (Win7 64 bit)
  • Graphics card deleted (AMD 5870)
  • Graphics card driver version deleted (10.12)
  • Affected ArmA II version changed from 1.57.76815 to 1.60 BETA
  • Maxmem parameter deleted (Not set)
  • Difficulty deleted (Recruit)
  • Reproduced by another DH user changed from No to Yes
  • CPU deleted (core i7 860)
  • Mainboard chipset deleted (Intel P55)
  • System RAM size deleted (8196)
  • GPU VRAM size deleted (1024)
  • Audio card deleted (integrated)
  • Size of OS swap file deleted (8183)
  • Language set to English
  • First affected build set to 71612

Updated by Sickboy about 4 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Upcoming version

Updated by Sickboy about 4 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Hanzu about 4 years ago

  • BIForumURL (Use new instead) set to http://forums.bistudio.com/showpost.php?p=2029928&postcount=12
  • Single / Multi Player? set to SP Only

Updated by Hanzu almost 4 years ago

  • Due date deleted (12/29/2011)
  • Status changed from Resolved to Closed

Tested with CO 1.60.76705 to be successfully fixed in ARMA 2 beta 1.11.86688.
Not sure how Jezuro changed this, but fix works since MOUT Sabre team did not attack me anymore no matter how noisy and loud I was in Anti-tank range. I played on Expert difficulty meaning they should be as aware as possible.

Thank you BIS!

Updated by Hanzu almost 4 years ago

  • Target version changed from 1.60 BETA to 1.11 BETA

Updated by kju almost 4 years ago

  • Target version changed from 1.11 BETA to 1.11.86734

Also available in: Atom PDF