Bug #1630

Bullet Impacts non visible at distance

Added by mr.g-c over 6 years ago. Updated about 5 years ago.

Status:Expired Start date:05/30/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Visual
Target version:-
Affected ArmA II version:1.05.62017 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

This is some sort of bug for me, because i never know where my bullets are impacting.

The Impact Particle Effects must be altered to kick-out more dust at impact on ground and buildings. On top of that, this kicked-off Dust must be stay for a short while around (at best "blowed" with the wind) and should not disappear within fractions of a second like currently.

Simply watch some Videos at Youtube/etc. from recent conflicts or else to get some ideas.

History

Updated by alef about 6 years ago

  • Status changed from New to Feedback
  • Assignee set to mr.g-c
  • Affected ArmA II version set to 1.01.57751

I've tried firing with an M107 with 1000m viedistance and see the impact dust at 800m. Shall I try another weapon?

Updated by alef about 6 years ago

  • Tracker changed from Bug to Feature

Updated by alef about 6 years ago

  • Due date set to 06/27/2009

Updated by mr.g-c about 6 years ago

Im talking bullet impact from non-scoped rifles! Of course you can see impacts with a scoped rifle rolleys
As soon as you shoot further than like 100m away you can't see any impact points anymore. This is unrealistic/improper made and therefor clearly a bug and not a feature.
Even in Arma1 without ArmaEffects Mod you could spot them way better.

Updated by alef about 6 years ago

  • Tracker changed from Feature to Bug

Updated by alef about 6 years ago

  • Due date changed from 06/27/2009 to 07/15/2009

Please confirm it's still the same in 1.02.58134 and we can assign it.

Updated by mr.g-c about 6 years ago

alef wrote:

Please confirm it's still the same in 1.02.58134 and we can assign it.

Yes its still there.
Bis just needs to make the most impacts bigger and longer lasting (blow with the wind and dissolve in 5 -10 seconds). MaddMatt did it just great in ArmaEffects to what was possible in the A1 Engine.

Updated by alef about 6 years ago

  • Due date changed from 07/15/2009 to 10/01/2009
  • Status changed from Feedback to Assigned
  • Assignee deleted (mr.g-c)
  • Affected ArmA II version changed from 1.01.57751 to 1.02.58134

Updated by Squelch about 6 years ago

  • Category set to Visual
  • Status changed from Assigned to Resolved
  • Target version set to 1.03.58627

Impacts appear to be present at 300m and further now. Greater distances need testing on larger screen/better display.

Tested with M4A1

Updated by mr.g-c about 6 years ago

  • Status changed from Resolved to Feedback

Definately NOT resolved!
You still cant see them like they appear in RL over a certain distance (more than 200m).
The dust kicked is to small and way way to quickly dissapearing. I see no difference between 1.03 and previous versions.

Updated by Fireball almost 6 years ago

  • Status changed from Feedback to Assigned
  • Target version deleted (1.03.58627)
  • Affected ArmA II version changed from 1.02.58134 to 1.04.59026

Updated by Fireball almost 6 years ago

  • Due date changed from 10/01/2009 to 11/01/2009
  • Reproduced by another DH user set to No

Updated by Fireball almost 6 years ago

  • Due date deleted (11/01/2009)

Updated by zGuba almost 6 years ago

  • Due date set to 11/30/2009
  • Reproduced by another DH user changed from No to Yes

Updated by zGuba over 5 years ago

  • Due date changed from 11/30/2009 to 12/30/2009

Updated by mr.g-c over 5 years ago

Short Update:
The problem has become WORSE since Grass-Layer was introduced IMHO.
Now you can not at all see them anymore at distance.... Please BIS change this, look at how it was done in Mattmads Arma-Effects Mod for Arma1 - there you could see in 1000m distance when and WHERE your MG Rounds hit the ground.

It was caliber dependent in Arma1 (in size/ammount of impact dust) and the impacts were long-lasting (many seconds, compared to currently 0.5 seconds max. in Arma2).

Updated by kju over 5 years ago

  • Due date changed from 12/30/2009 to 12/31/2009
  • Status changed from Assigned to Feedback

mr.g-c you should first do a proper report here:

  1. demo mission
  2. repro steps
  3. screens
  4. your game configuration (arma2.cfg, arma2profile).

For my setup I can still see the impacts for non scoped weapons for ~500m+.

Without RMB zoom it would be impossible to see an impact at the distance.
With the crazy zoom, I have hard times seeing the impact as it is so far away.
So I see no problem having it disappear for more than 500m because, I am unable
to see that even with RMB zoom any longer anyway.

Updated by mr.g-c over 5 years ago

:-)
Wwhat repro mission should that be? Placing a soldier anywhere at any island at any given time and then as instructions something like "Shoot at the hill SW of your view?
I can make a comparision video of Arma1 -> Arma2 ???

Updated by kju over 5 years ago

Try to read my comment again.

It is not too long to stop after the first line.

Updated by alef over 5 years ago

  • Due date changed from 12/31/2009 to 01/22/2010
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017
  • CPU changed from Please specify! to n/a

mr.g-c wrote:

Wwhat repro mission should that be?

I would suggest Kronzky's target range . It gives you impact distance ("n/a" or high values in case of ricochet).

I can make a comparision video of Arma1 -> Arma2 ???

I think screenshots would be enough, with info about video settings, with or without Maddmatt's effects. The range is available for A1 and A2.

Updated by CarlGustaffa over 5 years ago

How much impact do you really see in real life? I mean, in the typical forest undergrowth surface in Chernarus with lots of grass, would there be much "dust"? Wouldn't the grass in front of the impact cover up most of the dust?

I apparently already voted, but now I vote yes for concrete buildings, sand and gravel. No to trees, wooden buildings and typical grass covered ground. :)
Shooting at relatively dry tree: http://www.youtube.com/watch?v=Y5KpjflzWCg
Another one, .50 cal: http://www.youtube.com/watch?v=gVoDaTv-sBw&NR=1

Frankly, I did expect more than I see, and this is quite close range. Personally I'm annoyed with it too at times, but when I think about it, it doesn't feel all that unnatural (most of the time). If you have the option, select tracer rounds to gauge needed offset (in wind, probably ACE only) if you have problems seeing impacts.

Updated by kju about 5 years ago

  • Due date deleted (01/22/2010)
  • Status changed from Feedback to Expired

Expired.

Feel free to reopen with proper repro steps, demo mission and visual evidence.
And some real life data / evidence to compare.

Also available in: Atom PDF