Bug #16298

M2 tripods will not engage BRDMs and BTRs. Kord and DShKM will.

Added by maturin over 4 years ago. Updated about 4 years ago.

Status:Closed Start date:12/28/2010
Priority:Low Due date:01/21/2011
Assignee:VKing % Done:

100%

Category:Config
Target version:1.9
Component: Affected Version:
Close Reason:

Description

As the titles says, despite the fact that the ACE armor system makes HMGs effective against light APCs such as the BRDM-2, BRT-60 and BTR-70, an M2 tripod controlled by an AI will not fire at them, even if ordered to. Static Kords and DShKMs of similar caliber will happily fire at these vehicles.

Also, the Kord minitripod cannot be reloaded by the gunner, even though two extra magazines are shown attached to the sides. M2s and DShKMs can be reloaded by the gunner and are provided with multiple extra magazines, even though no such extra ammo boxes are rendered. This is all without using the ACE CSW method. The Kord should be able to be reloaded by its gunner, consistent with the other weapons.

These are as much feature requests are bug, bringing ACE and Arma features up to date so they work well with each other. Tested without latest beta, no other mods.


Related issues

related to A.C.E. for OA - Bug #16368: AI does not fire at several vehicles depending on ammo types Closed 01/01/2011

History

Updated by Sickboy over 4 years ago

  • Category set to Config
  • Status changed from New to Assigned
  • Assignee set to VKing
  • Target version set to 1.8

Updated by rocko over 4 years ago

  • Priority changed from Normal to Low
  • Target version deleted (1.8)

Reproduceable with Vanilla Arma?

Updated by maturin over 4 years ago

I didn't test this with vanilla, only with ACE alone. It seems like ACE would want to fix it since it is a crucial component of the gameplay enabled by the armor and crew damage systems, and affects a vehicle added by ACEX.

Updated by rocko over 4 years ago

And it helps if we know that the problem is also in vanilla and not in ACE, so we can save a lot of time skimming through many many configs and if it is not a problem then we can at least use diffs to track the problem down hence the question. So please please with sugar on top, is it reproduceable in vanilla?

Updated by maturin over 4 years ago

Ok, just tested with CO beta, no mods. The M2 will blast away at a BTR-60. The BTR-70, of course, doesn't exist to test.

Updated by rocko over 4 years ago

  • Target version set to 395

Updated by rocko over 4 years ago

  • Due date set to 01/12/2011

Still the case?

Updated by rocko over 4 years ago

  • Status changed from Assigned to Expired
  • Target version deleted (395)

Updated by VKing over 4 years ago

  • Due date changed from 01/12/2011 to 01/21/2011
  • Status changed from Expired to In progress
  • % Done changed from 0 to 50

Fix found.

Updated by rocko over 4 years ago

  • Target version set to 395

Updated by VKing over 4 years ago

  • % Done changed from 50 to 80

At least partly fixed in today's update (1.7 update 3)
Please test.

Updated by rocko over 4 years ago

  • Target version changed from 395 to 1.9

Updated by maturin over 4 years ago

M2 tripods will engage BTR-70s with the latest update. The AI fired on my frontal arc from 50m.

Updated by Sickboy about 4 years ago

tnx Maturin.

Status VKing?

Updated by VKing about 4 years ago

Not sure what else to do about this. If noone reports it more broken I think we can call resolved.

Updated by Sickboy about 4 years ago

  • Status changed from In progress to Closed
  • % Done changed from 80 to 100

Acesome!

Also available in: Atom PDF