Bug #1626

AI Slow turning/ Slow Aiming

Added by Sonsalt over 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:05/29/2009
Priority:Normal Due date:10/14/2009
Assignee:- % Done:


Category:AI Issues
Target version:1.03.58627
Affected ArmA II version:1.02.58134 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:


AI sometimes turns around really slowly when it sees you. Also it sometimes needs to aim really long ( testing distance ca.25m)

Behavior Description:

Slow Turning:
The AI notices your presents and turns towards you. AI is either standing or crouching. It turns really slowly (Average turntime 3-5sec)

Long Aiming
You are in clear sight for the AI and it starts to aim at you. (Average Distance 20-30m) Aiming up to 5 sec.

These issues occeur about 25% of all tests. The rest of the time the AI turns normal and aims quick.

AI skill 1.0
AI Setting skill : 1.0
AI: Russian Infantry rifleman
I am playing as USMC rifleman
Terain type: Urban
View: In plain view, clear sight

CIT_1626.utes.7z (966 Bytes) alef, 06/13/2009 15:11

CIT_162622.utes.7z (980 Bytes) Sonsalt, 06/23/2009 16:29

CIT_1626_3.utes.7z (1.3 kB) alef, 06/26/2009 19:29

VideoAITurning.7z - This is a video that shows the AI turning issue along with the detection beacon (8.5 MB) Sonsalt, 07/01/2009 14:31

Related issues

related to ARMA2 Community Issue Tracker - Bug #1703: AI Total Blackouts/Gaps & AI Reaction Times to slow Expired 06/01/2009 10/14/2009
related to ARMA2 Community Issue Tracker - Bug #4474: AI aiming at walls - possible AI problem ? Expired 09/12/2009


Updated by Sonsalt over 6 years ago

The Slow turning and not responding AI still remains even with Final Version 1.01

Updated by alef over 6 years ago

  • File CIT_1626.utes.7z added
  • Due date set to 06/27/2009
  • Category set to AI Issues
  • Assignee set to Sonsalt
  • Affected ArmA II version set to 1.01.57751

Could you please check if the attached mission works as repro for this problem? Thank you.
If not, please provide one from you.

Open it in the editor and change the init fields in game logic and player. As you start, you recevie a message as soon the enemy see you and start a timer up to the first hit. You have then a short time to see the measured time.

Updated by alef over 6 years ago

  • Status changed from New to Feedback

Updated by Sonsalt over 6 years ago

Roger will check

Updated by Sonsalt over 6 years ago

The best way to view the AI slow turning bug is by moving around the corner and change into sight of the AI again and again.

Most of the times the AI picks up on you and turns towards you the turning motion is really slow.

Updated the mission, try it by hiding behind the building and move into the open again several times.

Another issue related to this AI behavior is that the AI always seems to loose "interest" in you once you are out of sight.
Instead of aiming at your last known position it turns away and seems to look straight. In this matter it would make sense to implement some sort of delay.
-> The AI unit that last engaged an enemy that is now out of sight (but not dead) should remain at its position for some seconds and keep aiming at the last known enemy position (maybe even Suppression fire) before moving again. Other units within the group will however get the command to flank that enemy.

Updated by Sonsalt over 6 years ago

  • Assignee changed from Sonsalt to alef

Updated by alef over 6 years ago

Sonsalt wrote:

maybe even Suppression fire

Seen this happening in "STEALTH" behaviour.

Updated by alef over 6 years ago

  • File CIT_1626_3.utes.7z added
  • Due date changed from 06/27/2009 to 07/10/2009
  • Assignee deleted (alef)
  • Affected ArmA II version changed from 1.01.57751 to 1.02.58134

Repro updated. You can now see where the AI thinks you are. Sometimes does suppression fire.

Updated by Sonsalt over 6 years ago

First of thanks for the test mission, it helped to narrow in the problem

In order to show you the slow turning issue more precisely I made a short video.
There I repeatedly left my cover behind the building stepped in the open so that the AI could see me and once it has detected and aimed at me I returned back to cover.

As you can see the moment you step out of sight the Ai's point of concentration shifts away from you about 90°. Every time you step out of the cover, it instantly knows where you are, but the time it takes to turn and aim at you shifts between 2-5 seconds mostly.

Therefore the problem is two folded in my opinion.
1. Th AI is not aiming at your last position nor your actual position, but instead turning "straight" again most of the times.
This problem even occurs when the AI is laying down suppression fire. While shooting the AI is turning away. It keeps not shooting at the
last known position.

2. Although the AI almost instantly knows where you stand once you stepped out of cover it struggles to turn and aim at you. This behavior is
the same no matter what stance. The time until the AI shoots varies between 2-5 seconds.

The moment you step back into cover it forgets about your last known position and again starts to aim straight.

Updated by alef over 6 years ago

Good video! The last round with the external view shows clearly this bug.
  1. The enemy AI (r) knowsAbout you (p) at 4
  2. r follow the sensed vector movement of p behind the building
  3. as p appears again visible/audible, r does know exactly where p is
  4. since that, r turns to acquire the known target position of p
  • the turning speed of r at point 4 is too slow
  • this turning speed should be much faster

Updated by alef over 6 years ago

  • Due date changed from 07/10/2009 to 10/02/2009
  • Status changed from Feedback to Assigned

Updated by fabrizioT over 6 years ago

Good job here!

Updated by Sonsalt over 6 years ago

glad I could help :)

Updated by Fireball about 6 years ago

  • Due date changed from 10/02/2009 to 11/02/2009
  • Status changed from Assigned to Feedback
  • Reproduced by another DH user set to No

Is this still the case with patch 1.04?

Updated by Fireball about 6 years ago

  • Due date changed from 11/02/2009 to 10/14/2009
  • Status changed from Feedback to Resolved
  • Target version set to 1.03.58627

I've tried this out many times now with alef's CIT_1626_3 mission and I didn't think I've seen something way out of realistic turning/aiming speeds anymore - I've seen the video by Sonsalt and it's no more like that at all.

Unless you people feel this is still an issue and I'll close this on due date; I think that's been dealt with already on 1.03.

Updated by kju about 6 years ago

  • Status changed from Resolved to Closed
  • CPU set to Please specify!

Also available in: Atom PDF