Feature #16168

getAssignedTeam

Added by dslyecxi over 4 years ago. Updated over 3 years ago.

Status:Closed Start date:12/22/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Scripting: Problem
Target version:1.60.87580
Affected ArmA II version:Please select... First affected ArmA II version:
Reproduced by another DH user:No Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using: NGUrl:
Reproducible for you:No WIKIurl:
Related to content of DLC:

Description

The command assignTeam (http://community.bistudio.com/wiki/assignTeam) allows us to create team "subgroups" in a parent group. However, we cannot detect if a unit is in a given team via scripting.

Can we please get a "getAssignedTeam" command that can be used on a unit and returns a string of what color team they are on, and "MAIN" if none? (same as how assignTeam works)

This would be very helpful for our popular ShackTac HUD addon, as it would permit us to use the in-game user interface team assignment features to color-code different team members on the HUD.


Related issues

related to ARMA2 Community Issue Tracker - Feature #26643: Assigned team broadcast in MP Assigned 11/27/2011

History

Updated by kju over 4 years ago

  • Status changed from New to Assigned

Updated by Suma almost 4 years ago

  • Status changed from Assigned to Resolved

Implemented in 83400 as "assignedTeam xxx".

Updated by kju almost 4 years ago

  • Target version set to Upcoming version

Updated by kju almost 4 years ago

  • Target version changed from Upcoming version to 1.60 BETA
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Updated by Sickboy almost 4 years ago

  • Status changed from Resolved to Closed

Updated by zx64 over 3 years ago

Only just tested this in multiplayer and the assigned team values aren't visible remotely. :-(

Should this ticket be re-opened or make a new one?

Updated by Fireball over 3 years ago

  • Due date set to 11/30/2011
  • Status changed from Closed to Feedback
  • Assignee set to Suma

Reopening due to user request.

Updated by Suma over 3 years ago

Does not seem related to this ticket. If I am not mistaken, no colored teams are visible in MP, it does not matter if created by a script or from UI.

I suggest creating a new ticket.

Updated by kju over 3 years ago

His desire is to easily query remote data.
However this could also be scripted (sending the data between entities).

So yes "global" behavior would be a convenience but not necessary as far as I can tell.

Updated by Fireball over 3 years ago

  • Due date deleted (11/30/2011)
  • Status changed from Feedback to Closed
  • Assignee deleted (Suma)

Ok, please open a new ticket for MP compat, as the colored teams were originally only designed for SP.

Updated by zx64 over 3 years ago

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF