Bug #16162

Sometimes when loading multiplayer save alive player starts as a bird

Added by Hanzu over 4 years ago. Updated almost 3 years ago.

Status:Assigned Start date:12/22/2010
Priority:Normal Due date:06/01/2011
Assignee:Dwarden % Done:

0%

Category:Server
Target version:-
Affected ArmA II version:1.58.78473 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Reproduce
Only happens occasionally when savegame is loaded campaign mission is played with 3-4 players. Has happened to us once in Bitter Chill and 3 times in Badlands mission.

Observed
Human player reports he has started as a bird. Other players can see the bird but also his alive character below it.

Expected
In campaign game always should end if player is dead, so if player starts as bird observer, its a bug.

Hotfix
Turn off bird observer feature for campaigns or add option to turn off bird observer feature.

Temporary workaround
Player who started as a bird, disconnects and reconnects and the bird disappears and control for Razor Team character returns to player.


Related issues

related to ARMA2 Community Issue Tracker - Bug #14766: Eventhandler initialization order changed in 1.55 Beta Closed 10/31/2010
related to ARMA2 Community Issue Tracker - Bug #3309: Using #restart or #reassign in the (dedicated) server giv... Rejected 08/03/2009
related to ARMA2 Community Issue Tracker - Bug #12855: Client may get stuck with mission download, when the admi... Assigned 08/11/2010 12/01/2011
related to ARMA2 Community Issue Tracker - Bug #12846: Not possible to launch mission after reassign use. Assigned 08/10/2010 12/01/2011

History

Updated by Sickboy over 4 years ago

This problem goes back to at least ArmA 1, and back then was happening even on dedicated server and ordinary MP missions without save/load.

I have not heard about this problem for a while, yet there have been still reports of players randomly somhow 'not intializing properly on join', causing weird issues, scripts not working, etc. etc.

Updated by Hanzu over 4 years ago

Thank you for telling that Sickboy. It is a relief to know that I am not the only one with this problem. Since it has long traditions it is a bug worth of voting.

Maybe longer default timeout to join could help. If there is hardware, software or internet based lag for joining, the game might think that character is dead and starts player as a bird instead.

After loading savegame it would also help if the game would automatically pause in map screen until every player including the host have fully done loading their graphics and other stuff and game would not continue before the host sees everyone have loaded and clicks ready (just like it goes when you start any mission, you go through map screen where you see when players are loading (> play icon) and when they are ready (full blue square).

Updated by kju over 4 years ago

  • Due date set to 03/01/2011
  • Category changed from Savegame to Server
  • Status changed from New to Assigned
  • Assignee set to Dwarden

This is a multiplayer issue. It happens in different situations too.
The problem appears to be that the players do not get initialized correctly.

I have made one ticket in the CIT about this issue when you use #reassign or #restart.

Updated by Hanzu about 4 years ago

Last time when it occurred:
I was running non dedicated server COOP 08 Payback mission with 6 players of maximum 8. AI team members were disabled. All players were alive when we saved and later when we loaded same save. One player spawned as a bird with no apparent reason. Player disconnected and reconnected and this time spawned correctly as team member - easy workaround for annoying bug.

Note:
Using SSD now. So 99% surely it is not about me loading too slow compared to my clients. In briefing map screen I can see that I'm ready ready when others still load.

Updated by kju about 4 years ago

  • Subject changed from Sometimes in MP campaign player starts as a bird after loading savegame to Sometimes when loading multiplayer save alive player starts as a bird
  • Due date changed from 03/01/2011 to 06/01/2011
  • Operating system changed from WinXP 32 bit to Win7 64 bit
  • Affected ArmA II version changed from 1.57.76815 to 1.58.78473
  • Reproducible for you changed from No to Yes

Updated by kju about 4 years ago

It is probably some kind of init bug.

The same/very similar behavior can be observed on #restart use,
as well as on JIP in very rare cases.

Updated by Hanzu almost 4 years ago

  • Language set to Please set for missions

Still true with 1.59.81867

Happened for on 2 different savegame loads for 2 different players sitting in UAZ. Could be related to beeing inside vehicles while saving and loading.

Did not happen even once in all previous Harvest Red campaign missions.

Also available in: Atom PDF