Bug #16119

AI spotting ability too high even in the dark

Added by Voyage34 over 4 years ago. Updated over 4 years ago.

Status:Rejected Start date:12/20/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:Cannot reproduce

Description

The problem: I am supposing the ACE mod modifies some AI cfg values, but some of them are overtuned and gives unrealistics behaviours, so maybe they should be tuned down a bit. Please confirm if someone else found that.

I attached a simple mission just for making an example. It's about 3.00 at night and it's really dark (playing as a takistan soldier you could barely see your team mates near you). Now, that's the problem:

1.Repro steps: Hit the ground and shot to the takistani militia group patrolling the airstrip (less shot possible, just to make them switching to combat mode). Then stop fire and don't move.

2.Results seen: most of the times after a short time they start firing at you, even not having any kind of nvg or optics, and being you far away from them.

3.Desired results: they shouldn't be able to spot you, at least not in a so short time and with a so few shots fired by you.
I suppose they should take cover, while a group is sent in the direction the shot noise came from, or similary do what a group of human player would do in that situation, anyway the problem's not the group behaviour itself.

Important note: I tried this with no other mods loaded apart from ACE (updated to the last version via AddonSync), and I get the above written beahviour.
I'm pretty sure this is caused by ACE because if you remove the ace_c_ai_sensors and ace_c_ai_skill pbo's from the @ACE addons folder (don't know which one of the two cause that), you get the expected behaviour (group finding cover and sending a bunch of guys to your supposed position seeking for you.

Additional notes: this is just one, but there are many more examples of situation when i feel the AI spotting ability is too high; just a few of them: if you have "auto-report targets" ON in the difficulty settings you will often report targets that are much difficult to (or you can't) see in a really short time (ex. vehicles really far away, soldiers inside villages when you are still outside, etc); even AI leaders report some targets they are not still able to see with large advance.

These are just my personal considerations, if you can, please confirm my impressions, or tell me what you think about the current values (they're ok, too high, too low, etc..).

PS: I know I could generate the discussion "is better an AI that maybe sometimes sees to much where it shouldn't but are able to fight decently, or an AI that can sometimes seem dumb but at least you're sure that is not advantaged over you, etc..". These are different philosophies\doctrines on a little tweak that can be made, and there the "de gustibus" rules. I think my problem goes over, since the tweak here is imho too big to be considered a little help for the AI.

AI_20night_20vision_20test.utes.rar - Repro mission: (978 Bytes) Voyage34, 12/20/2010 12:42

History

Updated by rocko over 4 years ago

So, the AI cannot see your muzzleflash in the dark and you are suggesting they should ignore the bright flash and instead look for a "soldier" in the dark?

Updated by Sickboy over 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Sickboy
  • Target version set to 1.8

Updated by Voyage34 over 4 years ago

rocko wrote:

So, the AI cannot see your muzzleflash in the dark and you are suggesting they should ignore the bright flash and instead look for a "soldier" in the dark?

It can happen even if I fire just 1 shot from behind them (= no seeing the muzzleflash), and I stop fire (= no more muzzleflashes), that is uncorrect; with more shots it's instead rasoneable that they are able to spot you looking for the light from your rifle. Anyway the "problem" is not about how they react to the event "being under fire" and what they should do, but about how fast they can identify you in the complete dark, or in limited visibility situation.

PS i forgot another example, if you play the "Laser show" default scenario, that is based 90% on your technological superiority, so the fact that you can see them with nvg while they can't see you, with ACE loaded it becomes much more difficult to win, because they can somehow see you and return fire pretty well.

Updated by KingHomer over 4 years ago

I understand this problem.

Firing one shot and the AI knows where you are.

It may be possible to get a lose direction by the gunshot sound but a muzzleflash? You must be lucky to see the flash from one bullet furthermore the muzzleflash is only visible when the end of the barrel is heated already and ignites the resulting gases.

Updated by Voyage34 over 4 years ago

In poor words I'm not suggesting that the AI should become stupid, or blind, just that a militia group poorly equipped shouldn't be able to spot you (a camouflaged sniper in the grass about more than half a km away in the complete dark) is such a short time.

Updated by Sickboy over 4 years ago

Planning to take a bite into this for 1.8.
You would greatly increase the chance to fix/improve, in a short time, by supplying several demo missions which show the problems really well, missions that work also on the vanilla game so we can do a good comparison.

The missions should be simple, least amount of possible units (just enough to show the problem), and a simple list of Observed and Expected.

Updated by Sandiford over 4 years ago

on this topic: http://www.youtube.com/watch?v=ul_RihaMwNM&feature=player_embedded

don't know if much has changed since september

Updated by Voyage34 over 4 years ago

Ok, I'm coming back on my steps, tried a lot more of situations (nighttime and daytime, long ranges and short, obstacles, etc) in these 2/3 hours looking for examples, and I had to admit that everything generally works pretty well, so maybe I was wrong. Please don't think I didn't try before opening this, I made several test even trying all the mods, so I don't know why I've had this impression, maybe some unfortunately tries.
The only thing that could be changed for me (but maybe there are some engine limitation to this, since I imagine I'm not the first one to say that), is the fact that the AI, once have spotted you (and I mean spotted for real, not just hearing a noise), is too good at keep tracking you even when there's very low visibility (ex. at deep night, when seeing a muzzleflash should indicate only the current target position, but they should not be able to know that you're moving until they see another one in another place, or hear a rumor, etc..).
Apart from this I admit I was wrong, I can't find nothing big not working that require a change (well, some things are approximated, but just to find a compromise with the game mechanics and limits). Sorry guys for making you lose some time.

Updated by Xeno over 4 years ago

  • Category deleted (Config)
  • Status changed from Feedback to Rejected
  • Assignee deleted (Sickboy)
  • Target version deleted (1.8)
  • Close Reason set to Cannot reproduce

Maybe open a CIT ticket and report your findings there.

Also available in: Atom PDF