Bug #16039

Mouse moves out of window in windowed mode

Added by Megagoth1702 over 4 years ago. Updated about 4 years ago.

Status:Closed Start date:12/18/2010
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:Interface
Target version:1.57.76815
Affected ArmA II version:Please select... First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Hey guys.

If I run the game in windowed mode the mouse seems to leave the window and when it hovers over one of the other areas at the botton of the screen (where the clock is, or the windows-icon-button) it activates the "mouse-over" activities of those other areas.

So if I by accident hover over an other window the windows7 design blends in that window, moving the game into the background. I then have to move the mouse again to get the game back on. Also annoying pop-ups ... Annoy me.

This is clearly a bug, the mouse should not leave the window area if the game is running in windowed mode.

Thank you in advance!


Related issues

related to ARMA2 Community Issue Tracker - Bug #11591: Keyboard input in windowed mode still captured, even whil... Assigned 07/01/2010 05/01/2011
duplicated by ARMA2 Community Issue Tracker - Bug #7606: windowed mode affects desktop Duplicate 01/01/2010 10/01/2010

History

Updated by kju over 4 years ago

  • Due date set to 01/01/2011
  • Category set to Interface
  • Status changed from New to Feedback

Please find your arma2oa.cfg and adapt the values in there.
So should avoid this. If not, it is a win7 issue.

Updated by Megagoth1702 over 4 years ago

What do you mean - adapt the values? What values? Sorry, I am cofused. :-/

Updated by kju over 4 years ago

winDefH=960;
winDefW=1280;
winH=960;
winW=1280;
winX=0;
winY=0;
Resolution_W=1288;
Resolution_H=994;

Adjust as necessary.

Updated by Suma over 4 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Suma

Agreed, this is a bug (Vista / Win7 specific)

Updated by Megagoth1702 over 4 years ago

So is this going to be fixed or planned or anything? oô

Updated by Nyles over 4 years ago

I experience this a lot on my machine running the game in fullscreen on my primary monitor (26" @ 1920x1200 native), while having a second monitor (22" @1680x1050). Whenever I am in a menu with mouse control, and I move the cursor a bit too far to the right, it transitions into the desktop on the second monitor. Any accidental click will result in the game losing focus and dropping back on the desktop.

Updated by Dwarden over 4 years ago

  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

i agree this bug is bit annoying ...

Updated by Suma over 4 years ago

  • Status changed from Assigned to Resolved

Nyles wrote:

I experience this a lot on my machine running the game in fullscreen on my primary monitor (26" @ 1920x1200 native), while having a second monitor (22" @1680x1050). Whenever I am in a menu with mouse control, and I move the cursor a bit too far to the right, it transitions into the desktop on the second monitor. Any accidental click will result in the game losing focus and dropping back on the desktop.

I am afraid this is by design (or at least a different issue). When not ingame, but rather navigating the UI, what you see is normal OS cursor and it can be used to control desktop and other applications as well.

The issue described here is a different one: during the gameplay the OS cursor is invisible, but it still moves outside of the game window and can activate Area Preview or other OS functions.

The issue described is hopefully fixed as of 76796

Updated by Fireball over 4 years ago

  • Target version set to Upcoming version

Updated by Megagoth1702 over 4 years ago

Alright! Thank you so very much! :)

Updated by kju over 4 years ago

  • Due date deleted (01/01/2011)
  • Target version changed from Upcoming version to 1.57 BETA

Please confirm fix.

Updated by kju over 4 years ago

  • Target version changed from 1.57 BETA to 1.57.76815

Updated by Megagoth1702 over 4 years ago

I have not seen this happen again... If anything comes by I will post..

Thank you very much!

Updated by kju over 4 years ago

  • Status changed from Resolved to Closed

ty

Updated by Megagoth1702 about 4 years ago

Issue appeared again. Using latest beta 76973.

I just randomly played and somehow again touched the windows background... Dammit... :( Its like it has never been fixed or something, really strange.

However - just reporting this.

Also available in: Atom PDF