Bug #15886

Certain radio channels cannot be heard by some players (affects both VON and/or Text) [CO]

Added by Mr.Ben over 4 years ago. Updated about 3 years ago.

Status:Closed Start date:12/12/2010
Priority:Normal Due date:06/01/2011
Assignee:Dwarden % Done:

0%

Category:VON
Target version:1.60.87580
Affected ArmA II version:1.59 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Since 1.56 was released, when player in MP, at the start of a mission, some people can't hear people speak in VON and /or including the text chat within that radio.
Sometimes it is one channel only, it mainly affects group channel, but can be in any channel. Direct chat is also vastly affected.

I and many others have experienced this in all missions, that previously worked.
It is reproducable, though affects random players from the start till the end of a mission. On occation it has been fixed by dropping the radio and picking it up again, after doing this a few times, I have seen it fixed, but only on rare occasions.

Quite often the player who cannot hear other players and cannot see text, but can be heard or his text seen by others.

This is really really problematic bug, as no one can communicate with each other at all.

Is there any other information you require for this?

coco20_tour_oilcrisis_v1_05.Takistan.pbo (654.4 kB) Mr.Ben, 03/11/2011 15:02


Related issues

related to ARMA2 Community Issue Tracker - Bug #17892: Direct Chat not working Closed 02/26/2011

History

Updated by Sickboy over 4 years ago

  • Project changed from DevHeaven (Only site issues) to ARMA2 Community Issue Tracker
  • Affected ArmA II version set to Please select...
  • Maxmem parameter set to Not set
  • Difficulty set to Not set
  • Reproduced by another DH user set to No
  • CPU set to Please specify!
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by Fireball over 4 years ago

  • Due date set to 02/12/2011
  • Category set to Other
  • Status changed from New to Assigned
  • Affected ArmA II version changed from Please select... to 1.56.76134
  • I am using set to CO (A2+OA)
  • Reproducible for you changed from No to Yes
  • 27 set to 0
  • 28 set to 0

I've heard from buddies, that sometimes the radio commands (of Insurgency, e.g. increase/decrease VD) are not available, even though the radio is displayed in the gear inventory. But since we mostly use TS3 (to be able to communicate outside of the game too), we wouldn't notice the absence of chat messages or VON audio not passing through.

What I can do, next time, when someone claims that they cannot use the radio commands, we shall test if they also cannot chat and/or use VON at this time.

Updated by kju over 4 years ago

Isnt this about ACRE?

Updated by Deadfast over 4 years ago

No, it isn't. In-game VON and text chat.

Updated by kju over 4 years ago

I know that there are issues with the ArmA VON and direct channel.
However he says:

On occation it has been fixed by dropping the radio and picking it up again

I see no relation to the standard game for this sentence.

Updated by kju over 4 years ago

  • Category changed from Other to VON

Updated by Mr.Ben over 4 years ago

The radio you have in your inventory. Along with compass, etc.

Updated by Outlander over 4 years ago

This is a major issue, unfortunatley since many people use TS3 and such, it has gone largely unnoticed. In my experience voice chat usually works well in direct communication while text will often fail. In group chat, text usually works but on some occations voice will fail. Player textchat in direct communication seems to fail very often. Some players will be able to read a certain players chat, while others will not. The radio he means is the standard itemRadio item.

Updated by War over 4 years ago

This is quite a large issue that I suffer from regularly. My direct chat doesn't work, I can't see text or hear in it. It's getting very bothersome to play on an RP sever or have some good teamplay because direct chat does play a large role in game.

Updated by Althor over 4 years ago

I got this problem too, sometimes other people can see my direct chat but most of time i cant see theres. Its really annoying. Always direct channel for me. And at one point i had ACE installed which i uninstalled along with arma2 on numerous occasions and always did a clean uninstall by deleting the registry and temp files and folders.

Updated by kju over 4 years ago

  • Due date changed from 02/12/2011 to 04/01/2011
  • Status changed from Assigned to Feedback
  • Affected ArmA II version changed from 1.56.76134 to 1.57.76815
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Can we get some specific repro steps please.

Updated by Mr.Ben over 4 years ago

You can repro it by just placing a few default or custom BIS groups within a mission, then playing with 20 players or so. My server plays 20 players max for public games. But i have seen it with 50 or 5 players. Run a dedi server at 1.57, you can join with 1.57 or beta's, it seems to make no difference to whether you get the bug or not.

Would it be helpful to have one of the missions i have made? Though i am quite certain that it happens on all missions, whether BIS or community made ones available for DL.

Updated by kju over 4 years ago

yes please

Updated by Mr.Ben over 4 years ago

You can try this mission, I think this is the latest version of it. The more players you can get, the more likely you will encounter the bug.

Updated by kju over 4 years ago

  • Due date changed from 04/01/2011 to 06/01/2011
  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from No to Yes

ty

Updated by Yokhanan over 4 years ago

The recent 1.58 betas have seemed to cause an odd VOIP for me and a few other players while not affecting others. No matter what channel you try broadcasting through on ArmA's VOIP, no one can hear us and we don't see the player name on the screen when pressing the VOIP key. In-game text works just fine thus far, but it's only when trying to communicate by voice where the issues come in. We ended up having to use Mumble just to be able to communicate while playing without stopping in the middle of a firefight to type.

I reverted back to Beta Patch 78413, and everything when back to working normally. I need to test 78888 to see if things still work, but past that--that's where the game starts breaking.

Updated by ArMaTeC over 4 years ago

I have same issue but to work around it all players and server must be running the exact same setup so

RC + beta Vs RC + beta = Works
RC + beta Vs Steam + beta = Fails

Updated by kju over 4 years ago

It seems you guys are reporting a different issues.
Like latest version no longer backwards compatible, right?

This ticket is a different problem with VON.

Please confirm.

Updated by Jonny over 4 years ago

Yokhanan wrote:

The recent 1.58 betas have seemed to cause an odd VOIP for me and a few other players while not affecting others. No matter what channel you try broadcasting through on ArmA's VOIP, no one can hear us and we don't see the player name on the screen when pressing the VOIP key. In-game text works just fine thus far, but it's only when trying to communicate by voice where the issues come in. We ended up having to use Mumble just to be able to communicate while playing without stopping in the middle of a firefight to type.

I reverted back to Beta Patch 78413, and everything when back to working normally. I need to test 78888 to see if things still work, but past that--that's where the game starts breaking.

I have the same problem with the latest beta but it affects all players. We have CO (retail version) with no mods, updated to 1.57 and the latest beta patch (78967). Prior to 78888 we didn't experience this problem.

Tested the new 1.59.79122 beta patch and the problem is still present.

Updated by Dwarden over 4 years ago

can someone come up with repro case / situation which would make this easier for us to take look on it ?

e.g. for sure server with beta build where it happens always etc?

Updated by Dwarden over 4 years ago

  • Status changed from Assigned to Feedback

Updated by Mosh over 4 years ago

Dwarden, it has been happening for us since 78927, I missed 78888 so not tested... 78967, 1.59 RC, 79122 not working as well.

Reproduce:
server with any 1.58 beta, client with 78314 - it works
server with any 1.58 beta, any higher beta on client - it does not

can easily be tested in lobby without mission even being selected yet. Press key to chat VOIP, you see the microphone, but not your name (our server has it enabled to show name in all difficulty settings, so it's not a difficulty setting making it not show). Normally you would press the key, see the microphone, and see your name in the bottom left... not anymore.

Test variables:
Dedicated server 78413 - 78967 does not matter... only client version matters. If client using 78413 it works. Anything above, regardless of server version, and it doesn't work.
Also used multiple clients with multiple versions, 2 different dedicated servers, and various people hosting... all with same results, it was dependent on client version.

78413 everything works fine.

Hope I didn't miss anything... thanks.

EDIT - I forgot to add, I have never seen it with text, only VOIP... Our text chats are working fine.

Updated by Fireball over 4 years ago

  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.57.76815 to 1.59.78955

Updated by Fireball over 4 years ago

  • Affected ArmA II version changed from 1.59.78955 to 1.59 BETA

Updated by neokika over 4 years ago

Dwarden wrote:

can someone come up with repro case / situation which would make this easier for us to take look on it ?

e.g. for sure server with beta build where it happens always etc?

No, not Beta related at all, it's there since v1.56.

neo

Updated by Dwarden over 4 years ago

  • Status changed from Assigned to In progress
  • Target version set to Upcoming version OA

some VON fix is on it's way to next beta ...

Updated by neokika over 4 years ago

Thank you

Updated by Suma over 4 years ago

  • I am using deleted (CO (A2+OA))

I am afraid everything in this issue since #16 is most likely a different issue, which has no relation to the original problem. I am unsure how could we clean up this now.

Updated by Mosh over 4 years ago

#17892 is more relevant to the current issue, I should have posted there first, had I seen it first... all chat channels seem to work now with today's beta

Updated by Dwarden almost 4 years ago

  • Status changed from In progress to Feedback
  • Affected ArmA II version changed from 1.59 BETA to 1.60 BETA

ok, we need feedback on this one otherwise it's subject to expire

in any case better / simple repro with latest betas (83500 or higher build) needed

Updated by Dwarden almost 4 years ago

  • Status changed from Feedback to Closed
  • Target version changed from Upcoming version OA to 1.60 BETA
  • Affected ArmA II version changed from 1.60 BETA to 1.59 BETA

well i'm closing this
if there is still some VON problem then create new ticket with better repro just linked via related issue

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF