Feature #15650

Allow SF units to use MedKits

Added by AnimalMother92 about 4 years ago. Updated about 4 years ago.

Status:Rejected Start date:12/05/2010
Priority:Normal Due date:
Assignee:- % Done:

30%

Category:Script
Target version:-
Component:sys_wounds Affected Version:
Close Reason:Out of Scope

Description

As discussed in Wave:
I think it might be good to allow SF units to use MedKits as irl they get superior medical training and often have to help themselves when no corpsman or medevac is around.


Related issues

related to A.C.E. for OA - Feature #15645: Some factions have no medic, therefore medkits can only b... Closed 12/05/2010 12/12/2010

Associated revisions

Revision 07bcb37c
Added by Sickboy about 4 years ago

~ ADDED: Wounds - Everyone Medic module, and Full heal (even in the field) Module. refs #15650

History

Updated by Sickboy about 4 years ago

  • Category set to Script
  • Status changed from New to Feedback
  • Assignee set to Sickboy
  • Target version set to 1.7
  • Component set to sys_wounds

Updated by Huggy about 4 years ago

If i recall right there is a SF-Medic in every SF-Team.

Making every SF soldier a "Medic" makes him pointless and no teamwork required anymore to heal up wounded team members.

There is a reason why RL SF-Teams have a Medical Sergant.

Updated by Sonsalt about 4 years ago

I agree on that, the corps-man training is a specialisation just like explosives, marksmanship and engineering.
Every unit going out in the field will have at least one trained medic with it. Special forces are just like any other unit in this matter, they are just smaller in size and are better trained ans specialized.

Instead breaking the pattern of "medics" we should just make sure that there is a medic unit among the SF units and mission maker should make sure they bring him along, just like you would bring a demolition expert to handle explosives.

The Medic Kit is the tool-kit the Medic requires to patch up injured people, nothing more but nothing less. If the kit replaces the skills we defeat the purpose.

Updated by Sickboy about 4 years ago

  • % Done changed from 0 to 30

Good points, making a medic unit available where missing sounds like the best course of action.

Updated by rocko about 4 years ago

  • Status changed from Feedback to Rejected
  • Assignee deleted (Sickboy)
  • Target version deleted (1.7)
  • Close Reason set to Out of Scope

Updated by AnimalMother92 about 4 years ago

What about something along the lines of ["ace_w_ismedic",true] for the normal Wounding module. This would at least give the option to mission makers if they want that realism for SF guys. The whole "special ability" thing sounds too Battefieldish imo :/

Updated by Sickboy about 4 years ago

AnimalMother92 wrote:

What about something along the lines of ["ace_w_ismedic",true] for the normal Wounding module. This would at least give the option to mission makers if they want that realism for SF guys. The whole "special ability" thing sounds too Battefieldish imo :/

I don't understand what you mean. You already have that option.

Updated by AnimalMother92 about 4 years ago

Isn't that option for missions with the Morph/Epi for Medics only Module? I'm talking about the standard Module, so that you could make an SF unit able to use MedKits if you wanted to in a certain mission.

At least that's how I understood it:
If wounds medic only is enabled it is now possible to make other units to medics (factions without medic) by putting this setVariable ["ace_w_ismedic",true] into the unit init line, refs #12971 [Xeno]

Updated by Sickboy about 4 years ago

Incorrect. See Wounds Overhaul overrides section. ace_w_ismedic works anytime.

Updated by AnimalMother92 about 4 years ago

Perfect, thanks for clearing that up.

Updated by rye about 4 years ago

SASR It's two choices: medic or signaler. They need at least one of each per patrol.

And medics learn as much as a junior doctor.

http://www.youtube.com/watch?v=gdCs4C6wGnc 3mins onwards.

They get assignments all over the place, even working in hospitals and medical centers to help out. Anywhere from their home country all the way to Africa, so you can imagine the amount of patients and problems they encounter. And it's not just medical basics, they learn about water sanitation, first aid, minor surgery, hospital administration etc, etc, anything they need to learn about because that's what they'll need to know out there on patrol.

Other members of the patrol will know the basics, basic first aid, how to use some of the equipment etc etc.

Updated by rye about 4 years ago

And think about it your basic soldier knows how to use bandages and your basic gear, first aid, cpr. And the biggest complaint we have had on the MSO is ace wounds not allowing players to heal themselves, therefore having loads of unconscious people around the place and NEEDING two people on just to heal one another, which doesn't work out half the time as one of them dies.

Updated by Sickboy about 4 years ago

The original game doesn't allow you to heal yourselves either. I consider being able to heal yourself a cheat.
If you don't wanna go unconscious you need to stop the bleeding asap; stop moving asap when hit and apply a bandage asap.

The fact that units know how to use basic medic gear, is also apparant in-game;
you can use all items, except the item that magically heals you, when you're not a medic nor at a medical facility.

Additionally, if you really wanna be able to heal yourselfs; make it happen;
http://ace.dev-heaven.net/wagn/Wounds_Overhaul#Overrides
Add to the init lines of players; this setVariable ["ace_w_ismedic", true];

For next version i've added modules "Wounds - Full Heal" and "Wounds - Everyone is medic".

If you have feedback; please create a proper ticket for it.

Updated by Sonsalt about 4 years ago

rye wrote:

And think about it your basic soldier knows how to use bandages and your basic gear, first aid, cpr. And the biggest complaint we have had on the MSO is ace wounds not allowing players to heal themselves, therefore having loads of unconscious people around the place and NEEDING two people on just to heal one another, which doesn't work out half the time as one of them dies.

Well, I think the new medic system is a great improvement for the gameplay. It is much more realistic and very well balanced.
It divides the medic situation into two elements. Stabilizing and healing.

1. Stabilizing.
Stopping the blood loss and reviving unconscious soldiers. Every soldier can bandage others all the time and even bandage himself up to a certain degree. You have to agree that one will not be able to bandage a severe wound to the arm or stomach himself. The buddy bandaging takes care of this.
The second part is reviving. Surely the medic has his epi that allows him to revive quickly but every soldier can perform CPR and thus is able to revive and help his comrade to get back in combat.

This basically should take care of ppl not being able to remain combat effective.

2. Healing.
The medic class is very common in many FPS games and is also quite realistic. It adds diversity to the gameplay and and tactic. The medic has not only the ability to revive faster, ease pain and bandage, he can patch ppl up (sort of heal them). His role is core element of every army. He is a supporter not a fighter. He stabilizes and heals. With the new medic system the Medic now actually has something to do. In the past people either got fatally wounded and died instantly or they just bandaged and healed themselves, rendering the medic useless. This has changed. As you noticed death is now much less instantly but occurs rather later, leaving players an actual chance of getting revived and healed and therefore getting back into the game. The medic is now a valuable asset to every mission and is now kept in the back, while the wounded are brought to him or in cover before he attends them.
And after all there is still the ability for every player to heal someone else with a medic kit at a medic post or vehicle. Giving the ability to heal even without a medic. This function effectively adds the medevacs and tents back to the gameplay. Before this adjustment nobody ever used the medic vehicles in the game anyways.

I think we are just much too used to the former self bandaging self-healing medic system that barely knew any reviving and coop elements.

After all this is a COOP Game!!!

Updated by Huggy about 4 years ago

Sonsalt wrote:

After all this is a COOP Game!!!

Exactly

If anyone has problems with the new system or is often in the situation of having no one left to heal you and your other teammates, the i suggest to solve the problem in a very simple way.

Adapt your tactics!!!!!

Fall back when the enemy fire get´s to heavy, before someone get´s hit.
Make sure your formation isn´t too tight.
etc.......

Lot´s of stuff you can do.........

I like the new medical system

Updated by Sonsalt about 4 years ago

Second that :)

Updated by rye about 4 years ago

Yes but they can't even bandage themself. Because reality is that you are going to stop blood loss as quickly as you can, and do it yourself if no one can do it for you.

It's the biggest complaint so far in the game, we get into firefights, someones hit, we all are trying to take out that threat before we can move up and help the guy. If he could bandage himself and try to stop blood loss then we'd have more time and he could remain in the fight. It's not like the enemy have to put up with these problems so it's not so hard for them.

I'm not saying I don't like the new medical system or it hasn't improved, didn't even mention that.

All I mentioned was the ability to help yourself. I'm not saying the bandage should magically heal you, just stop or slow down, depending on the wound, and at least allow you to put a few rounds down range (again depending on wound).

We do play as a co-op, and we are adapting tactics, it's just no one fucking likes it because there is no reason why an injured soldier - say for instance shot in the leg - can't bandage it up at least. Maybe making body parts that don't effect your ability to use the medical gear treatable? The game should adapt to common problems like this.

And by the way it was a 4-man patrol, USSF. I think they know how to use bandages. :D

Updated by rocko about 4 years ago

I am able to bandage myself when bleeding.

Updated by Raptorko about 4 years ago

Rye, if someone shoots off SF´s arm, he probably wouldn´t be able to bandage himself :-) Or if shot to back :-D (Oh mirror mirror on the wall, show me my shot arse :-D ) Engine limitation - no mirrors :-D SO you need someone else to bandage the buttocks.

Updated by rye about 4 years ago

So not even in the leg? Which I mentioned, leg not arm.

And three of us who got hit couldn't bandage Rocko, trying both menu's.

Yet I've seen it - treat wounds -> bandage - when we're not hit, yet when we got hit it wouldn't come up.

Updated by rye about 4 years ago

Checking the mission, could of messed something up.

Updated by Huggy about 4 years ago

rye look up to the topic, it´s about the ability to use Medkits by SF-soldiers NOT bandages.

I guess we all agree that the ability to put on a bandage is something we can expect by everyone 16+ years old.
So SF personal is, like all soldiers in game, able to but on a bandage.

Ps: you might found a bug where under certain circumstances you are not able to do that anymore

Updated by Raptorko about 4 years ago

Maybe it´s not a bug but a feature and rye just managed to land a few criticals?
From http://ace.dev-heaven.net/wagn/Wounds_Overhaul :
•You can stop bleeding yourself when damage is under 30%
•Someone else needs to bandage you when damage is over 30%

Updated by rye about 4 years ago

Roger, ok, so engine limitation don't allow you to heal via body parts, just percentages of damage. And I know it is Huggy, I didn't want to create a ticket just to ask questions. So even if it's 31% damage to the leg, no go. :P Damn.

Even if it's one round... to the foot?

Ok so what about medics being allowed to bandage, medikit, morphine or epi themself? As they have superior training? Can they do that? And if so, what is their percentage of damage before they cannot do that?

And body armour, preventing penetration but still allowing damage?

Updated by rye about 4 years ago

Just talked to Jazzadazza [AAF] he said he got hit in the leg last night and couldn't bandage himself.

Wouldn't it be best to up the percentage of damage you can take in limbs before healing yourself? Chest shots etc, thats fine.

Updated by Sonsalt about 4 years ago

@rye

the current function to limit the bandaging of one self to a certain degree is only the first step into the overhaul of the system. In the future you might be able to bandage different bodyparts depending on the part and the gravity of the injury. For now the 30% simulate a degree of damage you just won't be able to handle your self anymore. And as far as I tested it, this also correlates with the unconsciousness state.

but now Back to the topic please

Updated by rye about 4 years ago

Yes but understand 30% is a lot with the hitpoint system, could be a ricochet. :P

And really consider depending on body parts because 30% with your leg is one shot.

Please consider making it a little bit more, and maybe even a litter bit more for the medic or people with body armour.

Updated by Sickboy about 4 years ago

The 30% damage is not calculated with getDamage but a custom function where damage to the head and body counts much more than the legs or the arms.
You can always bandage yourself from a single shot in the leg, im guessing he perhaps had damage left on other body parts.
It should take quite some shots, (and many more if to legs or arms), to not be able to bandage. Just make sure you get healed by medkit so you can bandage yourself again when you get shot later.

One problem though is that hits to the legs the game also transfer damage to head and body, looking into that.

Updated by rye about 4 years ago

Roger thanks for help.

Updated by Sickboy about 4 years ago

Lastly, Perhaps the 30% and how the damage is calculated can still be tweaked, so specific feedback is very welcome, in specific tickets ;)
For general discussion come visit us @ Wave; http://dev-heaven.net/projects/ace-mod2/wiki

As to the enemy; the enemy (AI) basically has the same limitations as you.

Updated by rye about 4 years ago

Aaaaaaaaah, got hit in the leg, 7.62, close range. Conscious, only needed bandages and morphine. I was give them both.

No option for first aid option to use medikits. Gunner (AEF) and Kynetic (AEF) can confirm as they both tried. I was active but could not walk and had no option to treat the wounds.

Updated by Sickboy about 4 years ago

In MP, Medkits can only be applied by medics (or by ordinary soldier at a medical facility) to treat damage, not bleeding.
Bleeding requires Bandage, not medkit.
Additionally, Medkits can only be applied after the patient is stabilized (stopped bleeding, conscious, no pain).

If you can't walk, you need to be treated with a medkit, by a medic in the field or by ordinary soldier at a medical facility, after you're stabilized.
On a side note, as of latest versions if you're stabilized, people can carry you even when not unconscious, useful for med-evac etc :)

Updated by Huggy about 4 years ago

Sickboy wrote:

On a side note, as of latest versions if you're stabilized, people can carry you even when not unconscious, useful for med-evac etc :)

Very good!!!

Also available in: Atom PDF