Feature #15569

Fixed azimuth&elevantion for mortars in 'Fire on Load' mode

Added by Trips over 4 years ago. Updated almost 2 years ago.

Status:Closed Start date:12/03/2010
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:1.14
Component: Affected Version:437
Close Reason:

Description

Can be reproduced with all CSW and static mortars with all shells.

First lay the tube direction then switch to the back seat and load a shell. Observe the tube move as you load the shell. I think it's 'resetting' to 0mils azimuth and the lowest elevation. You can stop the reset by switching to gunner seat, however then the shell wont fire-on-load. Shells don't seem to land anywhere.

FireOnLoadIssue.Takistan.zip - Demonstration mission. (758 Bytes) Swedge, 04/09/2011 21:48


Related issues

related to A.C.E. for OA - Bug #15570: Artillery Computer targeting is not possible before first... Rejected 12/03/2010
related to A.C.E. for OA - Bug #18869: Mortars sight and fire Rejected 04/12/2011
related to A.C.E. for OA - Bug #15628: Mortar Ammo exploit Closed 12/05/2010 12/12/2010
related to A.C.E. for OA - Feature #17413: Implement new sys_arty realistic usage for Mortars Duplicate 02/06/2011 12/31/2011
duplicated by A.C.E. for OA - Bug #17149: ACE mortar Autofire bug Duplicate 01/30/2011
duplicates A.C.E. for OA - Bug #21789: Bugged Mortars: Fire On Load doesn't work correctly Duplicate 07/03/2011

History

Updated by Sickboy over 4 years ago

  • Status changed from New to In progress
  • Assignee set to Sickboy
  • Target version set to 1.7
  • % Done changed from 0 to 20

First round problem is known issue, working on it.
However it should not reset on the next rounds (unknown issue if it does that :))

Updated by mr.g-c over 4 years ago

I confirm this issue.. the "fire on load" is always resetting the mortars azimuth/elevation as soon as a round was loaded. Tried all possible combinations, SP, MP with my Brother - always resets itself in "fire on load" mode.

Updated by Sickboy over 4 years ago

In SP it should only reset it-self for the first round.
Please provide repro mission in case it does also for all the other rounds.
MP is still a problem.

Updated by mr.g-c over 4 years ago

Ok before i make myself into an idiot here, please, is there any documentation how ACE-Team suggests the way to use "fire on load" properly?

Updated by rocko over 4 years ago

  • Due date set to 12/10/2010

Updated by rocko over 4 years ago

  • Affected Version set to 437

Updated by Sickboy over 4 years ago

  • Target version changed from 1.7 to 395

Updated by rocko about 4 years ago

  • Target version changed from 395 to Planned (Needs Contributors)

Updated by Swedge about 4 years ago

I confirm this Fire On Load issue for M224 60mm Mortar on both first round and other rounds following.

Arma 2 OA v1.59.79384
CBA v.0.7.4.152
ACE for OA 1.10 RC2

Demonstration video:
http://www.youtube.com/watch?v=JczTcgXXen0

Demonstration mission also attached.

Thank you for your time. Much appreciated.

Cheers,
Swedge

Updated by rocko about 4 years ago

  • Tracker changed from Bug to Feature

Updated by rocko about 4 years ago

  • Subject changed from Fire-on-load 'resets' the mortar's azimuth and elevation to Fixed azimuth&elevantion for mortars in 'Fire on Load' mode
  • Status changed from In progress to New

Important but expired -> Feature

(Fire-on-load 'resets' the mortar's azimuth and elevation)

Updated by rocko over 3 years ago

  • Target version changed from Planned (Needs Contributors) to Arma 3

Updated by rocko over 3 years ago

  • Due date deleted (12/10/2010)

Updated by Sickboy over 3 years ago

  • Assignee deleted (Sickboy)

Updated by zGuba about 3 years ago

  • Status changed from New to Feedback

What about usage of _MG fireAtTarget [objNull,_weapon]?

Updated by Sickboy about 3 years ago

zGuba wrote:

What about usage of _MG fireAtTarget [objNull,_weapon]?

Yea what about it? Did it change the problem?

Updated by rocko about 3 years ago

What should this fix? Does it take the AI into account, as soon as the AI enters it "misaligns" the tube from the mortar. So far firing already works, just the misaligning needs to be fixed/prevented.

Updated by zGuba about 3 years ago

It should prevent turning around. Only fire weapon.

AI can't be prevented from anything afaik, you can make it dofire something but I doubt it's worth the work.

Updated by rocko about 3 years ago

IIRC the issue with AI is, as soon as the AI enters the mortar it changes the orientation of the tube (it's just minimal, but has great impact on the accuracy)

Updated by zGuba about 3 years ago

Ah, indeed.

One solution would be to add another turret body, but then we cannot force it to fire.

BI...

Updated by rocko almost 3 years ago

  • Status changed from Feedback to Closed
  • Target version changed from Arma 3 to 1.14
  • % Done changed from 20 to 100

except fire on reload

Also available in: Atom PDF