Bug #15521

[PMC] Zargabad map stuttering

Added by Fireball over 4 years ago. Updated about 4 years ago.

Status:Closed Start date:12/02/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Performance breakdown
Target version:1.59.79384
Affected ArmA II version:1.56.76134 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC:PMC WIKIurl:

Description

The map Zargabad has clear performance issues, i.e. drastic FPS drops at some views something along 50-20 FPS differences. This per se wouldn't be THE big issue.

More interesting are the stutters, which are not connected to FPS; i.e. I get a wavey curve in Fraps (G15 Plugin), but it doesn't show "stoppers" i.e. nothing below 20 FPS, yet it feels like stuttering heavily while fighting across the map, also observed when "scoping" with e.g. a sniper rifle.

This is not directly connected to PMC only, but since PMC plays for a large part in Zargabad, it becomes more important. My observation came from the PMC campaign, but I had that impression earlier.

Repro

Someone would have to make a self-running demo through Zargabad - anyone?


Related issues

related to ARMA2 Community Issue Tracker - Bug #14397: [OA] Stuttering in cities and even small villages Closed 10/13/2010

History

Updated by Rommel over 4 years ago

Best bet is to get an SSD, I have a computer spec much less than yours, no stutters soon after getting an SSD and putting ArmA2 on it. Its because its constantly loading off the hard drive, and that limits how fast it can load the scene; and hence stutters as it loads each object off the hard drive.

Updated by kju over 4 years ago

My guess it is down to the amount of houses and
more important all of them having complex interior.

The only solution I can see is to reduce the VD a lot
and reduce the model complexity via graphic options.

Updated by AvEngErZx over 4 years ago

Try Defragging ARMA 2 Directory, hopefully it improve the performance on LOD Slutters

I used Game Booster v2.0 to defrag my game files, there is other Defragging tools available too

Updated by Fireball over 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee set to Fireball

Heh.

I was about to say that my drive gets automatically defragged every week and it couldn't be due to fragmentation. Then I saw that defrag is scheduled for 1 o'clock every Wednesday.

As I compared it to when I filed this ticket, it was 24 hours from now, but after I stopped playing on that night, thus I was playing on Zargabad at 1 o'clock on a Wednesday.

I'll verify again, since everyone keeps telling me "your rig is too slow"... :-P

Updated by kju over 4 years ago

  • Reproduced by another DH user changed from No to Yes

Well I get the same too. Even with the very low VD in the PMC campaign.
To me it helps, if the model complexity (NOT the textures) are reduced.

The stutters for me only happen when moving/zooming, aka new objects or LODs
need to be loaded. See also #14397.

Updated by Fireball over 4 years ago

  • Due date changed from 03/02/2011 to 02/02/2011
  • Status changed from Feedback to Assigned
  • Assignee deleted (Fireball)

Cheers.

Updated by Dwarden over 4 years ago

  • Related to content of DLC set to PMC

Updated by Dwarden over 4 years ago

  • Assignee set to Dwarden
  • Target version set to Upcoming version of PMC

Updated by INVICTUS over 4 years ago

I bought a new OCZ Agility 2 SSD and guess what the stutter is still there. I hope a patch will fix it. My new ssd has better specs than that of the intel 1st gen ssd I used before. I was under the impression this was a texture loading issue with the hard disk, but it is not!

Updated by Dwarden over 4 years ago

  • Status changed from Assigned to Feedback

should be goner with 1.59

Updated by Fireball about 4 years ago

  • Due date deleted (02/02/2011)
  • Status changed from Feedback to Closed
  • Target version changed from Upcoming version of PMC to 1.59.79384
  • I am using deleted (CO (A2+OA))
  • Language set to Please set for missions

Yes, I think it was already fine since 1.59 - been doing lots of tests with Insurgency in Zargabad.

Also available in: Atom PDF