Bug #15176

Unit Identity incorrect on Client when Spawned on Dedicated Server / Remote AI voices are low pitched

Added by thhamm over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:11/15/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Server
Target version:1.59.79384
Affected ArmA II version:1.57.76815 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When Units are spawned by "createUnit [array]" on a dedicated Server, they all have the same "Identity" on the Clients - i.e. same Face etc. - and Voice Pitch seems to be 0 (very slow Voice, unreadable).

Reproduce:

  • Fire Up "Superpowers",
  • Let the AI Buy some Units,
  • Try to shoot one of them in the Foot, to trigger "Blue on Blue" Messages, which will be distorted.

Units spawned locally or placed in the Editor are fine.

identtest.Desert_E.pbo (2.1 kB) thhamm, 11/16/2010 19:51


Related issues

related to ARMA2 Community Issue Tracker - Bug #15011: Problem setting the player ID in multiplayer Closed 11/09/2010
related to ARMA2 Community Issue Tracker - Bug #15009: [75445] "Unexpected message data" Closed 11/09/2010
related to ARMA2 Community Issue Tracker - Bug #25591: Radio messages are replayed slowly Closed 10/17/2011
duplicated by ARMA2 Community Issue Tracker - Bug #16142: Face and voice randomly assigned to host player in MP Duplicate 12/21/2010 01/01/2011
duplicated by ARMA2 Community Issue Tracker - Bug #16093: Extreme low pitched and slow speaking AI in Warfare missions Duplicate 12/19/2010

History

Updated by Fireball over 4 years ago

  • Due date set to 02/15/2011
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from No to Yes

Great work on identifying the root cause; can you write up a repro mission in Desert?

Updated by kju over 4 years ago

  • I am using set to OA only

#15011 might be about the same.

Also the rpt messages of the same root cause:
  • Face
  • Glasses
Repro
  1. Start DS.
  2. Connect with one client (1.55 or 1.56 beta).
  3. Load COOP 02 One Shoot One Kill or COOP 05 Steel Panthers on Takistan (BI OA missions).
  4. Notice you cannot hear the remote AI speaking. You only get some noise.

Possible same cause:

Repro
  1. Start DS.
  2. Connect with one client (1.55 or 1.56 beta).
  3. Play any mission where not leader (like most BI OA missions).
  4. Try to use radio (5-x) to talk to the SL.
  5. Notice the lack of response.

Updated by kju over 4 years ago

  • Subject changed from Unit Identity incorrect on Client when Spawned on Dedicated Server to Unit Identity incorrect on Client when Spawned on Dedicated Server / Remote AI voices cannot be heard.

Updated by kju over 4 years ago

  • Affected ArmA II version changed from 1.55.75445 to 1.56 BETA

Updated by thhamm over 4 years ago

Fireball wrote:

Great work on identifying the root cause; can you write up a repro mission in Desert?

Absolutely!

When launched on a DS, the Sniper has been placed using the Editor, AT Specialist spawns by Serverside "createUnit" and the AA Specialist with "createUnit" Clientside.
AT Specialist will be missing its Identity.

Updated by Fireball over 4 years ago

Great, thanks!

Updated by Fireball over 4 years ago

  • Subject changed from Unit Identity incorrect on Client when Spawned on Dedicated Server / Remote AI voices cannot be heard. to Unit Identity incorrect on Client when Spawned on Dedicated Server / Remote AI voices are low pitched

Updated by Dwarden over 4 years ago

  • Target version set to Upcoming version

Updated by thhamm over 4 years ago

Yep, fixed in Beta 76934, thanks!

Updated by kju over 4 years ago

  • Due date deleted (02/15/2011)
  • Status changed from Assigned to Resolved
  • Target version changed from Upcoming version to 1.58 BETA
  • Affected ArmA II version changed from 1.56 BETA to 1.57.76815

Yay

Updated by Convoke over 4 years ago

http://www.youtube.com/watch?v=gGK2VkFgSRA

This with last beta with BAF and PMC, A2:CO steam.
I have this in all coop & cti type missions.

Updated by Fireball over 4 years ago

Servers also need to run a beta past the fixed build. You're most likely running a fixed beta, but AIs spawned on the server are "remote" and thus have the old behavior. Don't worry, patch 1.58 is imminent!

Updated by rye over 4 years ago

Related to #16341

Updated by kju over 4 years ago

It is not possible to reference other project tickets and what's the point to do so?

Just both server and client need to use the latest beta. Or wait for 1.58.

Updated by rye over 4 years ago

Will wait for 1.58. Just pointing it out because actual "growling" type voices wasn't mentioned.

EDIT:
And Q, ffs, it's not referencing other projects - i'm just saying it happens in this also. It's only a mission not a mod project. It has vanilla and ACE versions - happens on both. Also if they need an extra repro they can use the vanilla version of the MSO.

Updated by Fireball over 4 years ago

They're called "low pitched" in this ticket, which is even more correct, so to say.

Updated by kju over 4 years ago

  • Target version changed from 1.58 BETA to 1.59.79384
  • Language set to Please set for missions

Updated by kju over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF