Feature #15144

Mortar, AI, Rearm

Added by Miccey2 over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:11/14/2010
Priority:Normal Due date:11/21/2010
Assignee:Sandiford % Done:

100%

Category:Config
Target version:1.7
Component:sys_crewserved Affected Version:
Close Reason:Cannot reproduce

Description

Not really sure how to do this but here goes:

Place yourself + 2 AI´s in editor
Place m252 Crate
Place correct ammo for M252 Mortars
Place CWS AI Module

Start

Have AI1 Pick up Tripod
Have AI2 Pick up Tube
Have AI1 Pick up ammo

Order AI1 to deploy tripod
Order AI2 to Mount weapon
Order AI2 "Get in As Gunner"
Order AI1 "Get in back"

Scenario is to have AI`s do the fireing.
Problem #1
You as player cant order them to fire.
You as player cant access Arty Copmuter.
Problem #2
AI1 cant rearm/load the weapon

I dont have a repo mission or rpt
Dont really know how to make the rpt
and the mission is easy...

CSW_Repro.Desert_E.7z (849 Bytes) Sickboy, 11/14/2010 15:10

load.png (1.7 MB) Sickboy, 11/14/2010 15:14

loaded.png (707.5 kB) Sickboy, 11/14/2010 15:14

mount.png (1.9 MB) Sickboy, 11/14/2010 16:23

mounting.png (1.9 MB) Sickboy, 11/14/2010 16:23

History

Updated by Miccey2 over 4 years ago

BTW:
Using A2 OA CO 1.55
ACE 1.6

Updated by Sickboy over 4 years ago

  • Due date set to 11/21/2010
  • Status changed from New to Feedback

Thanks.
Please include your rpt file (link describes where to find it) and the repro mission (the mission you already have to find the error :))

Updated by rocko over 4 years ago

I guess Problem #2 comes before Problem #1 ?

Updated by Sickboy over 4 years ago

  • File CSW_Repro.Desert_E.7z added
  • % Done changed from 0 to 10
  • Component set to sys_crewserved

Repro mission attached.

Updated by Sickboy over 4 years ago

  • File deleted (CSW_Repro.Desert_E.7z)

Updated by Sickboy over 4 years ago

  • File CSW_Repro.Desert_E.7z added
  • Status changed from Feedback to In progress
  • % Done changed from 10 to 80
  • Close Reason set to Cannot reproduce
Actually it seems to be working just fine;
  1. Load attached mission in the editor (For comfort, i've given the 2 AI, both 1 magazine)
  2. Take baseplate, and place it somewhere
  3. Take the mortar mount, and place it ontop of the base plate
  4. Order AI 2 to move next to the mortar
  5. Select AI 2, press 6, press 0 for more, select the number that says: Load.
    Sometimes it could take a few seconds before load to show up, retry last step.

Updated by Sickboy over 4 years ago

Updated by Sickboy over 4 years ago

Updated by Miccey2 over 4 years ago

Ok...It works sofar, Try making them fire..
"Canot execute Adjust Coordinates"

And the "LOADER" should be as "In Back" or as "Loader"

Updated by Miccey2 over 4 years ago

And trhat was by ME mounting the weapon...
The AI should be able to do it...

Updated by Sickboy over 4 years ago

You can use the same procedures for making the AI mounting/dismounting the weapons.
To fire I suppose you put the unit into the mortar as loader not in back, give him a target that he can reach and fire (number 3, 3)
As said, there is no artillery module support for CSW built mortars yet.

Updated by Sickboy over 4 years ago

Deploying tripod and mounting weapon:
  1. Start mission
  2. Wait a while, so the gear in ammo boxes becomes visible for AI (Sometimes it seems to help if you grab something from the box first)
  3. Order AI 2 to grab base plate from box
  4. Order AI 2 to Deploy tripod
  5. Order AI 2 to Confirm deploy tripod
  6. Order AI 2 to grab mortar from box
  7. Order AI 2 move near the baseplate
  8. Order AI 2 Mount weapon

Updated by Sickboy over 4 years ago

  • Assignee changed from Sickboy to Sandiford

Haven't been able to make them really fire from it either though;
Sandiford perhaps some clue?

Updated by rocko over 4 years ago

  • Target version set to 395

Updated by Sandiford over 4 years ago

Artillery module targetting should be available soon.

Allowing AI to fire using the artillery module isn't generally simple, but there is one complication: AI guns are organised into batteries (by syncing to a game logic), so how would we know which battery the mortar should be part of?
Perhaps each group of AI would get it's own battery, with a func to access it. I have to wonder if anyone would ever use this though.

It sounds like there is another way of firing (something to do with selecting target by commanding AI?), guess I would have to try with some static mortars to see if/how that works

Updated by sgtmoody1944 over 4 years ago

Sandiford wrote:

http://dev-heaven.net/issues/15792

so this is fixed?

Yes sir.

Updated by Sickboy over 4 years ago

  • Status changed from In progress to Closed
  • Target version changed from 395 to 1.7
  • % Done changed from 80 to 100

Also available in: Atom PDF