Bug #15141

Javelin usage below minimum engagement range issues

Added by BlackRussian over 4 years ago. Updated over 2 years ago.

Status:Assigned Start date:11/14/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Weapons
Target version:-
Affected ArmA II version:1.62.95248 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

If shoot a Javelin to a T90 below minimum engagement range, the tank gets no damage whatsoever.

This doesn't happen with the T72 and similar. I suppose that the armor value is that high in case of an T90 that the Javelin damage isn't calculated.

Repro

To test it just add an T90[A] with you as a gunner or similar and put an US AT soldier with a Javelin behind you. Even if the Javelin hits you directly on top every damage indicator is still green.
Simply start the attached mission and wait until you get hit by the AT soldier.

Suggestions

Either
- Javelin targeting computer shouldn't let you fire below 150m range with top down attack
- Missiles shouldn't arm and thus not explode below 150m
- Target should receive damage from a near miss anyway

CIT_15141_T90Javelin.Desert_E.7z (666 Bytes) Fireball, 11/14/2010 22:46


Related issues

related to ARMA2 Community Issue Tracker - Feature #13930: Javelin direct attack mode Assigned 09/24/2010

History

Updated by Sickboy over 4 years ago

  • Project changed from ARMA2 Community Issue Tracker to A.C.E. for OA
  • Category deleted (Weapons)

Updated by Sickboy over 4 years ago

  • Due date set to 11/21/2010
  • Status changed from New to Feedback
  • Assignee set to Sickboy

Updated by Sickboy over 4 years ago

  • File T90_Repro.Desert_E.7z added
  • Category set to Complex

Updated by Sickboy over 4 years ago

  • File kabooooom.png added

Updated by Sickboy over 4 years ago

  • Subject changed from [ACE] Javelin has no impact on T90[A] in latest ACE for combined operations to Javelin has no impact on T90[A] in latest ACE for combined operations

Updated by Sickboy over 4 years ago

  • Affected Version set to 425

Updated by BlackRussian over 4 years ago

  • File T90Javelin.Desert_E.pbo added

Updated by Sickboy over 4 years ago

  • Project changed from A.C.E. for OA to ARMA2 Community Issue Tracker
  • Category deleted (Complex)

Updated by Sickboy over 4 years ago

  • Subject changed from Javelin has no impact on T90[A] in latest ACE for combined operations to Javelin has no impact on T90 sometimes
  • Affected ArmA II version changed from 1.55 BETA to 1.55.75445
  • I am using some Mods changed from Yes to No

Updated by Sickboy over 4 years ago

  • File deleted (kabooooom.png)

Updated by Sickboy over 4 years ago

  • File deleted (T90_Repro.Desert_E.7z)

Updated by Sickboy over 4 years ago

  • Assignee deleted (Sickboy)

Updated by BlackRussian over 4 years ago

  • File arma2.7z added

Updated by Fireball over 4 years ago

  • File CIT_15141_T90Javelin.Desert_E.7z added
  • Due date changed from 11/21/2010 to 02/21/2011
  • Category set to Other
  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

I can repro this with your mission - intriguing.

Attached in zipped editor version.

Updated by Fireball over 4 years ago

  • File deleted (T90Javelin.Desert_E.pbo)

Updated by Fireball over 4 years ago

  • File deleted (arma2.7z)

Updated by Fireball over 4 years ago

  • Affected ArmA II version changed from 1.55.75445 to 1.56 BETA

Updated by kju over 4 years ago

  • Affected ArmA II version changed from 1.56 BETA to 1.56.76134

Still true for me in 1.56 (5 of 5).

Updated by Fireball over 4 years ago

  • Due date deleted (02/21/2011)
  • Status changed from Assigned to Rejected
  • Assignee deleted (Dwarden)

I've just doublechecked the repro mission and the T-90 is below minimum engagement range for the (default and only available) top-down attack of the Javelin which is 150 m. As soon I move the T-90 to 150m roughly, it will be destroyed immediately.

So it should be a feature request to switch to direct attack mode which minimum engagement range will be 65 m.

http://www.inetres.com/gp/military/infantry/antiarmor/Javelin.html

Updated by BlackRussian over 4 years ago

Thanks for the information. But in this case the Javelin missile shouldn't hit the target or if it is possible to hit the target but don't do so much hazard in this case there should be at least some damage or no explosion sound.

Updated by BlackRussian over 4 years ago

Nevertheless a direct attack mode would be great too because you can also shoot down helicopters. :)

But imho more important is it to make the wired guided missiles like the Metis user controlled so they can be used for attacking buildings or helicopters like in RL. I mean besides the realism it is unfair that the Metis in Arma 2 (without ACE) has nearly the same capabilities as the Javelin but no lock on time.

Updated by Fireball over 4 years ago

BlackRussian wrote:

Thanks for the information. But in this case the Javelin missile shouldn't hit the target or if it is possible to hit the target but don't do so much hazard in this case there should be at least some damage or no explosion sound.

Either what you say, or the system shouldn't let you fire, because it would know that you're too close.

Updated by Fireball over 4 years ago

  • Subject changed from Javelin has no impact on T90 sometimes to Javelin usage below minimum engagement range issues
  • Status changed from Rejected to Assigned

Well, I've read again that the T-72 is not affected by the problem. Possibly an armor calculation issue too. I'm sure this could need some tweaking.

Updated title and added suggestions to avoid funny behaviour.

Updated by kju over 4 years ago

  • Due date set to 03/01/2011
  • Category changed from Other to Weapons

Updated by kju over 2 years ago

  • Affected ArmA II version changed from 1.56.76134 to 1.62.95248
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • I am using deleted (CO (A2+OA))

Updated by kju over 2 years ago

  • Due date deleted (03/01/2011)
  • Operating system deleted (Win7 64 bit)

Also available in: Atom PDF