Bug #15062

High View Distance causes "Buffer to small - nowhere to write the data"

Added by Fireball over 4 years ago. Updated about 4 years ago.

Status:Closed Start date:11/12/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Game freezes
Target version:1.56.76134
Affected ArmA II version:1.55.75445 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When you e.g. start the mission "Village Sweep" with ~ VD 6500 (or even higher), after the briefing, you are stuck in the "Receiving..." screen and the HDD trashes on forever, writing out tons of errors in the RPT:

(...)
Buffer to small - nowhere to write the data
Buffer to small - nowhere to write the data
Buffer to small - nowhere to write the data
Buffer to small - nowhere to write the data
(...)

When you reduce VD below 6000, the mission loads.

History

Updated by Fireball over 4 years ago

  • Assignee set to Dwarden

Updated by kju over 4 years ago

hm works for me. Did you check the rpt?

Updated by Fireball over 4 years ago

4 MB full with

(...)
Buffer to small - nowhere to write the data
Buffer to small - nowhere to write the data
Buffer to small - nowhere to write the data
Buffer to small - nowhere to write the data
(...)

Updated by Derbysieger over 4 years ago

This has something to do with the graphic settings. Since 1.55.74858 I'm not able to load Chernarus/Zargabad with the settings I usually use on Takistan when I fly planes:
1920x1080x32; 3DRes 2192x1232
VD 10000m (7000-8000 when playing on the ground)
PP Very Low, AA Low, AF High, Texture Detail High, Terrain Detail High, Objects Detail Very High, HDR Normal, VSync disabled

When I try that now the game is stuck at 'Receiving' screen and RPT gets spammed with 'Buffer to small - nowhere to write the data'.
Alt+Tab or Alt+F4 doesn't work. The Taskmanager is the only way to go. I have to change the VD before I play on Chernarus/Zargabad to ~6000 for Chernarus and ~4000 for Zargabad in order to load these maps without getting that error.

PC:
Win 7 64-Bit
GA-EX58-UD4P
Intel i7 920 @3,99GHz
6GB DDR3
Toxic HD 4870 1GB
Intel X25-M 80GB

Updated by Fireball over 4 years ago

  • Affected ArmA II version deleted (1.55)

I concur on all parts, but I didn't change any settings.

Updated by Fireball over 4 years ago

  • Affected ArmA II version set to 1.55.75445

Ah, the VD. Mine is over 6k by default. I'll try by reducing it a bit. Not what one would expect tbh.

EDIT: Yes, that helped, thanks! o_O

Updated by Fireball over 4 years ago

  • Subject changed from Scenario mission "Village Sweep" hangs game to High View Distance causes "Buffer to small - nowhere to write the data"

Updated by tonygrunt over 4 years ago

Have the same problem with many multiplayer missions I have tried to play the past day.
After some tests it seems to be some combination of VD and having Object Detail Very High.
For example, starting "Village Sweep" with VD=4000 and Object Detail Very High, I open display settings and start playing with VD.
It will almost always stuck immediately. Setting Object Detail to High or lower and then playing with VD will not display the problem.

PC specs:
Win 7 64-Bit
GA-X58A-UD7
Intel i7 920 @4.41GHz
12GB DDR3
Twintech GTX480 1536 MB
2*OCZ Vertex 120GB in Raid-0

Updated by SAbre4809 over 4 years ago

I'm getting the same, but only when leaving the map screen and at only 2000m VD. So game playing fine, look at map, press 'M' to exit map, recieving, with map still visible and other program(TS3) functions fine with Push To Talk key working fine aswell.
Only remedy is PC restart via main switch(in normal conditions ArmA Alt-tabs, Alt-F4s without a hitch). Happens 1/10 times approx. RPT full of

Buffer to small - nowhere to write the data
and not much else.

PC
Win XP 32
Nforce 650i sli
Intel C2D E6750 @ 2.66
2GB Ram
GForce 9800 GTX 512

All drivers upto date. Never had recieving bug in the past. Only started happening now with 1,55.

Updated by tonygrunt over 4 years ago

SAbre4809 wrote:

Only remedy is PC restart via main switch(in normal conditions ArmA Alt-tabs, Alt-F4s without a hitch). Happens 1/10 times approx. RPT full of [...] and not much else.

To avoid PC restart via main switch, ctrl-alt-del -> start task-manager and kill arma (you will have to use keyboard only as mouse is still grabbed exclusively by arma). At least this works in W7-X64, don't know about winxp.

Updated by SAbre4809 over 4 years ago

Yes it does but what I'm saying is I cant Alt-Tab, so I cant switch onto Task Man.(XP still uses the old Task Man. where it opens on desktop oppossed to that new way Vista/Win 7 have now).
So I Can start it but no control.

Updated by aeggwards over 4 years ago

I have the same issue since update 1.55. On using the map or free looking around on top left airfield on with a battle between 6 USMC and 4 Russian squads.

Specs:
Specs:
Intel i7 950
Nvidia 460GTX 1GB
6GB RAM
120GB SSD
Win 7 x64

Settings:
Res: 1680 x 1050
All settings on VH
Vsync enabled
VD: 5000

This problem didn't exisit until the last two betas. Will test with lower VD.

Updated by Suma over 4 years ago

Hotfixed in 75666.

Updated by Fireball over 4 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.56 BETA
  • Reproduced by another DH user changed from No to Yes

Updated by Suma over 4 years ago

Proper fix of the underlying cause implemented in 75755

Updated by kju over 4 years ago

  • Due date deleted (12/12/2010)
  • Target version changed from 1.56 BETA to Upcoming version

Updated by Hanzu over 4 years ago

SAbre4809 wrote:

Yes it does but what I'm saying is I cant Alt-Tab, so I cant switch onto Task Man.(XP still uses the old Task Man. where it opens on desktop oppossed to that new way Vista/Win 7 have now).
So I Can start it but no control.

In Windows XP (maybe Vista/7 too) if this happens with ArmA 2 (or any game) press CTRL+ALT+DEL and Task Manager will open behind the freezed game even though you don't see it opening). Then press TAB (to switch to End Task gadget) and after that press E (to End Task). Repeat TAB and ESC until game closes and you saved some time for not rebooting.


Still mystery is why 1.55 worked fine for one day in Chernarus Bitter Chill multiplayer before starting to freeze about 10 times when playing the very same mission and filling my ArmA2OA.RPT was 24MB including nothing else but
Buffer to small - nowhere to write the data
It seems that writing those lines to ArmA2OA.RPT continues until game is closed. I guess my specs here doesn't matter anymore since Suma has hopefully fixed it in the latest beta for me too, but I can also verify I had 10000 View Distance and most settings in Very High.

Freezed screens, black screens and never ending Receiving... screens occurred in Bitter Chill when:
4 times when driving east part of the road west of Krasnostav (after that I chose another route)
1 time when driving to back to FOB Manhattan main gate and when cutscene should have appered
3 times when loading saves
1 time when exiting vehicle after long drive

Between those freezes I played 05 Steel Panthers mission for a quite long time without a single freeze. So yes, it is only related to some heavy maps like Chernarus.


EDIT: Everything is fine here too with 1.56.76134. Played Bitter Chill with View Distance 10000 several hours without a single freeze or crash. Great!

Updated by kju over 4 years ago

  • Target version changed from Upcoming version to 1.56 BETA

Please test and report back with the new beta patch out.

Updated by Derbysieger over 4 years ago

Everything's fine with the latest beta (76067). Even if I set everything to max (including 3DRes)on chernarus the map still loads. It's unplayable of course (0-3fps)^^

Updated by kju over 4 years ago

  • Status changed from Resolved to Closed

ty

Updated by kju about 4 years ago

  • Target version changed from 1.56 BETA to 1.56.76134

Also available in: Atom PDF