Feature #14853

nickname Killer Tiger : M26 pershing tank wanted in the mod

Added by colonel29 almost 5 years ago. Updated over 4 years ago.

Status:Closed Start date:11/02/2010
Priority:Trivial Due date:
Assignee:- % Done:

0%

Category:-
Target version:Maybe
Close Reason: I am using some Mods:No
Affected Version: I am using:
Graphics card driver version: Reproducible for you:No
Affected ArmA II version:Please select... BIForumURL (Use new instead):
Reproduced by another DH user: Single / Multi Player?:

Description

can you build a M26 pershing tank for I44 mod ?

[[http://img716.imageshack.us/img716/4496/53596627.jpg]

History

Updated by canukausiuka almost 5 years ago

  • Priority changed from Urgent to Trivial

Updated by Macolik over 4 years ago

  • Target version set to Maybe

Updated by OrdeaL over 4 years ago

Wasnt that thing around in 45? and def not normandy?

Updated by Hannibal78 over 4 years ago

that's right but i think we need the pershing immediately as a counterpart for the tiger /kingtiger
especially if penetration module in use

Updated by OrdeaL over 4 years ago

I see what your saying but at the same time thats like saying why dont we put a Abrams in to counter it because that wasnt around yet either.. Its a numbers game against those German Big Cats so missions will have to have a lot more Allied tanks and air support like RL? Maybe a Firefly could help ;)

Updated by ArthurA over 4 years ago

I would say that first make Tank Destroyers (TD) that were quite common; Wolverine M10, Jackson M36, Achilles, Hellcal M18 etc...

Updated by PacUK over 4 years ago

  • Status changed from New to Closed
  • Affected ArmA II version set to Please select...
  • I am using some Mods set to No
  • Reproducible for you set to No

M26 was not present during the timeframe of the mod, those tanks that were used for this role are more likely to be produced for the mod.

Also available in: Atom PDF