Bug #14806

Music skipping using 'esc' key

Added by Sumrak almost 5 years ago. Updated about 3 years ago.

Status:Assigned Start date:11/01/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

90%

Category:Sound
Target version:-
Affected ArmA II version:1.63 Beta First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Using esc key (ingame menu) i'm able to skip currently played music track very fast.
Example: http://www.youtube.com/watch?v=opoR7GpJWHU

Tested on OA, CO, only Arma II, on beta patches or stable versions. No changes.
Tested also on another pc, same issue.
I'm not sure, but i think, this issue is in ArmA II since release (i don't remember time, where i didn't have this bug).

arma2oa 2012-05-23 19-39-51-71.avi (6.9 MB) Danil-ch, 05/23/2012 12:46


Related issues

related to ARMA2 Community Issue Tracker - Bug #21653: Collective sound engine issues ticket Assigned 07/01/2011 06/14/2012

History

Updated by kju almost 5 years ago

  • Due date set to 02/01/2011
  • Category changed from Gameplay to Scripting: Problem
  • Status changed from New to Assigned
  • Affected ArmA II version changed from Please select... to 1.55 BETA
  • I am using set to OA only
  • Reproducible for you changed from No to Yes

I think to recall BI scripted the music stop and resume system.
Seems like it is not working correctly.

Updated by zGuba almost 5 years ago

  • Category changed from Scripting: Problem to Sound

Updated by zGuba almost 5 years ago

It's more about sound engine I guess, since detecting game beign paused is quite difficult if possible at all?

Updated by Sickboy almost 5 years ago

Game paused is generally when diag_tickTime progresses but time does not.

Updated by kju almost 5 years ago

Cannot find a related script. Maybe was someone else at OFPEC or so.

Updated by kju over 4 years ago

  • Due date changed from 02/01/2011 to 06/01/2011
  • Operating system deleted (Win7 64 bit)
  • Graphics card deleted (NVIDIA 8600M GT)
  • Affected ArmA II version changed from 1.55 BETA to 1.58.78473
  • CPU deleted (Intel Core 2 Duo T8100)
  • System RAM size deleted (3)
  • GPU VRAM size deleted (512)

Updated by Danil-ch over 4 years ago

Still true in 1.59.

Updated by kju over 4 years ago

  • Affected ArmA II version changed from 1.58.78473 to 1.59.78955

Updated by kju over 4 years ago

  • Target version set to 1.59 BETA
  • Language set to Please set for missions

Updated by kju over 4 years ago

  • Target version deleted (1.59 BETA)

Updated by kju over 4 years ago

  • Affected ArmA II version changed from 1.59.78955 to 1.59 BETA

Updated by Danil-ch over 3 years ago

Still true in 1.60.

Updated by Dwarden over 3 years ago

  • Status changed from Assigned to Resolved
  • Assignee set to Dwarden
  • Target version set to 1.61 BETA
  • % Done changed from 0 to 90
  • Reproduced by another DH user changed from No to Yes

Music will often stop playing after OA/TOH window focus is lost and regained.

Should be fixed as of build 92951

Updated by Danil-ch over 3 years ago

Not fixed but get better.
Now you need to press 'esc' a lot more times.

Updated by Dwarden over 3 years ago

it will skip small buffer of 0.18s
no idea about cummulative effect of repated multiple ESC or rapid ESC pressing ;)

Updated by Danil-ch over 3 years ago

Still true in 93348

Updated by kju about 3 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Updated by kju about 3 years ago

  • Due date deleted (06/01/2011)
  • Status changed from Resolved to Feedback
  • Affected ArmA II version changed from 1.59 BETA to 1.61 Beta

Can you please try with the latest 1.63 beta.
AFAIK some changes may have effected this.

Updated by Danil-ch about 3 years ago

Still true in 95883
note in arma 1 it works fine

Updated by kju about 3 years ago

  • Status changed from Feedback to Assigned
  • Target version deleted (1.62.95248)
  • Affected ArmA II version changed from 1.61 Beta to 1.63 Beta

ok thanks for testing!

note: arma1 used a different sound engine altogether

Also available in: Atom PDF