Bug #14669

Tanks firing everything from their machine gun

Added by Flanker15 almost 5 years ago. Updated over 4 years ago.

Status:Closed Start date:10/26/2010
Priority:High Due date:
Assignee:Dwarden % Done:

0%

Category:Animations
Target version:1.59.79384
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Tanks and IFV are firing their main gun through their coaxial weapon.

Effects:
-Projectile emits from the coax.
-Muzzelflash emits from the coax.
-Tank receives a physics recoil equivocal to the machine gun not the main gun, the tank won't rock back like it should.
-Dust plume which is supposed to expand out from the tank when it fires it's main gun dose not appear.

Versions affected:
-All versions post v1.07 including (1.07) Arma 2
-All versions and betas [74123] of OA and CO.

Vehicles that function correctly:
-T-55
-BMP-3

M1.JPG - An M1 firing it's maingun through the coax. (99 kB) Flanker15, 10/26/2010 16:28


Related issues

related to ARMA2 Community Issue Tracker - Bug #14308: FV510 Warrior (Muzzleflash) Assigned 10/10/2010
related to ARMA2 Community Issue Tracker - Bug #14046: Firing a tanks maingun also plays the coaxial machine gun... Closed 09/28/2010 09/14/2011
related to ARMA2 Community Issue Tracker - Bug #14863: Missing dustwave effect from firing the tank main gun Closed 11/03/2010
related to ARMA2 Community Issue Tracker - Bug #14821: [BETA CO] Vehicles have no physical recoil firing the mai... Closed 11/01/2010

History

Updated by Flanker15 almost 5 years ago

Bug #14046 is also related to this.
Other vehicles that are working correctly:
-All BMP-2, LAV-25, BTR, Bradley, AAV7 and BRDM varients.

Updated by zGuba almost 5 years ago

there was config switch shotFromTurret = 1 that was used to use turret center as muzzle for given weapon. Has it been broken?

Updated by BigDawgKS almost 5 years ago

No, it still works as intended (it's for MG based weapons). Cannon based weapons are supposed to be hardcoed to fire from the correct place (and never used shotFromTurret), so it seems something else broke.

Updated by Fireball over 4 years ago

  • Status changed from New to Assigned

Updated by Flanker15 over 4 years ago

2 more that are related:
Bug #14863
Bug #14821

Updated by Dwarden over 4 years ago

  • Category set to Animations
  • Assignee set to Dwarden
  • Priority changed from Normal to High
  • Target version set to Upcoming version

Updated by Danil-ch over 4 years ago

Still true in 1.57. and 77068

Updated by kju over 4 years ago

  • Due date deleted (01/27/2011)
  • Status changed from Assigned to Closed
  • Target version changed from Upcoming version to 1.58.78473

Fixed in 1.58.

Updated by kju over 4 years ago

  • Target version changed from 1.58.78473 to 1.59.79384
  • Language set to Please set for missions

Also available in: Atom PDF