Bug #14629

Inaudible gun sounds

Added by BigBoss almost 5 years ago. Updated almost 5 years ago.

Status:Closed Start date:10/24/2010
Priority:High Due date:11/05/2010
Assignee:Sickboy % Done:


Target version:1.6
Component: Affected Version:
Close Reason:


Playing multiplayer using ACEX_SM I can hear my own gun but my team mates don't hear it or see it's muzzle flash when I fire and likewise I don't hear their weapons being fired, I just only see and hear impacts. This is weird and annoying because I couldn't tell whether our Ar was engaging targets or not.

This seems to only affect BLUFOR weapons:
Assault Rifles and SMGs (M4,M16,G36,MP5) when fired in semi automatic mode are inaudible for team mates however when fired fully automatic they are audible.
LMGs (M249,M240) are always inaudible.

OPFOR weapons and CSW seems to be unaffected.

We were all using ACEX_SM, we tested it with different sound mods but in all cases guns were inaudible from the outside.

Mission__RPT.rar (560.2 kB) columdrum, 10/25/2010 21:30

SoundBUgTest.Takistan.pbo - Sound bug demostration (4.9 kB) columdrum, 10/26/2010 19:50

Soundbug_Client_and_server_RPT.rar - sound bug with only ACE (2.2 kB) columdrum, 10/27/2010 16:47

ace_c_weapon.pbo - nvgoggles back to normal slots (1.7 MB) Sickboy, 10/28/2010 21:39


Updated by Xeno almost 5 years ago

  • Category deleted (Config)
  • Status changed from New to Feedback
  • Priority changed from High to Normal


ACEX_SM is working fine, also on non ACE servers.
Take a look at the link above on how to report bugs.
The issue you describe is most likely caused by another addon/addons.

Updated by columdrum almost 5 years ago

I am having this issue too :S, and i am only using ACRE + ACE, so may be this combination, will try later with ACE alone. Also another side note, seems to happen only on one missions of all that i have tried so may be a ACRE+ACRE + some mission conditions... if i find what is exactly i will post here, do the same if you found something ^^.

EDIT: nothing to do with ACRE happens alson without it, its only a mission problem i will try to find out what is exactly. I will attach the mission and the RPT later

Updated by columdrum almost 5 years ago

Added mission and RPT that produces the problem :( (the RPT is with ACRE, but it happens also without it).

I know that the missions has to many scripts :P, and its a hell to find what causes it ^^. Well if i find anything i will post here may solve BigBoss problems too.

Updated by Sickboy almost 5 years ago

  • Category set to Sound
  • % Done changed from 0 to 20

We were all using ACEX_SM, we tested it with different sound mods but in all cases guns were inaudible from the outside

That means it didn't matter if ACEX_SM was used or another soundmod, the specific sounds were never transfered to other players?

In any case, it sounds pretty weird that when everyone has equal mods+versions, you can hear the sounds locally but not remotely, generally it would indicate that not everyone is running the same.

Also important is Beta vs non Beta, and if everyone runs them, or doesn't run them, etc.

@Columdrum; does the problem still occur even if you disable script inits completely? ( remove init.sqf etc ).
There's plenty of errors / problems in the rpt that could indicate desynchronized config inheritance tree between the server, and client(s).

Updated by columdrum almost 5 years ago

Finally found it, a really really weird issue, use the repro mission attached.

Steps to reproduce:
1-Start it on a dedicated server
2-Take any weapon( for example a dmr) from the ammobox near to the spawn.
3-You won't hear or see the muzzleflash of the shot but you will see and hear an see the impacts.

This was introduced in last update, because it wasn't happening on previus one

The script that produces the error is really simple:

sleep 1;
waitUntil {!isNull player};
_Posicion = getpos player;
sleep 2;
removeallweapons player;

I think that it's just the removeallweapons done after some seconds on the start, but well.... i had been hours testing until i reduced it to this ones soo it should be enought :P.

Updated by Xeno almost 5 years ago

Just tested the mission a few seconds ago on a dedicated server.
No problems at all.

I could see the muzzleflash, see the impact and hear the weapon shooting.

What about the other addons you are using ?
Have you tried without @JayArma2Lib;@ACRE;@CHS ?

Additionally you have some base class updates:

Updating base class ->Mi17_base, by ca\air\config.bin/CfgVehicles/Mi17_base_Ins/
Updating base class ->Mi17_base_RU, by ca\air\config.bin/CfgVehicles/Mi17_rockets_RU/
Updating base class ->UAZ_Unarmed_Base, by ca\wheeled_e\config.bin/CfgVehicles/UAZ_Unarmed_TK_EP1/
Updating base class ->BRDM2_Base, by ca\wheeled_e\btr60\config.bin/CfgVehicles/BTR60_TK_EP1/
Updating base class ->ACRE_BaseRadio, by x\acre\addons\sys_prc119\config.bin/CfgAcreRadios/ACRE_PRC119/

Those are not caused by ACE (ACE is currently not causing any rpt warnings or errors)

Updated by columdrum almost 5 years ago

Good point, maybe one of the included in @CHS[ DAC, MAP_EU, or sg_runavinfdes ] causes, still really weird. More testing tomorrow :P, so it may not be a ACE bug more a conflit of ACE with other mods :(.

By the way the removeallweapons doesn't remove the new rucks included on some models, maybe it's caused by te conflict too

Updated by columdrum almost 5 years ago

By the way, you tested it with somebody?, because you can see your own but not the ones from others players, thats the bug. Well, tomorrow i will post the results with only ACE.

Updated by Xeno almost 5 years ago

Hm, no, not tested with other players. Will try again tomorrow.
Though I have played with others last saturday and also missions with removeweapons but everything was fine then.

Updated by Sickboy almost 5 years ago

  • % Done changed from 20 to 30

@Columdrum; conflicts can be resolved once pinpointed; so :-D instead of :-( :D

Updated by columdrum almost 5 years ago

Confirmed with ACE alone(No beta patches) using the soundbug.pbo attached before.

Here the client and server RPT. The problem seems to be the removealweapos after a little sleep(2-3 seconds), i also noticed that now the removeallweapons doesn't remove the backpacks :S . It's soo weird that maybe it's and engine bug , but still it didn't happen on previus version :s.

Updated by Xeno almost 5 years ago

Removeallweapons doesn't remove BIS backpacks (if units have them)

Updated by q1184 almost 5 years ago

Is it reproduceable without ACE?

Updated by columdrum almost 5 years ago

No, only happens with lastest version of ACE. With Arma2 vainilla or previous versions of ace wasn't happening. The strange thing it's that only happens with some weapons like m4, but you can hear misile launcher or vehicles shooting

Well... i already fixed the mission changing the removeallweapons from the script to the init line of all playable units( a hell... there where 120 slots :P)

Temporally workaround:
Just put the removeallweapons on the unit init.

EDIT:I was wrong still not tested with Arma2 OA vainilla yet, someone said that but, he was runing ace. I am really bored of this one, maybe i will do some more testing this weekend.

Updated by Sickboy almost 5 years ago

Well there was something changed re M4 and Burst modes, etc, perhaps it is somehow related leading to this bug in engine.
I'll try to find the change and send a reverted copy to try.

Updated by Sickboy almost 5 years ago

  • Target version set to 395

Updated by rexehuk almost 5 years ago

To update further... not sure if this has been mentioned

MK16 - Full Auto (Continuous Burst) - ALL PLAYERS HEAR THE AUDIO

Reproduceable in MP on any mission.

Updated by Sickboy almost 5 years ago

  • Priority changed from Normal to High

Updated by Sickboy almost 5 years ago

  • Assignee set to Sickboy
  • % Done changed from 30 to 40

Xeno and me can't reproduce it.
We tested the test mission, both with ACEX_SM. The server without.
Running beta 74123. Also did not get the message re magazines (Cannot use magazine 30Rnd_545x39_AK in muzzle BAF_ied_v4_muzzle and Cannot use magazine ACE_5Rnd_25x59_HEDP_Barrett in muzzle BAF_ied_v4_muzzle).
Though perhaps that was specific to the full mission.

Perhaps it is solved in the current development version, otherwise stumped.

Updated by Xeno almost 5 years ago

Can you test again tomorrow after the next release is available again ? (If possible as fast as possible :))

Updated by Sickboy almost 5 years ago

Perhaps it was somehow related to the NVGoggles as Item, re #14689 etc?
Please try attached addon (server+all clients, note; unsigned atm)

Updated by columdrum almost 5 years ago

It's really weird, we where using just arma2 OA CO 1.54(no betas) + ACE, with signature checking(so no corrupt files) and nothing else.

I have no much time till tuesday 2 :( , but if i have a moment with some friend i will try to test it.

Hope it's fixed, but once i found what it was(took me some hours of testing), it's not a big problem ^^.

Updated by Sickboy almost 5 years ago

Any news on this one with the current version?

Updated by columdrum almost 5 years ago

Its solved in ACE 1.6 RC2 Update, at least i can't reproduce it anymore :D

Updated by Sickboy almost 5 years ago

  • Due date set to 11/05/2010
  • Target version changed from 395 to 1.6
  • % Done changed from 40 to 80

Weehaw; some welcome good news! (dance)
Leaving open till Friday.

Updated by Sickboy almost 5 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

Also available in: Atom PDF