Bug #14601

Artillery aim is off

Added by Sickboy about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:10/23/2010
Priority:Normal Due date:
Assignee:Xeno % Done:


Target version:1.6
Component:sys_bi_arty Affected Version:
Close Reason:


By Gunterlund21:

Hi all
Working with the standard BIS arty module and it looks like there is a change in ACE again where the rounds are coming up short with the standard module. Has this been mentioned at all. Is there any detail docs on the interaction with ACE and the ARty system. Something seems to change between ACE version that affects the BIS arty module.

Added possibly related tickets, it's also said there's arty changes in oa betas.

Related issues

related to A.C.E. for OA - Bug #14494: All artillery max ranges are wrong Rejected 10/19/2010

Associated revisions

Revision 6a3a288b
Added by Sickboy about 5 years ago

~ CHANGED: Reapplied Sandiford's Dispersion settings for ARTY. refs #14601


Updated by Sandiford about 5 years ago

Those tickets are unrelated

this is a duplicate: http://dev-heaven.net/issues/13499 (incorrectly marked as a duplicate of what seems to be an unrelated issue)

As far as I know the artillery module in 1.54 vanilla doesn't work at all - the targetting reticle doesn't come up

In ace_sys_bi_arty the reticle comes up, but the rounds land way short (e.g. 20%)

We abandonned it as we had a new targetting system almost done (super-simplified ballistic computer, enter grids, returns elevation/azimuth), however this uses the vanilla arty module's functions, so it should be possible to fix it

Updated by Sickboy about 5 years ago

  • % Done changed from 0 to 20

Thanks Sandiford, unsure why the claim is then that the effects changed when updating ACE.
Perhaps there was also an update of Beta, or switch from vanilla to beta, however since you say arty is weird on 1.54 as well, it all seems awkward.

Updated by rocko about 5 years ago

  • Target version set to 1.7

Updated by Evil_Echo about 5 years ago

The range problem can reproduced with a simple manual fire mission using BIS's functions while running ACE. No ballistic computer involved.

Create a simple mission with a couple mortars per the BI wiki page for the artillery module and include a command similar to.

[_battery, _coords,  ["IMMEDIATE", "HE", 0, 6]] spawn BIS_ARTY_F_ExecuteTemplateMission;

My tests create a marker at the same location as _coords to verify the aimpoint. Something is effecting either the aim angle or the muzzle velocity of the rounds. Best guess is an event handler for fired rounds is interacting in a bad way with the BI ARTY module, causing the post-boost velocity after leaving the tube to be incorrect.

Updated by Nou about 5 years ago

EE is probably right, but I checked the config values and they look the same in OA as they do in A2... I think that it has to be the internal artillery engine that OA has which is screwing with things. I am not sure what it is. I tried using the function to disable it, but it was acting odd still.

I dug around in sys_bi_arty and tried to fix a number of issues but the main thing is that shells were being caught, deleted, then spawned (like normal) for all clients, but the spawned shells were non-existent. I don't know if this is an issue with the ACE arty magazine/ammo classes or what, didn't look into it much further cause I just got frustrated at the futility of fixing a system that in itself is sorta crap anyways.

With that I am redoubling my efforts for player controlled arty that is custom built from the ground up (mortars, like the M224, but I am actually scratch building a M120 first).

Updated by Sickboy about 5 years ago

  • % Done changed from 20 to 30

Updated by Sickboy about 5 years ago

All Fired EH's of the M252;
From ingame:
[[{if ((_this select 4) isKindOf 'MissileBase') then { if (local ((_this call CBA_fnc_getFirer) select 0)) then { _this call ace_sys_missileguidance_fnc_fired }};;;if (not isnil {(_this select 0) getVariable 'ace_sys_sight_adjustment_params'}) then {_this call ace_sys_sight_adjustment_fnc_fired};;if ( ((_this select 4) isKindOf 'MissileBase') || ((_this select 4) isKindOf 'RocketBase') ) then { _this call ace_sys_muzzleblast_fnc_fired };;;;if (player in crew (_this select 0)) then { _this call ace_sys_camshake_fnc_fired_veh };_this call BIS_Effects_EH_Fired;;}]]

From config browser;

Will need a repro mission that works for vanilla, and for ACE, and preferably rpt of both runs (working vs broken).
Also wondering if results are different when using BIS Arty Module vs ACE Arty module when running ACE.
Last thing to try is ACE minus ace_sys_bi_arty.pbo .

Sandiford could you perhaps provide this?

Updated by Sandiford about 5 years ago

Player Controlled

    Artillery Computer:

        Works correctly with 8Rnd_81mmHE_M252 and ACE_ARTY_8Rnd_81mmHE_M252

        ARTY_8Rnd_81mmHE_M252 appears to work correctly on "close" (min/max I think is the same as the original arty module), on higher charges the firing solutions are incorrect and it lands short

        I think that ARTY_ rounds' velocity is not changed by the Arty Computer, and "close" uses it's default velocity and ballistics

    BI Artillery Module:

        8Rnd_81mmHE_M25 - Map comes up, no reticle
        ARTY_8Rnd_81mmHE_M252 - works
        ACE_ARTY_8Rnd_81mmHE_M252 - Artillery Computer interferes causing misses

    ACE Artillery Module:

        No target action - probably intentionally disabled

AI Artillery

    BI Artillery Module

        standard (non ACE/ARTY) mags on a podnos work

    needs further testing


Summary for mission makers:
You can use Artillery Computer + Standard Mags
BI Artillery module + ARTY_ mags

Question: Does anyone know what the ACE arty module is actually for?

Updated by Xeno about 5 years ago

Sandiford wrote:

Question: Does anyone know what the ACE arty module is actually for?

Probably introduced because the A2 arty module was facing long lasting bugs ?

I'm removing it now. Should have done that much earlier.

Updated by Xeno about 5 years ago

  • Category deleted (Complex)
  • Status changed from Feedback to Rejected
  • Assignee deleted (Sandiford)
  • Target version deleted (1.7)
  • % Done changed from 30 to 0

ACE artillery module removed (the modules will now start the BIS artillery module, some classes left for compatibility reasons, ammo and magazines inherit from BIS artillery module)

Updated by Sickboy about 5 years ago

Sandiford's Custom damage values reapplied in c_weapon.
Dispersion changes are disabled for now; let's wait until after 1.6 stable, to experiment again.

Updated by Sickboy about 5 years ago

Related issue @ CIT, re the OA Betas with extended Fired Eventhandlers;

Updated by Sickboy about 5 years ago

  • Category set to Complex
  • Status changed from Rejected to Closed
  • Assignee set to Xeno
  • Target version set to 1.6
  • % Done changed from 0 to 100
  • Component set to sys_bi_arty

Closed 100% seems a better status for it especially after later findings re #14502 and workarounds, as well as the cleanup of our bi arty override :D

Updated by Evil_Echo about 5 years ago

Thank you.

Updated by gunterlund about 5 years ago

Arty seems to be working better now with the shut down. Especially third party addons including director and R3F. Thanks for doing this.

Updated by Sickboy about 5 years ago

NP, glad it is working fine again! If you experience any more issues, let me know!

Also available in: Atom PDF