Bug #14491

Artillery module RPT error

Added by Das_Attorney almost 5 years ago. Updated over 4 years ago.

Status:Closed Start date:10/18/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

90%

Category:BI Modules
Target version:1.56.76134
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Repro:
  1. Install attached mission
  2. run mission
  3. activate -showscripterrors or check rpt on mission exit

Obs:
Artillery will fire automatically
On each fire mission called, errors write to the RPT

Exp:
As per 1.54 behaviour, the errors should not occur

Notes:
Please note, the ammunition has been left as default. I also tried it with the following in each 2B14 init line:

this removemagazines "2b14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14"; this addmagazine "ARTY_8Rnd_82mmHE_2B14";

I don't know the significance of these errors. I felt as if I should report because they were not present in 1.54. Thanks

RPT_test1.Chernarus.7z (1.4 kB) Das_Attorney, 10/19/2010 00:00

RPT_test_spawn.Chernarus.7z (1.4 kB) Das_Attorney, 10/20/2010 21:57

rpt.txt (4.2 kB) Das_Attorney, 10/20/2010 22:08

History

Updated by Das_Attorney almost 5 years ago

Beta version is 74123. (The error first appeared in earlier betas).

Clarification: Errors persist after changing ammunition to ARTY equivalent

Updated by Das_Attorney almost 5 years ago

Here's the file. I can't see it in the initial post.

Updated by Das_Attorney almost 5 years ago

I was asked to try this again using the command spawn instead of call for BIS_ARTY_F_ExecuteTemplateMission, but the results are the same.

Please see attached file for example mission.

Updated by Das_Attorney almost 5 years ago

rpt added - did not post it originally.

Updated by kju almost 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Operating system deleted (Win7 64 bit)
  • Graphics card deleted (ATI HD5870)
  • Graphics card driver version deleted (10.9)
  • CPU changed from Intel Xeon 920 quad to x
  • Mainboard chipset deleted (UD5)
  • System RAM size deleted (6)
  • GPU VRAM size deleted (1)
  • Audio card deleted (motherboard)
  • Size of OS swap file deleted (6114)

ty

Updated by Headspace almost 5 years ago

What I know is this: The new beta breaks the artillery module. But I know what's causing it. These errors probably have something to do with the same issue. Stay tuned.

Updated by Dwarden almost 5 years ago

  • Status changed from Assigned to In progress
  • Target version set to Upcoming version
  • % Done changed from 0 to 10
  • Reproducible for you changed from No to Yes

Updated by Headspace almost 5 years ago

I reproduced it and it was, indeed, due to what I thought it was.

Updated by kju almost 5 years ago

  • Due date changed from 01/18/2011 to 12/01/2010
  • Status changed from In progress to Feedback

It seems there were some changes in the ARTY module code.
It might be fixed. Can you please tested and report back. Ty.

Updated by kju over 4 years ago

  • Due date changed from 12/01/2010 to 12/14/2010

Is this fixed in 1.55 / 1.56?

Updated by Dwarden over 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 10 to 90

this should be fixed in 1.56 , if not please say so

Updated by kju over 4 years ago

  • Due date deleted (12/14/2010)
  • Target version changed from Upcoming version to 1.56.76134

Updated by Dwarden over 4 years ago

  • Status changed from Resolved to Closed

this should be fixed ... so closing

Also available in: Atom PDF