Bug #14480

Once you suspend and continue a mission from the editor it's not possible to exit it anymore.

Added by test over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:10/18/2010
Priority:Normal Due date:12/01/2010
Assignee:Dwarden % Done:

0%

Category:Mission editor
Target version:1.56.76134
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
Once you suspend and continue a mission from the editor it's not possible to suspend it anymore.
Every attempt to suspend a continued mission (ESC -> Suspend) results in the mission being saved and then continued.
So you end up being trapped in it.

Restarting the mission is possible but does not solve the problem.
The only way out is closing the game.

Repro
  1. Load the editor
  2. Load any mission (must be done) (ie the attached one)
  3. Launch it
  4. Esc-suspend
  5. Continue button
  6. Esc-suspend
  7. Note that it saves instead of the desired back to the editor

Note
This happens in windowed mode. I don't know if it also happens in fullscreen mode.

History

Updated by test over 4 years ago

I think I found out what causes the above mentioned problem.

When loading a mission directly from the shortcut (as described in the Biki) a wrong path for the save file is constructed. Here's what ProcMon reports:

arma2oa.exe    3764    CreateFile    C:\Users\foo\Documents\ArmA 2 Other Profiles\bar\Saved\c:\users\foo\documents\arma 2 other profiles\bar\missions\test.desert_e\continue.ArmA2OASave    NAME INVALID

Updated by kju over 4 years ago

  • Due date set to 12/01/2010
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from No to Yes
  • I am using set to OA only

ty

Added specific repro details. You must load a mission first for the bug to appear.

PS:
There are two workarounds.
1) Kill yourself (with a console or via ingame weapons etc).
2) Hide the continue button of the editor (it is basically useless anyway).

Updated by kju over 4 years ago

  • Due date deleted (12/01/2010)
  • Status changed from Assigned to Resolved
  • Target version set to 1.55 BETA
class RscDisplayMPInterrupt: RscStandardDisplay

        class CA_B_Skip: CA_B_SAVE
        {
            idc = 1002;
            text = "Skip";
        };

Seems fixed for me. Probably due to the above changed.
Please confirm.

Updated by test over 4 years ago

Can't confirm. This bug was not fixed (tested with 74858).

The problem is in the way the path for the save file is constructed (see ProcMon output above). It is unlikely that changes in the config will make it go away.

Updated by kju over 4 years ago

The point is the save file is obsolete / a relic from old ofp days not made in use.
It does not matter if the saving broken or not, right?
In other words the broken savegame does not matter as it cannot be used anyway.

The undesired behavior is that it does not return to the editor.

This works fine for me now. Confirmed once again just now.

So please follow the repro steps exactly above and report back if you remain in the mission
unable to exit it or if you end up in the editor now.

Updated by test over 4 years ago

Tried with 74858:

It is still not possible to exit a once "Suspend"ed and then "Continue"d mission if the mission was loaded directly "from the shortcut" (see BIKI link above).

Updated by kju over 4 years ago

  • Due date set to 12/01/2010
  • Status changed from Resolved to Feedback

hm works for me also :|

Updated by kju over 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Updated by Fireball over 4 years ago

  • Status changed from Feedback to Resolved
  • Affected ArmA II version changed from 1.55 BETA to 1.56.76134

Works for me.

Updated by Fireball over 4 years ago

  • Target version changed from 1.55.75445 to 1.56.76134
  • Affected ArmA II version changed from 1.56.76134 to 1.55 BETA

Updated by Dwarden over 4 years ago

  • Status changed from Resolved to Closed

this should be fixed ... so closing

Also available in: Atom PDF