Bug #14397

[OA] Stuttering in cities and even small villages

Added by kju over 4 years ago. Updated 10 months ago.

Status:Closed Start date:10/13/2010
Priority:Normal Due date:
Assignee:admin % Done:

0%

Category:Performance breakdown
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
There is a considerable drop in FPS for a brief at times,
when you move inside towns. This results in short stutters.
It can also be noticed if you turn or zoom in (RMB/optics).

Hopefully at attached mission can demonstrate this somewhat.

The game is run on an Intel M SSD.
The 3 GB OS swap file is located on a RAM drive.

Zargabad is a lot worse, as well as overall FPS way lower.
However it is likely due to the sheer density of buildings.
We play it with 1500 VD normally.

Repro
  1. Disable v-sync
  2. Use your normal graphic settings (very high)
  3. Run the attached mission
  4. It will be a fast camera moving through a village
  5. Notice the occasional stutter/FPS drop.

VD is set to 2500 and terrain detail to low in the mission.

_TEST_FPSXXX3.takistan.7z (2.1 kB) kju, 10/13/2010 11:52

FPS_chart.xls (17 kB) kju, 11/27/2010 09:33

ecl_combi_chak-chak_12.takistan.7z (7.4 kB) kju, 11/27/2010 09:33

1stRun.jpg (25.1 kB) kju, 11/27/2010 09:33

2ndRun.jpg (25.1 kB) kju, 11/27/2010 09:33

IngameGraphicSettings.jpg (125 kB) kju, 11/27/2010 09:33

FPS_chart.jpg (166.7 kB) kju, 11/27/2010 09:33

DxDiag.txt (60.7 kB) kju, 11/27/2010 10:12

LowFPS.Takistan.7z (714 Bytes) kju, 04/15/2011 18:22

dispersed_rubble_fps_crashing_2.jpg (308.3 kB) kju, 04/15/2011 18:23

House_C_4_EP1.jpg (128.3 kB) kju, 04/15/2011 18:23

fps_graph_junkpile.jpg (173.3 kB) kju, 04/15/2011 18:23

dispersed_rubble.jpg (167.5 kB) kju, 04/15/2011 18:23

dispersed_rubble2.jpg (180.4 kB) kju, 04/15/2011 18:23

dispersed_rubble_fps_crashing_1.jpg (275.4 kB) kju, 04/15/2011 18:23


Related issues

related to ARMA2 Community Issue Tracker - Bug #15521: [PMC] Zargabad map stuttering Closed 12/02/2010
duplicates ARMA2 Community Issue Tracker - Bug #1745: Stuttering in cities and even small villages Closed 06/03/2009 11/01/2010

History

Updated by Suma over 4 years ago

  • Status changed from Assigned to Resolved

Edit: mistake in which window I should write to. Sorry. No update here yet.

Updated by Suma over 4 years ago

  • Status changed from Resolved to Assigned
  • Assignee set to Suma

Updated by kju over 4 years ago

  • Due date changed from 12/01/2010 to 02/01/2011
  • Graphics card changed from ATI Radeon 4980 HD to Gigabyte GTX 460 OC
  • Graphics card driver version changed from 10.9 to 260.99
  • Affected ArmA II version changed from 1.55 BETA to 1.56 BETA
  • I am using changed from OA only to CO (A2+OA)

Updated by kju over 4 years ago

New demo mission attached - requires CO.

Its based on a PvP league missions.
There is a lot of big FPS drops and mini freezes while moving,
turning and zooming inside the small villages.

Removed all scripts and added the camera sightseeing flight instead.
Notice the two big FPS drops in the FPS_chart.jpg.

Also significantly less in the second run.

Updated by kju over 4 years ago

Updated by Alex72 over 4 years ago

Stutter is indeed a problem that has been there from start IIRC. Even with new videocard HD 6970 i get that stutter when zooming in (RMB) and out. Although much less than with GTX275 Nvidia. Not lag but stutter that when it goes away after some second(s) the FPS is amazing again.

Updated by kju about 4 years ago

  • File LowFPS.Takistan.7z added
  • Due date changed from 02/01/2011 to 07/01/2011
  • Graphics card driver version changed from 260.99 to 270.51
  • Affected ArmA II version changed from 1.56 BETA to 1.60 BETA
  • System RAM size changed from 4 to 8
  • Audio card deleted (Audigy 2)
  • I am using deleted (CO (A2+OA))
  • Language set to Please set for missions
Update
It seems the source is one of these four models or a mix of them:
  • ca\misc\garbage_paleta.p3d (misc.pbo in common)
  • ca\misc\junkpile.p3d (misc.pbo in common)
  • ca\structures_e\HouseC\House_C_4_EP1.p3d (structures_e.pbo in expansion)
  • ca\structures_e\HouseK\Terrace_K_1_EP1.p3d (structures_e.pbo in expansion)

I am not quite sure which one it is. My best guess is the dispersed rubble
(the bottles, magazine paper, fish etc)

Repro
  1. Editor - run attached mission
  2. Run to the east in front of you towards the first waypoint
  3. Notice once you enter the courtyard the FPS the drop significantly and to observe a very noticeable slow down.
  4. Especially once you pass by the rubble the FPS crashes down to 10-20.
  5. Move to the next waypoint and finally to the last.
  6. Once the rubble gets out of view, the FPS rate recovers again.
Notes
  1. The issue does not happen with very low graphic settings or very powerful hardware.
  2. The GPU use percentage crashes down the same time the FPS does.
  3. If you keep looking at the rubble eventually (5-10s+) the FPS will recover.
  4. Using RMB to zoom in onto the rubble, makes the drop even worse.
  5. If you run around the house, the second time the hit is still there, yet a lot less.
  6. The huge drop be the rubble can be repro'ed 100% here.

Updated by Suma about 4 years ago

File LowFPS.Takistan.7z added

Great repro, easy to follow any really reliable (the issue is seen only once after each game restart, but that is still great).

First checks tells what is slow is most likely loading textures and normal maps on some furniture or other interior equipmen

Updated by kju almost 4 years ago

[80336] Optimized: Reduced frame rate drops caused by texture loading

Thanks Suma!

Looking to have sorted this very nicely. :)

Very smooth now; yes there is a FPS drop, yet its basically not noticeable.
This is a huge improvement! From testing some minutes in similar situations,
it seems the game is very smooth now. :D

Updated by GingerMcAle almost 4 years ago

Wow. This is great news. Thank you.

Fixed:
Huge FPS drop in scope (propably video memory related game bug)
http://forums.bistudio.com/showthread.php?t=112646

Updated by Fireball almost 4 years ago

  • Due date deleted (07/01/2011)
  • Status changed from Assigned to Resolved
  • Target version set to 1.60 BETA

Sounds good! Shall we close this out?

Updated by kju almost 4 years ago

In my view it can be closed.

Updated by Fireball almost 4 years ago

  • Status changed from Resolved to Closed

Thx.

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Updated by kju 10 months ago

  • Private changed from Yes to No

Also available in: Atom PDF