Bug #1439

script error

Added by Bionicman303 almost 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:05/20/2009
Priority:Normal Due date:
Assignee:Doomguy % Done:

0%

Category:-
Target version:Warface v1.1.8a

Description

The following message is constantly being displayed at the top of the screen:

... GetPos Leader _team;

nearestCities = |#|nearestLocations [_leaderPos, ["nameVill...'
Eror 0 elements provided, 3 expected
File mpMissions \
_cur_mp.Saralite\Common\Functions\Common_TeamIsInTown.sqf,
line 9

arma_warface_1.18_bug.JPG (76.1 kB) Bionicman303, 05/21/2009 17:39

History

Updated by Doomguy almost 6 years ago

  • Target version deleted (Warface 1.1.9)

This is strange - that script runs fine for me. At what point during the mission do you get the error messages?

What version of the game do you use?

Updated by Doomguy almost 6 years ago

  • Assignee deleted (Doomguy)

Updated by Bionicman303 almost 6 years ago

Hi Doomguy,

I'm using the latest Arma Beta (1.16). I played on Bluefor with 3 AI-Players against 8 Opfor AI-Slots
The message occurs about 5 minutes after I did build my HQ, Barracks, Light Vehicle Factory and Heavy Factory.
I started at "Pesto et Yoro" and moved my HQ to GPS coordinates 998122 (East of Somato behind a small hill).
I was able to reproduce this error message by restarting the match a couple of times until I spawned againg a "Pesto et Yoro".

I will check if this occurs at a different spawing site in the same way.

Thanks a lot for your efforts! Appreciate!

greetz
Bionicman303

Updated by Doomguy almost 6 years ago

When the error occurs, could you please check the in-game debug log (CTRL `) and wait for the messages (about 16 of them) like: *** team EAST-C led by EastPos3 (ACE_SquadLeaderE)

Please take a screenshot and post it here. Basically, if any of the messages has Null in them there's a problem!

Thanks,
Doomguy

Updated by Bionicman303 almost 6 years ago

Hi Doomguy,
here is the Screenshot. Hope it helps!
Thanks!
Bionicman

Updated by Doomguy almost 6 years ago

That's explained then, 4 west teams have gone defunct... Can you explain what you're doing a bit more? Dedicated server? Did players enter and leave during the game?

Updated by Bionicman303 almost 6 years ago

Hi Doomguy,

usually, I play like this:

I open a MP LAN game as a listen server (i.e. both playing and hosting at the same time). The setup is as follows:

Island: Saralite
Map: Warface 1.18
- I assign myself to the first Bluefor slot
- I set the Bluefor slots 2,3 and 4 to "AI"
- Bluefor slots 5,6,7,8 are closed/disabled (instead of "AI" there is a cross)
- Opfor slots 1 to 8 are all set to "AI" -> all enabled

... then I start the game.

Maybe, the error message occurs because Slots 5-8 are disabled!? If so, this case could be easily caught within the script, right?

Thanks again!

Bionicman

Updated by Doomguy almost 6 years ago

Aaah, that explains it! Disabling the AI's like that probably doesn't prevent the AI script to start. Thanks Bionicman303, I'll fix it.

Doomguy

Updated by Doomguy almost 6 years ago

  • Status changed from New to Assigned

Updated by Doomguy almost 6 years ago

  • Assignee set to Doomguy

Updated by Doomguy almost 6 years ago

  • Target version set to Warface v1.1.8a

Updated by Doomguy almost 6 years ago

  • Status changed from Assigned to Feedback

This should be fix by rev 632. AI teams can be disabled in lobby. Slots retain their role, i.e., slot 8 gets AI team type 8 (the spec op team), even if you disable all the other AI teams.

Updated by Doomguy almost 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF