Bug #14297

Disabled "Auto guided AT" makes AI gunner commanded by a player no longer guide the missile.

Added by 50.cal over 4 years ago. Updated almost 3 years ago.

Status:Closed Start date:10/10/2010
Priority:Normal Due date:04/01/2012
Assignee:Suma % Done:

0%

Category:Gameplay
Target version:1.62.95248
Affected ArmA II version:1.61 Beta First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
With "Auto guided AT" disabled AI gunner commanded by a player no longer guide the missile.
It fires on the ground instead.

Exp
AI should manually guide the missile into the assigned target.

Repro
  1. Go in Options/Game Options/Difficulty/Edit
  2. Disable "Auto guided AT" (or select veteran which has it off by default)
  3. Load mission
  4. As M2A2 commander order the AI gunner to change the weapon to TOW
  5. RMB click lock one of the T72 (or use quick command menu or radio 2-x)
  6. Wait until the AI gunner aims at the target
  7. Order the AI gunner to fire on target with TOW (via "fire" key shortcut)

Affected vehicles

  • BTR-90
  • BMP2
  • BRDM ATGM
  • M2A2
  • M2A3
  • Stryker TOW
  • Tungusta (2A38M gun)

TOW_bug.Desert_E.zip (854 Bytes) 50.cal, 10/10/2010 16:42

TOW_bug.wmv (622.7 kB) 50.cal, 10/13/2010 09:05

14297.Desert_E.7z (795 Bytes) kju, 01/16/2012 09:13


Related issues

related to ARMA2 Community Issue Tracker - Bug #14436: [CO] Refleks and arkan missiles cannot be guided manually... Assigned 10/15/2010
related to ARMA2 Community Issue Tracker - Feature #12299: Locking of _guided missiles_ does not work as pilot witho... Assigned 07/25/2010
related to ARMA2 Community Issue Tracker - Bug #13380: Cannot acquire laser target for BAF Wildcat CRV-7 PG rock... Assigned 08/30/2010
related to ARMA2 Community Issue Tracker - Feature #27763: Disable locking of all non guided weapons with AutoGuideA... Assigned 01/13/2012
related to ARMA2 Community Issue Tracker - Feature #14094: Add option to restrict radar locking (TAB target cycling)... Assigned 09/30/2010
duplicated by ARMA2 Community Issue Tracker - Bug #16816: BMP2 Konkurs missile fired by AI always hits below the ta... Duplicate 01/19/2011 02/01/2011

History

Updated by kju over 4 years ago

  • Due date set to 11/01/2010
  • Category set to Gameplay
  • Status changed from New to Feedback

Updated by 50.cal over 4 years ago

Updated by kju over 4 years ago

  • File deleted (TOW_MISS.Desert_E.zip)

Updated by kju over 4 years ago

  • File 14297.avi added

Updated by 50.cal over 4 years ago

Updated by kju over 4 years ago

  • Subject changed from M2A2/A3 and Stryker TOW can't hit targets to Disabled "Auto guided AT" makes AI gunner commanded by a player no longer guide the missile.
  • Due date changed from 11/01/2010 to 12/01/2010
  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from No to Yes

Updated by kju over 4 years ago

  • File deleted (14297.avi)

Updated by kju over 4 years ago

Thanks 50.cal! Now we have the actual issue.

I hope you see now why it is important to report
an issue very precisely with demo mission.

Updated by 50.cal over 4 years ago

Glad it helps!

Doing my best ;-)

Updated by kju over 4 years ago

  • Due date changed from 12/01/2010 to 03/01/2011
  • Operating system deleted (Win7 64 bit)
  • Affected ArmA II version changed from 1.55 BETA to 1.58 BETA
  • CPU deleted (E8400)

Updated by Suma over 3 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Dwarden to kju
  • I am using deleted (CO (A2+OA))

This seems expired to me, manual guiding in the attached repro mission seems to work as of 88027. Please, confirm.

Updated by kju over 3 years ago

  • Due date changed from 03/01/2011 to 04/01/2012
  • Assignee changed from kju to Suma
  • Affected ArmA II version changed from 1.58 BETA to 1.61 Beta
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Still true for me in 88027 Suma.

The key part is to have "Auto guided AT" disabled like in Veteran difficulty.
This disables auto guide for TOW (canLock = 1) - the AI gunner does not manually guide it to target for some reason.

Updated repro
  1. Go in Options/Game Options/Difficulty/Edit
  2. Disable "Auto guided AT" (or select veteran which has it off by default)
  3. Load mission
  4. As M2A2 commander order the AI gunner to change the weapon to TOW
  5. RMB click lock one of the T72 (or use quick command menu or radio 2-x)
  6. Wait until the AI gunner aims at the target
  7. Order the AI gunner to fire on target with TOW (via "fire" key shortcut)

PS: In 1.61 beta / 88027 you can only tell the AI gunner to fire the TOW at the T72 as commander - after a target command via radio / RMB click lock / quick command menu (attack that target).
(no longer possible to order the fire command as driver)

Updated by Fireball over 3 years ago

  • Description updated (diff)
  • Status changed from Feedback to Assigned

Updated repro in description.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Fixed in 88110

The issue was introduced when delayed locking was implemented for OA.

AI should manually guide the missile into the assigned target.

Note: technically the AI is not guiding the missile, instead the missiles fired by AI are handled as fire and forget guided missiles, only with a simulated control distance limitation. This is the same implementation as was used in OFP / Arma / A2.

Note: for some reason I cannot target the enemy using Tab targeting when I am commander and M220 TOW missiles are selected, the Tab works for me only with machine gun (M240) or a cannon (M242). I am not sure if this is a bug or not, if it is, it is probably unrelated to this.

Updated by kju over 3 years ago

Good job


only with a simulated control distance limitation

From what I can tell AI is also able to hit a moving target/a target that moves after the missile was fired - so the missile adjusts to the changing target position during the flight.

This is why I called it "AI manually guiding it".


Note: for some reason I cannot target the enemy using Tab targeting when I am commander and M220 TOW missiles are selected, the Tab works for me only with machine gun (M240) or a cannon (M242). I am not sure if this is a bug or not, if it is, it is probably unrelated to this.

a) M240 should never be lockable (canLock = 0) (not TAB nor RMB) - so quite strange if it worked for you
b) TOW is only lockable for Recruit and Regular - NOT for veteran and expert (canLock = 1) - it has to be manually guided
c) TAB lock only works for red/hostile radar targets - this is only true for enemy side vehicle and it has to move (the demo mission hat fuel = 0)
d) However one can still assign a target as commander with RMB even for non lockable weapons (or via radio or assign target in quick command menu via context sensitive cursor)

added a simple test mission in case you want to check it again

Updated by kju over 3 years ago

  • Target version set to Upcoming version

Updated by Dwarden over 3 years ago

  • Target version changed from Upcoming version to 1.61 BETA

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

works. ty

Updated by kju almost 3 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Also available in: Atom PDF