Bug #14193

SetCaptive doesn't stop AI shooting at a unit/player

Added by Xeno over 4 years ago. Updated about 3 years ago.

Status:Closed Start date:10/05/2010
Priority:Normal Due date:10/05/2011
Assignee:- % Done:

100%

Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When you use setCaptive on a unit or player AI doesn't stop shooting at the unit/player.

Specially AI vehicles are effected by it.

Expected behaviour would be that AI stops shooting immediately when a unit is captive.

Attached are two test missions:
In the first one shoot at the friendly AI units until they start shooting at you. After 10 seconds a trigger will set the player captive.
Second test mission is with enemy AI, same trigger, AI doesn't stop shooting when the player is captive.

Tested it with OA Beta 73643

_captivetest1.Takistan.7z (1.7 kB) Xeno, 10/05/2010 19:20

_captivetest2.Takistan.7z (1.6 kB) Xeno, 10/05/2010 19:20

History

Updated by zGuba over 4 years ago

  • Due date set to 01/05/2011
  • Category set to AI Issues
  • Status changed from New to Assigned
  • Affected ArmA II version changed from Please select... to 1.54.72888
  • Reproduced by another DH user changed from No to Yes
  • I am using set to CO (A2+OA)
  • Reproducible for you changed from No to Yes

Updated by Xeno over 4 years ago

During testing on a dedicated server I've made a video which shows the problem again (watch fullscreen and in 1080 HD).

http://www.youtube.com/watch?v=cnSE89T0bXE

While all AI units ignore the playable unit because setCaptive is issued over the network (the player is not dead in this case, it's just the death animation) there is one unit on the right side which doesn't care about it and doesn't stop shooting (at least it takes a long time until the AI unit stops shooting).

(unrelated to this ticket, if you watch the video till the end you see that the three patroling units coming to the player position have white faces when they are further away)

The video was made using the latest available beta (client and dedi server), 74094

Updated by Dwarden over 4 years ago

  • Assignee set to Dwarden
  • Target version set to Upcoming version
  • Affected ArmA II version changed from 1.54.72888 to 1.55 BETA

Updated by Suma over 4 years ago

  • Status changed from Assigned to Feedback

Chance is this might be fixed by fix http://dev-heaven.net/issues/5183#note-20 - please, test.

Updated by kju over 4 years ago

  • Due date changed from 01/05/2011 to 12/01/2010

Updated by Xeno over 4 years ago

Not fixed.

Specially crews in vehicles still ignore it completely sometimes. But also normal infantry AI units.

Updated by Fireball over 4 years ago

  • Status changed from Feedback to Assigned

Updated by Sickboy over 4 years ago

Could it be related to suppression functionality etc?

Updated by mr.g-c over 4 years ago

Yes, could be possible i think, i had the same idea...
Perhaps, if this is really by design, a new scripting-command could be introduced replicating the old "SetCaptive" behavior.

Updated by Dwarden over 4 years ago

  • Status changed from Assigned to In progress
  • % Done changed from 0 to 10

Updated by Dwarden over 4 years ago

  • % Done changed from 10 to 90

since b76664 this issue should be greatly improved

Updated by Sickboy over 4 years ago

Hoooooray, thank you!

Updated by kju over 4 years ago

  • Due date deleted (12/01/2010)
  • Status changed from In progress to Resolved
  • Target version changed from Upcoming version to 1.57 BETA

Please confirm fix:
[76664] Fixed: SetCaptive doesn't stop AI shooting at a unit/player

Updated by Dwarden over 4 years ago

  • Target version changed from 1.57 BETA to Upcoming version OA
  • % Done changed from 90 to 100

improved AI in build 76733 - when unit is setCaptive then unit's target is set to NULL

Updated by Xeno over 4 years ago

It is improved in 76711...

But, in the second test mission (with the east soldiers) there is always one BRDM that doesn't stop shooting.
All other units are fine and stop, just one of the BRDMs seems to ignore it and constantly attacks the player with his machine gun.
(it takes a looong time until he finally stops, might be because he has run out of ammo)

Updated by Dwarden over 4 years ago

if you move the brdm will stop fire

i think it's problem with the supressiveFire or something ...

Updated by Xeno over 4 years ago

Yep, could be the reason.

Updated by Dwarden over 4 years ago

so that issue with vehicle was resolved by 76733 fix !

Updated by Xeno over 4 years ago

Resolved completely in beta 76752

Updated by Sickboy over 4 years ago

Hooray! Thanks.

Updated by kju over 4 years ago

  • Status changed from Resolved to Closed
  • Target version changed from Upcoming version OA to 1.57 BETA

Updated by kju over 4 years ago

  • Target version changed from 1.57 BETA to 1.57.76815

Updated by Xeno over 3 years ago

While trying to play the game again in MP, this one showed its ugly head again.

A lonely Taki AI BMP was shooting at a captive player and totally ignored that the player was captive.
No addons, just vanilla OA (server was running 1.59 full patch).

Updated by Fireball over 3 years ago

  • Due date set to 10/05/2011
  • Status changed from Closed to Feedback
  • Assignee changed from Dwarden to Xeno
  • I am using deleted (CO (A2+OA))

Reopening, needs simple repro with 1.60 BETA to confirm.

EDIT: Or existing repros need to be confirmed, that they reproduce the issue.

Updated by zGuba over 3 years ago

  • Status changed from Feedback to Expired

Updated by zGuba over 3 years ago

  • Status changed from Expired to Assigned

Updated by zGuba over 3 years ago

  • Status changed from Assigned to Feedback

Updated by Sickboy over 3 years ago

This issue is supposedly solved with latest betas, please confirm.

Updated by kju over 3 years ago

  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

For me everyone, including BRDMs, stops in the second demo mission once setCaptive true (83500).

Updated by Fireball over 3 years ago

  • Status changed from Feedback to Resolved
  • Assignee deleted (Xeno)
  • Target version changed from 1.57.76815 to 1.60 BETA

Setting to resolved according to feedback kju, updating target version, as we may assume that the fix must have been improved in 1.60 BETA.

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF