Bug #14191

Object synchronization in Multiplayer at > 1.5km not precise enough

Added by Sickboy almost 5 years ago. Updated over 3 years ago.

Status:Closed Start date:10/05/2010
Priority:Normal Due date:12/01/2011
Assignee:Dwarden % Done:

0%

Category:Multiplayer
Target version:1.60.87580
Affected ArmA II version:1.59.79384 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

This problem makes systems like Hellfire LOAL missileguidance, very hard, especially at distance, especially on moving targets, or simply wanting to change target before hit.

Attached pictures show the marked position from perspective of designator guy, as well as observer.
Related ticket, and it's related tickets, are witness to the problem.

Observed:
In Multiplayer, dedicated server, one client has a laserdesignator and designates a location, other client observes the marked location.
When designating a position with a laserMarker, one has to be within ~1500m, for the position of the object to be reliable.
Outside this radius, if the designator guy moves the marker elsewhere, it will lag behind on the other client, sometimes remains on original position for several seconds, before updating, to a perhaps already old location yet again.
I have seen differences like 30-200m. At picture 4, once the marker is @927m distance, the positions are basically correct, ~1m diff.

Expected:
Lasermarkers should be accurately positioned, synchronized, on all machines. Perhaps even up to 6 KM, however, 3-4 would be a good start :)

Repro:
  1. Load no Addons/Mods.
  2. Put lasermarkertest folder in Addons, then make a pbo of it
  3. Put mission in MPMissions folder
  4. Start a dedicated Server
  5. Join with your client
  6. A second player should join from his client
  7. Let second player designate an area to south, and move the designator slow to left or right, pulling it away, or closer to the observer position.
  8. Check Map - you will see NL (local marker where your client thinks the laser is) and L (global marker where the other client thinks the laser is).
  9. If the laserTarget is further away than ~1500m from the observing player, the NL marker will lag behind the L marker, sometimes a little, sometimes more, etc.

lasermarker_test.7z - Addon (411 Bytes) Sickboy, 10/05/2010 13:04

LaserMarkerTest.Desert_E.7z - Mission (1.3 kB) Sickboy, 10/05/2010 13:04

1.png (290.8 kB) Sickboy, 10/05/2010 13:05

2.png (244.3 kB) Sickboy, 10/05/2010 13:05

3.png (177.4 kB) Sickboy, 10/05/2010 13:05

4.png (183.4 kB) Sickboy, 10/05/2010 13:05

5.png (180.9 kB) Sickboy, 10/05/2010 13:05


Related issues

related to ARMA2 Community Issue Tracker - Bug #1915: AI warping - especially at distance. Closed 06/08/2009
related to ARMA2 Community Issue Tracker - Bug #24014: Remote AI ground vehicles at large distance are not updat... Closed 09/01/2011
related to ARMA2 Community Issue Tracker - Bug #19213: JIP players do not register on other clients at extreme r... Duplicate 04/26/2011 12/20/2011
related to ARMA2 Community Issue Tracker - Bug #27200: JIP Players don't synchronise until they get close to you Closed 12/20/2011 12/20/2011
related to A.C.E. for OA - Bug #13677: Hellfire K not locking on SOFLAM laze on Takistan Closed 09/13/2010
related to ARMA2 Community Issue Tracker - Feature #10452: Expand IR laser simulation Assigned 05/03/2010
related to ARMA2 Community Issue Tracker - Bug #22447: Positional information at a distance completely unreliabl... Feedback 07/17/2011
related to ARMA2 Community Issue Tracker - Bug #24898: When a player joins a server and spawns far away from oth... Closed 09/25/2011

History

Updated by Sickboy almost 5 years ago

Updated by Evil_Echo almost 5 years ago

Agree. More precision would be a great help for systems that are attempting long-range targeting. There should be some variability due to atmospheric distortions ( weather-related? ), just not as much as current values.

Updated by Megagoth1702 almost 5 years ago

Total thumbs up on this one!

Updated by zGuba almost 5 years ago

  • Category set to Multiplayer
  • Status changed from New to Assigned

Updated by zGuba almost 5 years ago

  • Affected ArmA II version changed from Please select... to 1.54.72888

Updated by zGuba almost 5 years ago

  • Due date set to 01/05/2011
  • Reproduced by another DH user changed from No to Yes
  • I am using set to CO (A2+OA)
  • Reproducible for you changed from No to Yes

Updated by Nou about 4 years ago

Testing copperhead rounds (which can reach out to 16Km) I noticed some very odd behavior. It seemed like the laser markers are residual in MP. My copperhead guidance code looks for the nearest laser marker and goes after that, the guidance code runs on the machine that fired it. What I noticed last night is that if I fired a copperhead the first round would hit fine. If I then designated a target further from the gun than the last target the round would hit the first target. If I designated a target closer to the gun, then it would hit the new target. Same goes for any additional shots. If I kept moving the laser target closer to the gun, the rounds would generally hit the laser target. If I moved the laser target more forward, it seemed to be finding and tracking an old laser target, usually the one closest to the gun.

I noticed this both in Vanilla and in ACE (which does laser targets differently, but still uses the laser target object I believe) so this leads me to believe there is something funky in its simulation type that leaves it residually there on some clients.

Updated by Sickboy about 4 years ago

  • I am using deleted (CO (A2+OA))

I think i've confirmed something similair with my tests back then, this behaviour only occured at distance though.

Updated by zGuba about 4 years ago

  • Due date changed from 01/05/2011 to 10/05/2011
  • Affected ArmA II version changed from 1.54.72888 to 1.59.79384

Updated by zGuba about 4 years ago

Done some reproing with Fireball. Our research shows that remote laser position is not updated if its position change does not exceed 30 meters.

This means that scripted laser searching will be dramatically unreliable, unless laser owner does broadcast more accurate data to make use of.

Updated by Sickboy about 4 years ago

Nice, but the effects get worse at farther distances, or not tested?

Updated by Fireball about 4 years ago

Ok repro'ed it together with zGuba:

http://www.youtube.com/watch?v=utdkAE3LqdQ

Conclusions:

- the LD marker is not updated anymore if moved outside MP view distance, i.e. 1600m from the player
- to repro move the LD marker along around your posit, this way the other player is > 2km apart from the marker
- the non-local LD marker updates only, if it's moved by about 20-30m, i.e. it jumps along

SB: The distance can be seen in the vid; it's about 2.2km. From what we could both tell it wouldn't get any worse, but then again the map is too small for that.

Updated by kju almost 4 years ago

  • Due date changed from 10/05/2011 to 12/01/2011
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Might be useful to test this with the latest beta due to the MinErrorToSend changes.

Updated by Dwarden over 3 years ago

  • Status changed from Assigned to Feedback
  • Assignee set to Dwarden
  • Target version set to Upcoming version

any change with 1.60.86411 ?

Updated by Dwarden over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Dwarden over 3 years ago

  • Target version changed from 1.60 BETA to 1.61 BETA

Updated by Fireball over 3 years ago

  • Status changed from Feedback to Closed
  • Target version changed from 1.61 BETA to 1.60.87580

Also available in: Atom PDF