Bug #14134

"assignedVehicle" of remote unit is not updated where the vehicle is local

Added by Fireball over 4 years ago. Updated over 1 year ago.

Status:Assigned Start date:10/02/2010
Priority:Normal Due date:02/01/2011
Assignee:Dwarden % Done:

0%

Category:AI Control
Target version:-
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

(alef)

"assignment" status is not updated correctly along MP.
This lead to problems with mount (or disembark) vehicles.
But the effect are random, sometimes the unit get in, sometimes not.
See the video: http://www.youtube.com/watch?v=mlul30MAb0A

s1 is the player in MPH (left screen), s2 is his AI, one group.
p1 is the player in MPC (right screen), p2 is his AI, another group.
o1 and o2 are AI in another group.

20101002_223935.zip - mission under MPH profile (locality_1) (12.9 kB) alef, 10/02/2010 21:16


Related issues

related to ARMA2 Community Issue Tracker - Bug #1718: In multiplayer, you cannot make AI under your control dis... Closed 06/02/2009

History

Updated by alef over 4 years ago

Updated by alef over 4 years ago

  • Due date deleted (01/02/2011)
  • Assignee set to Dwarden

Updated by alef over 4 years ago

The commands "assignAS...." works correctly, but when you order AI to mount or disembark via radio menu, "assignedVehicleRole" report different results on different clients at different time.
Video updated with more details.

Updated by kju over 4 years ago

  • Due date set to 02/01/2011

Updated by MadDogX about 3 years ago

  • I am using changed from CO (A2+OA) to CO (OA+A2)

Last update > 1 year ago. Is this ticket still valid?

Also available in: Atom PDF