Feature #14094

Add option to restrict radar locking (TAB target cycling) of vehicles

Added by El_Duderino almost 5 years ago. Updated over 2 years ago.

Status:Assigned Start date:09/30/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Game settings
Target version:-
Affected ArmA II version:Please select... First affected ArmA II version:
Reproduced by another DH user:No Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using: NGUrl:
Reproducible for you:No WIKIurl:
Related to content of DLC:

Description

Suggested

Add an option to restrict radar locking (TAB target cycling) of vehicles.
The reason is that in player vs player multiplayer games (warfare to be specific)
vehicles can be abused way too easily.

Possible setup
  1. Easy Mode: TAB locking enabled for all missiles and cannons against vehicles.
  2. Veteran Mode: TAB locking enabled for all missiles against vehicles.
  3. Expert Mode: TAB locking enabled only for heat/radar guided missiles (ie Javelin, AA, hellfire etc) against vehicles.

It is its just a matter of tapping the TAB key.

Ref: Discussion on the BIF forums

Notes
  1. Player vs player should rely more on the new features of the game, like FLIR and countermeasures,
    to be effective in armored vehicles.
  2. Possible different options: Disable radar locking of ground vehicles, air and both or none.

Related issues

related to ARMA2 Community Issue Tracker - Bug #13000: "Next target" targets vehicles even behind terrain and ob... Closed 08/17/2010
related to ARMA2 Community Issue Tracker - Feature #16719: Add option to disable friend-foe radar signature (difficu... Assigned 01/15/2011
related to ARMA2 Community Issue Tracker - Bug #12101: [OA] TOW control failing at distance Closed 07/18/2010 02/14/2012
related to ARMA2 Community Issue Tracker - Feature #4113: Add scripting commands: disableLockOn, disableCycLockOn a... Assigned 08/29/2009
related to ARMA2 Community Issue Tracker - Feature #18451: (Add difficulty option to) Disable auto lock of infantry ... Duplicate 03/24/2011
related to ARMA2 Community Issue Tracker - Feature #16255: Disable auto locking of infantry launchers or reduce auto... Assigned 12/26/2010
related to ARMA2 Community Issue Tracker - Feature #8890: Vikhr Missiles CfgAmmo should be changed to make the Vikh... Assigned 02/07/2010
related to ARMA2 Community Issue Tracker - Bug #2651: METIS & TOW not wire guided but fire & forget Rejected 07/07/2009 09/27/2009
related to ARMA2 Community Issue Tracker - Bug #24430: T-55 tank needs "TAB" targeting or T-34 needs it removed Assigned 09/12/2011 12/12/2011
related to ARMA2 Community Issue Tracker - Bug #24938: CfgWeapons - canLock issues Assigned 09/27/2011 12/01/2011
related to ARMA2 Community Issue Tracker - Bug #14436: [CO] Refleks and arkan missiles cannot be guided manually... Assigned 10/15/2010
related to ARMA2 Community Issue Tracker - Bug #13380: Cannot acquire laser target for BAF Wildcat CRV-7 PG rock... Assigned 08/30/2010
related to ARMA2 Community Issue Tracker - Feature #27763: Disable locking of all non guided weapons with AutoGuideA... Assigned 01/13/2012
related to ARMA2 Community Issue Tracker - Bug #14297: Disabled "Auto guided AT" makes AI gunner commanded by a ... Closed 10/10/2010 04/01/2012
related to ARMA2 Community Issue Tracker - Feature #12299: Locking of _guided missiles_ does not work as pilot witho... Assigned 07/25/2010
related to ARMA2 Community Issue Tracker - Bug #14221: Despite irTarget = 0 units/objects can be locked with TAB. Closed 10/07/2010
related to ARMA2 Community Issue Tracker - Feature #2251: Improve radar and friend-foe-identification (IFF) simulation Assigned 06/24/2009
related to ARMA2 Community Issue Tracker - Bug #37331: Radar targets and locking should to be limited by object ... Assigned 07/17/2012
related to ARMA2 Community Issue Tracker - Feature #17965: Add difficulty option to disable radar of vehicles (that ... Assigned 03/01/2011
related to ARMA2 Community Issue Tracker - Bug #16987: Gunner firing broken (blank ammo) when human pilot activa... Resolved 01/26/2011
related to ARMA2 Community Issue Tracker - Feature #10452: Expand IR laser simulation Assigned 05/03/2010
related to ARMA2 Community Issue Tracker - Bug #11200: Rockets 9M117M1 Arkan / 9M113 Konkurs / 9M119M Refleks no... Duplicate 06/13/2010
duplicated by ARMA2 Community Issue Tracker - Feature #27929: Apply T55's model to all tanks Duplicate 01/18/2012
duplicated by ARMA2 Community Issue Tracker - Feature #16704: please remove TAB key option for Veteran/Expert Mode Duplicate 01/14/2011
duplicated by ARMA2 Community Issue Tracker - Feature #14375: Add Option to Enable/Disable 'Tab Lock-on for Human Playe... Duplicate 10/12/2010 10/19/2010

History

Updated by kju almost 5 years ago

  • Subject changed from Tab Cycling Restricted Via Difficulty Parameters to Add option to restrict radar locking (TAB target cycling)
  • Category set to Game settings
  • Status changed from New to Assigned

Updated by kju almost 5 years ago

  • Subject changed from Add option to restrict radar locking (TAB target cycling) to Add option to restrict radar locking (TAB target cycling) of vehicles

Updated by kju almost 5 years ago

To clarify:
Radar locking (TAB) should never make it possible to lock infantry.
As said, if it does, it is a bug and needs a new ticket with demo mission and repro steps.

Now direct click locking (RMB) is different.
Some weapons (MG type mostly) can lock infantry and are meant to be (in the current system).

For this part (along with vehicles) is this ticket.

Does this help - Is it clear now?

PS: RMB = right mouse button

Updated by El_Duderino almost 5 years ago

ok then, thanks for clarification, i thought this was a new feature of OA/CO since it was very obvious to me as soon as i started playing OA/CO warfare.

Updated by AGW-Grimes almost 5 years ago

You are able to target infantry in ground and air vehicles, but in neither have I seen that you can 'lock' onto them, lock onto as in firing a Hellfire that is guided onto them. Now, a circle maybe show up over the square target indicator, but it just works the same way as when the Hydras are aligned... you are aligned, and should hit the target. It is not a lock.

Updated by El_Duderino almost 5 years ago

im not talking about that kind of lock (with the beeping you get when locking hellfire), but the cycling using the TAB key, before OA it was only possible to cycle through vehicle targets, now since OA it's possible to cycle through infantry targets as well, i would like to have a setting that removes that.

but as per above apparently its a bug?

Radar locking (TAB) should never make it possible to lock infantry (#14221).

Updated by 76 almost 5 years ago

  • Status changed from Assigned to Closed

Updated by kju almost 5 years ago

  • Status changed from Closed to Assigned

Updated by kotov over 4 years ago

will be good to see sytem that much closer to realistic than we have now.
Veteran/expert mod
- No red dots on radar - except laser.
- no tab key autolock.
- one target only at the time - e.g.If you fire 2 rockets at time you can only hit 1 target which locked.
- only mouse manual lock available.

Updated by kju almost 4 years ago

  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • I am using deleted (CO (A2+OA))

Another good comment to discuss this issues:
http://forums.bistudio.com/showthread.php?t=124870

Updated by kju over 3 years ago

See this thread for a possibly workable compromise (as a start):
http://forums.bistudio.com/showthread.php?p=2068353#post2068353

Updated by kju over 3 years ago

Added ticket: #27763 - go for it NOW!

Also available in: Atom PDF