Feature #1369

Projects overview: White-grey background needed.

Added by kju almost 6 years ago. Updated about 5 years ago.

Status:Expired Start date:05/14/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Website
Target version:-
Close Reason: NGUrl:
BIForumURL: WIKIurl:

Description

White back, grey back, white back, grey back

as in the issue list:
http://dev-heaven.net/projects/heaven/issues?sort_key=priority&sort_order=asc


Related issues

related to DevHeaven (Only site issues) - Feature #1436: Forum posts need to be visual separated Expired 05/19/2009
related to DevHeaven (Only site issues) - Feature #1371: overall less use of background coloring it seems Expired 05/14/2009

History

Updated by kju almost 6 years ago

  • Tracker changed from Bug to Feature

Updated by kju almost 6 years ago

  • Target version set to 152

Updated by SquelchAdmin almost 6 years ago

Squeegie uses a graduated background for issues, and this would also work well for other areas of the site. If this is acceptable, it would be better than an alternating background imo.

Updated by kju almost 6 years ago

What is graduated background?
The effect from going from one color to white in the same field?

If so, IMO this is a very BAD feature. Makes it lot less readable.
Either plan white or better white-grey-white (color does not matter,
yet solid for one field).

Updated by Sickboy almost 6 years ago

  • Assignee changed from Sickboy to Squelch

Updated by Spooner almost 6 years ago

You either want a border around all cells or you want alternating colours. Both is just making my eyes hurt more.

Updated by kju almost 6 years ago

I vote for alternating colors.

Updated by Spooner almost 6 years ago

I put the rules in the "right" place, so visual separation should be massively improved. 9997d7f8

Updated by kju almost 6 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Squelch to Vigilante
  • Priority changed from High to Normal
  • Target version deleted (152)

Still alternating colors for posts would be good imo.
What are your thoughts?

Updated by Vigilante almost 6 years ago

  • Status changed from Feedback to Resolved

its possible by chaning h3 but that might make troubles on other parts of the site...
i pushed the change up so try it on the big mainsite projectpage..

Updated by kju almost 6 years ago

hmmmmm

looks good on the projects overview:
http://dev-heaven.net/projects

unfortunately also ie the update ticket dialog is affected. :(

new ticket also:
http://dev-heaven.net/projects/heaven/issues/new
and the wiki:
http://dev-heaven.net/wiki/heaven#Donations

The change is good, yet it needs to be applied only where desired.

Updated by kju almost 6 years ago

  • Status changed from Resolved to Assigned

Maybe Spooner can support?

Updated by Vigilante almost 6 years ago

yeah, i guess some trudy or rhtml is needed to setup a new class for these.. or i just didnt got/found it yet..

Updated by kju almost 6 years ago

  • Assignee changed from Vigilante to Spooner

Spooner please take a look once you feel like it.

Updated by Spooner almost 6 years ago

This is no longer necessary since we have horizontal rules. We want alternating stripes OR rules. Not both.

Updated by kju almost 6 years ago

Sorry maybe its just me and my TFT,
yet the current grey in the background looks horrible.
The thin line is hardly visible.

http://www6.picfront.org/picture/gFR9XPIn/img/p001.jpg

Compare this to the default Redmine:
http://www.redmine.org/projects
http://www.redmine.org/
Or this mod:
https://projects.littlestreamsoftware.com/projects

While they are not perfect design wise either,
their tone is far more positive and easier to read. :|

http://dev-heaven.net/projects

Does it look different for you in your browse compared
to my screenshot?

Updated by kju almost 6 years ago

Same is true for this ticket view or the forum:
http://dev-heaven.net/boards/9/topics/show/37

The only thing to stop me from going crazy is the
black thin text, bold blue for links and bold black for headers.
And the icon here and there. :D

Updated by Spooner almost 6 years ago

Well, those examples all have no definition (hr or stripes) so I'm not sure what you were trying to indicate by showing them.

I see exactly the same as you do and the lines are very visible for me, without making the place look very messy. It is exactly the same thin line which is fine for issues page (and which I added recently to the forum message pages)...

We need to get a bit more consistent. I added lines to projects and messages because there was absolutely no definition between projects (well, ok, there were lines already on the projects page, but in the wrong place in the middle of the project description, not between them, so more confusing than not having any at all).

OK, I don't really like striped, preferring subtle lines. The key thing I've said, however, is that we should have striped OR ruled and that we should aim for consistency rather than formatting every page differently. Just adding striped on top of ruled is a mess.

Please let us decide on one style and apply it to projects, activities, forum messages, issues, etc (all message lists should be the same and all overall lists, like the list of forum threads, should be the same). We shouldn't be deciding this on a per-page basis at all!

Updated by kju almost 6 years ago

Thanks for the confirmation that it is looking the same for you others too.

My say is:

1) Gray BG + black font => bad

2) Gray => negative color => white BG on black OR white BG for text, keep gray
for non text areas and use dark gray for headers/special elements:
http://dev-heaven.net/account/show/527

3) I prefer white BG on black OR white BG for text and use dark gray
for headers/special elements.

From a user experience standpoint, saying that black text on a white background
is easier to read is not an opinion, it's been tested. The issue is not whether
or not its possible to read, its what's the most effective way to present the data,
making it as easy on the end user as possible. Dark backgrounds do take more time
to process visually.

What does google use.

Updated by kju about 5 years ago

  • Status changed from Assigned to Expired
  • Assignee deleted (Spooner)

Also available in: Atom PDF