Bug #13586

Controls Unusable After Using "openMap false" Whilst Naming Marker

Added by JamesF1 about 5 years ago. Updated almost 4 years ago.

Status:Assigned Start date:09/08/2010
Priority:Normal Due date:12/22/2010
Assignee:Dwarden % Done:


Category:Game freezes
Target version:Upcoming version
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:


When executing openMap false (to hide the map by scripting), whilst the user is naming a marker, the user is unable to finalise the marker naming, and all other control commands (moving, escaping to the game menu, etc.) remain inaccessible, as if still typing.

Expected Behaviour
When openMap false is executed, all 'in-progress' names should be finalised (as if you pressed enter yourself), allowing control to be returned to the user.

  1. Set up a mission with a single unit.
  2. Place sleep 20; openMap false in init.sqf (Or a similar sort of condition. A radio trigger, etc. won't work for obvious reasons).
  3. Run the mission
  4. open the map
  5. double-click to create a marker
  6. and begin typing
  7. wait for the map to close
  8. attempt to continue to control your character.

Issue13586_Repro.Desert_E.zip (869 Bytes) JamesF1, 09/21/2010 07:35


Updated by oblivion180 about 5 years ago

Reproduced as described.

Updated by Fireball about 5 years ago

  • Due date set to 09/22/2010
  • Category set to Game freezes
  • Status changed from New to Feedback
  • Reproduced by another DH user changed from No to Yes

Dare to attach the repro mission?

Updated by kju about 5 years ago

  • Due date changed from 09/22/2010 to 12/22/2010
  • Status changed from Feedback to Assigned


As workaround you may want to try to close the map with closeDialog IDD;

Updated by kju about 5 years ago

  • Assignee set to Dwarden

Updated by Dwarden about 5 years ago

  • Status changed from Assigned to Feedback

unable to reproduce with build 73206

Updated by JamesF1 about 5 years ago

Sorry for the delay in attaching a repro. Follow steps listed above.

Updated by kju about 5 years ago

  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.54.72888 to 1.55 BETA
  • I am using set to OA only


Confirmed with latest beta patch.

Updated by Dwarden about 4 years ago

  • Target version set to Upcoming version

Also available in: Atom PDF