Bug #13380

Cannot acquire laser target for BAF Wildcat CRV-7 PG rockets if "Auto guide AT" is turned off in difficulty

Added by Floydii over 4 years ago. Updated almost 2 years ago.

Status:Assigned Start date:08/30/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Config
Target version:-
Affected ArmA II version:1.62.95248 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC:BAF WIKIurl:

Description

Observed
AH-11 pilot cannot acquire laser target when "Auto guide AT" is turned off; rockets fire only to where the pilot crosshairs points.

Expected
Laser target should be available despite of difficulty settings.

Repro
  1. Set difficulty to mercenary or turn off "Auto guide AT" in veteran
  2. Open Editor
  3. Place a Wildcat AH11 (None)
  4. Go to gunner seat and turn on the laser
  5. Switch back to pilot, hover to any height and press TAB
  6. No lock on laser target will be acquired
  7. Fire the CRV7 and it flies straight ahead/follows the pilot's crosshair

Fix

class CRV7_PG: RocketPods
 canLock = 1;
 =>
 canLock = 2;

Notes
At this time, the Lynx Wildcat in the British Armed Forces DLC has 12 CRV-7 PG rockets. They quite rightly are guided, but only on vehicle targets that you can lock up(like the A10's Maverick missiles).

After doing some research, It appears that the rockets are laser guided (at least in the terminal phase). http://en.wikipedia.org/wiki/CRV7 provides a reference under 'guided version'.


Related issues

related to ARMA2 Community Issue Tracker - Bug #12025: Cannot mark targets with laser as gunship gunner when mis... Closed 07/15/2010 04/01/2012
related to ARMA2 Community Issue Tracker - Bug #14297: Disabled "Auto guided AT" makes AI gunner commanded by a ... Closed 10/10/2010 04/01/2012
related to ARMA2 Community Issue Tracker - Bug #4812: Missiles don't lead moving optical/laser targets Assigned 09/22/2009
related to ARMA2 Community Issue Tracker - Feature #5750: more realistic fire control for missiles Assigned 11/08/2009
related to ARMA2 Community Issue Tracker - Feature #10452: Expand IR laser simulation Assigned 05/03/2010
related to ARMA2 Community Issue Tracker - Bug #24938: CfgWeapons - canLock issues Assigned 09/27/2011 12/01/2011
related to ARMA2 Community Issue Tracker - Bug #26112: Difficulty option AutoguideAT does not apply to hand METIS Assigned 11/04/2011 04/18/2012
related to ARMA2 Community Issue Tracker - Feature #14094: Add option to restrict radar locking (TAB target cycling)... Assigned 09/30/2010
related to ARMA2 Community Issue Tracker - Feature #27763: Disable locking of all non guided weapons with AutoGuideA... Assigned 01/13/2012
related to Arma 2: Community Configuration Project - Bug #28678: BAF Wildcat CRV-7 PG rockets cannot be locked when "Auto ... Closed 02/14/2012
related to ARMA2 Community Issue Tracker - Feature #27346: Equip more vehicles with a laser weapon - Laser FCS (Firi... Assigned 12/25/2011
related to ARMA2 Community Issue Tracker - Feature #50107: Make laserLock and nvLock independant to canLock. Assigned 09/15/2012
related to ARMA2 Community Issue Tracker - Feature #28784: Realistic rangefinders Assigned 02/19/2012

History

Updated by kju over 4 years ago

  • Status changed from New to Assigned
  • Affected ArmA II version deleted (1.54.72888)

Updated by kju over 4 years ago

  • Due date set to 10/01/2010
  • Status changed from Assigned to Feedback

Updated by kju over 4 years ago

  • Tracker changed from Feature to Bug

Updated by kju over 4 years ago

  • Affected ArmA II version set to 1.54.72888

Updated by Xerxes17 over 4 years ago

The issue appears to be with the weapon being canlock = 1. Where in the higher difficulties it's not possible to lock anything. However, changing it to that makes it a tab lock fire and forget because in the ammo irlock = 1. Setting it to 0 makes it so that it can only target laser, however getting an ai co-pilot to target something with the laser is impossible. Tab does not work, neither does the 2 menu.

Updated by Floydii over 4 years ago

Hmm, so maybe this is purely an issue related to hardcoded difficulty settings in the game?

A work-around would be to lower difficulty and then turn on the difficulty settings except for the guidance ones. Not ideal, but that's life.

Does the hellfire on the Apache have this issue in higher difficulties? For game purposes, the CRV7 should be handled like the Hellfire (tab lock simulates gunner lasing target in single player, as is the case with the other attack helicopters).

Updated by ricnunes about 4 years ago

I also did some more extensive testing regarding this and I can confirm that if the auto-guide AT option is set to OFF the CRV7PG can NOT lock ANY laser targets (being it the Wilcat's laser designator or the other laser designators) but if the auto-guide AT option is set to ON then it's already possible to lock laser targets including the one generated by the Wilcat's own laser designator.
So I think that the problem lies in some config parameter(s) regarding on how the rocket can or cannot lock (laser) targets depending on the dificulty level (regarding the auto-guide AT option to be more precise).

IMO the best solution for this problem would be to mimic the CRV7PG configuration paramaters to be exactly the same as the Hellfire ones excepting for the "explosive power" and range (the hellfire should be more powerfull and have more range since it's quite bigger than a CRV7 rocket) because the hellfire works flawesly with the auto-guide AT option set to both ON and OFF.

Updated by Floydii about 4 years ago

I think what Ricnunes (and I, earlier) said is the easiest option to get this working.

Updated by Fireball almost 4 years ago

  • Subject changed from Laser guidance for BAF Wildcat CRV-7 PG rockets to Laser guidance for BAF Wildcat CRV-7 PG rockets fails when crosshairs is turned off in difficulty
  • Description updated (diff)
  • Due date changed from 10/01/2010 to 10/21/2011
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.54.72888 to 1.59.79384
  • I am using deleted (CO (A2+OA))
  • Reproducible for you changed from No to Yes

Adjusted description, but I didn't test the repro yet.

Updated by ricnunes over 3 years ago

@Fireball:

No, NO, NO!! You got it all wrong! The difficulty setting that's causing this problem is NOT the "crosshairs is turned off" but it is the "AUTO GUIDE AT set to off"!! This problem is due to the "AUTO GUIDE AT" difficulty setting, for example:
- If the "crosshairs" is turned OFF but the "auto guide AT" is turned to ON than the player will be able to lock CRV-7PG rockets on laser targets without any problem!
- But if the "auto guide AT" is turned to OFF, it doesn't matter if the "crosshairs" is turned either to OFF or ON, the player will NOT be able to lock CRV-7PG rockets on laser targets!

It's a petty that this issue doesn't seem to be fixed in the upcomming v1.60 patch (unless I'm mistaken)

Updated by Fireball over 3 years ago

  • Subject changed from Laser guidance for BAF Wildcat CRV-7 PG rockets fails when crosshairs is turned off in difficulty to Laser guidance for BAF Wildcat CRV-7 PG rockets fails when "Auto guide AT" is turned off in difficulty
  • Description updated (diff)
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from No to Yes

Updated by zGuba over 3 years ago

  • Due date changed from 10/21/2011 to 03/21/2012
  • Category changed from Gameplay to Config
  • Audio card deleted (Please specify!)
  • Related to content of DLC set to BAF
  • Language deleted (Please set for missions)

Updated by kju over 3 years ago

  • Due date changed from 03/21/2012 to 04/01/2012
  • Operating system deleted (Vista 64 bit)
  • Graphics card deleted (GTX285)
  • Affected ArmA II version changed from 1.59.79384 to 1.60.87580
  • CPU deleted (i7)
  • Size of OS swap file deleted (Please specify!)
  • I am using some Mods changed from Yes to No

Updated by kju over 3 years ago

Small config tweak fix:

class CfgPatches
{
    class CRV7_PGLockingFix_Gameplay_C_PvPscene
    {
        units[] = {};
        weapons[] = {};
        requiredVersion = 0.1;
        requiredAddons[] = {"CAWeapons_BAF"};
        version = "2012-01-13";
        fileName = "AAA_Gameplay_C_PvPscene.pbo";
        author = "PvPscene";
        mail = "pvpscene@web.de";
    };
};
class CfgWeapons
{
    class RocketPods;
    class CRV7_PG: RocketPods
    {
        canLock = 2;//1
    };
};

Updated by ricnunes about 3 years ago

I noticed that this issue is already assigned but it still isn't implemented/fixed in the latest Beta Patch (v90242) so is there a ETA to when will this issue/fix will be implemented?
I'm asking this since this seems to be a very simple issue to fix and yet one that completly breaks the playability of the Wilcat Helicopter in higher dificulty levels (Veteran and Elite).

Updated by ricnunes almost 3 years ago

Just tested the 1.61 patch release candidate and I'm disapointed to see that this bug isn't solved in this lastest 1.61 patch.

When will this be solved, when ArmA3 is released?
Now really, why does it take so long to solve this very simple issue that doesn't break any other gameplay feature?

Updated by kju almost 3 years ago

  • Due date deleted (04/01/2012)
  • Affected ArmA II version changed from 1.60.87580 to 1.61.94945 RC1

Updated by OMAC almost 3 years ago

  • File Wildcat_missile_test.Shapur_BAF.zip added

Updated by OMAC almost 3 years ago

  • File arma2oa_2012_07_15_17_22_42_646.jpg added

Updated by Fireball almost 3 years ago

  • Status changed from Assigned to Closed
  • Assignee deleted (Dwarden)

Confirming working as designed.

(...)

Updated by kju almost 3 years ago

  • Status changed from Closed to Feedback

Sorry to say OMAC and Fireball but you have the wrong premise here.
With an AI gunner it work of course as the AI is manually guiding it to the target.

The issue is at hand if you are pilot with no other crew.

Updated by ricnunes almost 3 years ago

I must admit that this is getting a bit frustrating by now!
Since when the original repro is wrong/invalid?? The original repro clearly shows that the CRV-7 PG doesn't lock LASER MARKERS.
The problem is not that the CRV-7 PG can (or not) lock military targets such as cars or fixed weapons (fixed MGs for example).

Yes, you can order your AI gunner to lock some military targets (like you usually do in the Apache with Hellfire missiles) even with "Auto guide AT" turned OFF and yes it will lock tanks, cars and even fixed weapons (MGs, mortars, etc...) but that's not the problem!
The problem is that you CANNOT lock LASER MARKERS either marked by your own Wildcat helicopter/gunner or designated by an infantry soldier on the ground and note that the CRV-7 PG is in real life a LASER GUIDED rocket if you have "Auto guide AT" turned OFF. But if you do this in an Apache using Hellfire missiles, you are able to lock LASER MARKERS either marked by infantry soldiers on the ground or by your own Apache helicopter gunner if you arm the Apache with a Laser Designator (in the mission editor) even if you have "Auto guide AT" turned OFF.

Again, note that the problem/ticket isn't regarding the Wildcat's CRV-7 rockets ability to lock tanks (or other military targets), this ticket is regarding the ability for the CRV-7 rockets ability to lock LASER MARKERS.
For example: If you're flying a Wildcat Helicopter as a pilot and you have an another Human as a Gunner in your helicopter and if you want to take out a building or a group of infantry soldiers you can do this if your human gunner aims the laser designator/marker towards the building or infantry and then you lock the laser marker and fire but this is only possible if you have the "Auto guide AT" turned ON. But if you have the "Auto guide AT" turned OFF there's no way to lock Laser Markers made by the Laser Designator with the CRV-7 PG rocket (but curiously this is possible with the Hellfire missile).

And the problem that the CRV-7 rockets don't lock Laser Markers still persists with version 1.61 RC!

Updated by Fireball almost 3 years ago

  • Subject changed from Laser guidance for BAF Wildcat CRV-7 PG rockets fails when "Auto guide AT" is turned off in difficulty to Cannot acquire laser target for BAF Wildcat CRV-7 PG rockets if "Auto guide AT" is turned off in difficulty
  • Description updated (diff)
  • Status changed from Feedback to Assigned

Ok, improved bug description, so that even a Fireball (and maybe any devel) understands the issue.

Kju and me tested it in MP so we had a human pilot and gunner and we were unable to lock on the laser target when the difficulty setting was accordingly.

The additional comments are confusing to say the least, if not even misleading (referral to AI etc.) - hence I'll remove some of them.

Updated by Fireball almost 3 years ago

  • File deleted (Wildcat_missile_test.Shapur_BAF.zip)

Updated by Fireball almost 3 years ago

  • File deleted (arma2oa_2012_07_15_17_22_42_646.jpg)

Updated by Fireball almost 3 years ago

  • Assignee set to Dwarden

Updated by Fireball almost 3 years ago

  • Description updated (diff)

Updated by OMAC almost 3 years ago

To further reduce the possibility of future confusion, I would change the repro step

5. No lock will be acquired

to:

5. No lock on laser-marked target will be acquired

since locks will occur for other targets (vehicles), just not the laser designated ones.

Updated by kju almost 3 years ago

  • Description updated (diff)

Updated by Fireball almost 3 years ago

  • Description updated (diff)

Updated by Fireball almost 3 years ago

(removing irrelevant post for the bug ticket)

Updated by kju almost 3 years ago

  • Affected ArmA II version changed from 1.61.94945 RC1 to 1.62.95248

Also available in: Atom PDF