Bug #13377

BMP-2 will not attack armored targets at short distance

Added by gibson23 over 4 years ago. Updated over 2 years ago.

Status:Closed Start date:08/30/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:AI Issues
Target version:1.62.95248
Affected ArmA II version:1.58 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs:
From the mission file you will see two Bmp 2's facing each other, None will fire at each other.

Exp:
Both BMP 2's should engage each other.

Repro:
1:load mission
2:observe how both bmp 2's will not engage

Note
If you put them 500m+ apart, they will start to use their 2A42 gun. No missile use though.

13377.chernarus.7z (672 Bytes) kju, 02/12/2011 16:58


Related issues

related to ARMA2 Community Issue Tracker - Bug #2236: LAV-25 vs BMP-2 or BMP-2 vs BMP-2 not engaging each other Closed 06/23/2009

History

Updated by gibson23 over 4 years ago

  • File mission.sqm added

Updated by Fireball over 4 years ago

  • Due date set to 11/30/2010
  • Status changed from New to Assigned
  • Priority changed from High to Normal

Updated by Fireball over 4 years ago

  • Assignee set to Dwarden
  • Reproducible for you changed from No to Yes

Updated by Fireball over 4 years ago

  • Due date changed from 11/30/2010 to 09/15/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)

Updated by Fireball over 4 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • Affected ArmA II version changed from 1.54.72888 to 1.55 BETA

Updated by Dwarden over 4 years ago

  • Target version set to Upcoming version

Updated by kju about 4 years ago

  • CPU deleted (AMD Phenom II X2 550 3.2GHZ)

Updated by kju about 4 years ago

  • Subject changed from BMP 2 problems engaging to BMP 2 do attack armored targets at close distance
  • Due date changed from 09/15/2010 to 03/01/2011
  • Affected ArmA II version changed from 1.55 BETA to 1.58 BETA

Updated by kju about 4 years ago

  • Reproduced by another DH user changed from No to Yes

Updated by kju about 4 years ago

  • File 13377.chernarus.7z added
  • Due date changed from 03/01/2011 to 05/01/2011
  • Target version deleted (Upcoming version)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Updated by kju about 4 years ago

  • Subject changed from BMP 2 do attack armored targets at close distance to BMP 2 do not attack armored targets at short distance

Updated by kju about 4 years ago

  • File deleted (mission.sqm)

Updated by zGuba almost 3 years ago

  • I am using deleted (CO (A2+OA))

May be related to value inherited:

irscanrangemin = 500;

http://browser.six-projects.net/cfg_vehicles/BMP2_Base/config?version=58
Click Show full

Though this may be outdated and needs retesting

Updated by zGuba almost 3 years ago

  • I am using set to CO (OA+A2)

Updated by Dwarden almost 3 years ago

  • Target version set to 1.61 BETA

Updated by Hanzu over 2 years ago

  • Subject changed from BMP 2 do not attack armored targets at short distance to BMP-2 will not attack armored targets at short distance
  • Due date deleted (05/01/2011)

Updated by Hanzu over 2 years ago

  • Status changed from Assigned to Expired
  • Assignee deleted (Dwarden)

Tested repro mission with 1.60.94444 and the original issue seems to be gone. Everytime both BMP-2s fired at each other.

BMP-2 [CDF] vs BMP-2 [Insurgents]
1-0 (CDF won)
1-1 (both damaged their gun, so battle never ended)
1-1 (both damaged their gun, so battle never ended)
1-0 (CDF won)
1-0 (CDF won)
1-0 (CDF won)
0-1 (Insurgents won. I was beginning to think if there is differences in their armor, since Insurents rarely won with same vehicle).

Since original issue could not be reproduced. Setting this expired.

Updated by Hanzu over 2 years ago

  • Status changed from Expired to Closed

Updated by kju over 2 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Also available in: Atom PDF