Bug #13366

OnRespawn for a Player Unit not getting the Init

Added by ViperMaul about 5 years ago. Updated almost 5 years ago.

Status:Closed Start date:08/29/2010
Priority:Normal Due date:
Assignee:Sickboy % Done:

100%

Category:XEH
Target version:v0.7.0
Component:XEH Affected Version:
Close Reason:

Description

Line 88 the Init runs at the start as expected.
But it does not run when the player respawns.
No error msgs.

http://pastebin.jonasscholz.de/981

The class name of the player unit is USMC_Soldier_AR

Any thoughts? Could this be an XEH bug or something we are doing wrong?


Related issues

related to Community Base Addons - Task #14768: Evaluate OA 1.55 MP eventhandler usages (Killed/Respawn etc) Closed 10/31/2010 12/14/2010

Associated revisions

Revision 00ae82c2
Added by Sickboy almost 5 years ago

~ FIXED: XEH onRespawn initEHs. fixes #13366

Revision 00ae82c2
Added by Sickboy almost 5 years ago

~ FIXED: XEH onRespawn initEHs. fixes #13366

Revision 52079e86
Added by Sickboy almost 5 years ago

~ FIXED: InitPost did not run onRespawn. refs #13366.

~ FIXED: Different playableUnits behaviour on Killed Event. refs #13366.

Revision 52079e86
Added by Sickboy almost 5 years ago

~ FIXED: InitPost did not run onRespawn. refs #13366.

~ FIXED: Different playableUnits behaviour on Killed Event. refs #13366.

Revision 959df284
Added by Sickboy almost 5 years ago

CHANGED: Proper InitPost respawn fix. refs #13366

Revision 959df284
Added by Sickboy almost 5 years ago

CHANGED: Proper InitPost respawn fix. refs #13366

History

Updated by ViperMaul about 5 years ago

CAManBase > SoldierWB > USMC_Soldier_base > USMC_Soldier_AR
seems to be the player unit we are testing I am told.

Updated by Sickboy almost 5 years ago

Should be fine. I suppose is bug.
New global killed/hit/respawn events in latest A2OA Betas will probably make things a lot easier too.

Updated by Sickboy almost 5 years ago

  • Category set to XEH
  • Status changed from New to Assigned
  • Assignee set to killswitch
  • Target version set to v0.7.0

Updated by Sickboy almost 5 years ago

  • Status changed from Assigned to Feedback

Is this bug still the case?

Updated by Sickboy almost 5 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Updated by Sickboy almost 5 years ago

  • Tracker changed from Support to Bug
  • Assignee changed from killswitch to Sickboy

Updated by Sickboy almost 5 years ago

  • Status changed from Resolved to Closed
  • Component set to XEH

Solved, and confirmed. Perhaps we can also do more improvements with the new MP events, once 1.55 is out; #14768

Also available in: Atom PDF