Bug #13143

Laserdesignator laser misaligned to the optics markings.

Added by kju over 4 years ago. Updated over 3 years ago.

Status:Closed Start date:08/22/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Weapons
Target version:-
Affected ArmA II version:1.59.79384 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
At especially at distance with the laser dot very small,
it makes the dot hard to see as its conflicts with the optics
horizontal black line.

Repro
  1. Load mission
  2. Switch to LD
  3. Activate LD
  4. Notice the offset of the laser dot to the optics

0001.jpg (75.7 kB) kju, 08/22/2010 05:27

0002.jpg (146.8 kB) kju, 08/22/2010 05:27

OA_LaserNotCentered.Desert_E.7z (624 Bytes) kju, 08/22/2010 09:58

arma2oa-LD-60m.jpg (191.7 kB) Fireball, 07/14/2011 10:55

arma2oa_2011-07-14_13-02-42-89.bmp (3.5 MB) kju, 07/14/2011 11:07

arma2oa_2011-07-14_13-02-56-42.bmp (3.5 MB) kju, 07/14/2011 11:07

arma2oa_2011-07-14_13-02-58-29.bmp (3.5 MB) kju, 07/14/2011 11:07

arma2oa_2011-07-14_13-03-00-45.bmp (3.5 MB) kju, 07/14/2011 11:07


Related issues

related to ARMA2 Community Issue Tracker - Bug #12798: Laser point at night behaves differently than at day time Expired 08/08/2010 02/01/2011
related to ARMA2 Community Issue Tracker - Feature #8540: Make vehicle/turret controls follow cursor/camera, possib... Assigned 01/26/2010

History

Updated by kju over 4 years ago

  • File deleted (OA_LaserNotCentered.Desert_E.7z)

Updated by Fireball over 4 years ago

  • Reproduced by another DH user changed from No to Yes

Confirm, it overlaps naughtily at approx 200m distance.

Note that this only reproes at day time; for night time we have another bug (#12798).

Updated by zGuba over 4 years ago

IMO laser should always be shot "through the optics", so we could use it with gunships (currently if we equip f.e. AH-64 with laserdesignator_veh, it would be always shot along currently selected weapon's direction).

Updated by BigDawgKS over 4 years ago

Actually zGuba, we should be able to define which muzzle the laser designator uses (by should I mean I'm not sure if it is already possible, but if it isn't it should be) in the config, so we can have a seperate laser designator "muzzle" that we can align with the optics if we wish.

Updated by zGuba over 4 years ago

what about something like gunEnd and gunBeg, but for laser? ;)

Updated by BigDawgKS over 4 years ago

That, or ability to define in laser designator weapon config which selections to use.

Updated by kju over 4 years ago

  • Due date changed from 12/01/2010 to 03/01/2011
  • Affected ArmA II version changed from 1.53 BETA to 1.58 BETA

Updated by zGuba almost 4 years ago

  • Due date changed from 03/01/2011 to 10/01/2011
  • Affected ArmA II version changed from 1.58 BETA to 1.60 BETA

Updated by Fireball almost 4 years ago

  • Status changed from Assigned to Duplicate

Dupe of #21026.

Updated by kju almost 4 years ago

  • Status changed from Duplicate to Feedback

No duplicate and still true in 82604.

This seems more of a model problem. Selection not perfectly aligned right.

Updated by Fireball almost 4 years ago

  • Due date changed from 10/01/2011 to 07/28/2011

Seems more a 'zeroing' issue at close distance. This might be by design since the laser is not actually "shooting" out of the optics and you will rather not use the designator at close distances like this (4m and 58m, according to screenshots).

Please tell me if this influences usage of LD at regular distances, else this issue might be irrelevant.

Updated by Fireball almost 4 years ago

Coming from 60m, the LD is more or less spot on - I think that's not a bug.

Updated by kju almost 4 years ago

Here are some samples. You need to zoom in closely to see
the laser dot as it is close to a (few) pixel small.

The distance is 300-500 meters. Above the laser dot is no longer rendered.

Updated by Fireball almost 4 years ago

I see the pixel is one off at 500m - not sure how much in centimeters or meters this is at 1000 or 2000, but from my in-game experiences in the past I'd say this is neglectable.

I think we need to prove that this is a very issue at larger distances, not just theorize based on a pixel - we're targeting buildings or vehicles with the LD, not squirrels.

Can you provide a mission with repro steps which proves that the LD is, in fact, too inaccurate at a meaningful distance (this probably is the point where we need to define "meaningful distance" for the LD)?

EDIT: I think you can see it well at night, that the LD laser dot becomes more accurate the further away you point it - up to 2500m. But this could be the result of #12798 too.

Updated by zGuba over 3 years ago

  • Due date changed from 07/28/2011 to 11/28/2011
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.60 BETA to 1.59.79384

Updated by Fireball over 3 years ago

  • Due date changed from 11/28/2011 to 08/11/2011
  • Status changed from Assigned to Feedback

Actually, I've been trying this again in the LD inaccuracy repro mission for MP (different issue) with zGuba and was aiming with crosshairs at a rock in approx 2km distance; my findings were that the crosshairs were absolutely accurate on the edge of the rock:

When I moved the crosshairs center over the edge of the rock, the distance readings jumped up and down, as it should when the laser is well-centered. So I think the fear that on distance the LD might be inaccurate is unfounded; as I mentioned earlier, the contrary is the case; it's zeroed for very far distances, hence you can see slight offsets on closer distances.

Try it yourself.

Updated by zGuba over 3 years ago

  • Due date changed from 08/11/2011 to 09/11/2011
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

I can't reproduce it neither.

Updated by kju over 3 years ago

  • Due date deleted (09/11/2011)
  • Status changed from Feedback to Closed

Also available in: Atom PDF