Bug #12973

Remote (non-local) bullet impacts not shown beyond 500m

Added by Franklin almost 5 years ago. Updated almost 3 years ago.

Status:Closed Start date:08/15/2010
Priority:Normal Due date:06/01/2011
Assignee:Dwarden % Done:

0%

Category:Rendering
Target version:1.62.95248
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:Yes Single / Multi Player?:MP Only
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

In multiplayer, non local bullet impacts are not rendered past a certain distance ~500m maybe. This makes it impossible for spotters to assist snipers at all.

CIT_12973_RemoteBulletImpacts.Desert_E.7z (780 Bytes) Fireball, 09/04/2010 15:53

CIT_12973_RemoteBulletImpactsAH64.Desert_E.7z (874 Bytes) Fireball, 03/27/2011 19:53

arma2oa_2011-03-27_21-43-28-50.jpg (101.2 kB) Fireball, 03/27/2011 19:54

arma2oa_2011-03-27_21-44-01-47.jpg (94.4 kB) Fireball, 03/27/2011 19:54

distantBulletHit.Desert_E.zip - Automated DS repro (1 kB) Suma, 12/29/2011 09:56

History

Updated by kju almost 5 years ago

  • Due date set to 09/01/2010
  • Category set to Rendering
  • Status changed from New to Feedback

Updated by Franklin almost 5 years ago

just go into any map and shoot past 500m in multiplayer, and have a buddy watch. Binos, vector nite, scopes... your buddy cant see the round land with anything. if its really necessary to provide a map, ill make one tonight.

Updated by Fireball almost 5 years ago

It's true, I have had the same issue being the gunner of an AH-64D, which was remote. The pilot saw the impacts, but I didn't - it was completely impossible for me to guess where I was shooting.

When the pilot shot, I saw the impacts - I thought I was going crazy. Now, reading this ticket, it makes all sense!

Attached a mission, with a sniper and a playable spotter, and a popup target, approx. 600m away. This should exhibit the issue, when the Franklin is right.

Updated by Morhoo over 4 years ago

Seconded. Any progress so far?

Updated by stk over 4 years ago

We need this BIS I am a sniper and have a friend who spots for me we struggle to say the least if I miss.

Updated by kju over 4 years ago

  • Due date changed from 12/15/2010 to 06/01/2011
  • Operating system deleted (Vista 64 bit)
  • Graphics card deleted (EVGA GTX260OC 3way SLI)
  • Affected ArmA II version changed from 1.07.71750 to 1.58.78473
  • CPU deleted (i7 930)
  • Audio card deleted (N/A)
  • Size of OS swap file deleted (Please specify!)

Updated by Dwarden over 4 years ago

  • Target version set to Upcoming version
  • I am using deleted (CO (A2+OA))

Updated by Dwarden over 4 years ago

  • I am using set to CO (OA+A2)

Updated by Fireball over 4 years ago

New repro mission with AH-64D for vehicle fire impact effects not seen:

- start the mission and shoot at the containers around the oil platform (see screenshots)
- the gunner can see the impacts, smoke and explosion
- the pilot, albeit his visual is closer than the gunner's even (due to "zoomed view"), he can't see the explosions

It seems to cut off the effects remotely around 200m.

Updated by Sickboy over 3 years ago

  • Subject changed from non-local bullet impacts not shown to Remote (non-local) bullet impacts not shown
  • Status changed from Assigned to Feedback
  • Assignee changed from Dwarden to Franklin
  • Affected ArmA II version changed from 1.58.78473 to 1.59.79384

Updated by Sickboy over 3 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from Franklin to Dwarden
  • Affected ArmA II version changed from 1.59.79384 to 1.60 BETA

Still valid for v1.60beta..

Updated by Sickboy over 3 years ago

  • Subject changed from Remote (non-local) bullet impacts not shown to Remote (non-local) bullet impacts not shown beyond 500m

Updated by l0ckandl0ad over 3 years ago

Coming here from http://forums.bistudio.com/showthread.php?t=129333.

All I can say that it was perfectly working in 1.59.85680 beta. We did test it with M107 for up to 2km with standart ammo (no tracers/RAUFOSS).
And, yeah, we would LOVE this feature to be fixed. Community sniper teams would be so much grateful that you can't possibly imagine.

Updated by Dwarden over 3 years ago

  • Assignee changed from Dwarden to Suma
  • Target version changed from Upcoming version to 1.61 BETA
  • Single / Multi Player? set to MP Only

this may interest Suma, especially the part "it was perfectly working in 1.59.85680 beta"

Updated by kju over 3 years ago

All I can say that it was perfectly working in 1.59.85680 beta

I cannot confirm this.

Updated by Suma over 3 years ago

All I can say that it was perfectly working in 1.59.85680 beta

Cannot be true. 85680 did not exist before Oct 2011, while this issue is more then a year old now.

Updated by Dwarden over 3 years ago

Suma wrote:

Cannot be true. 85680 did not exist before Oct 2011, while this issue is more then a year old now.

thanks for confirm, i found it strange myself ...

anyway is there way how show distant MP remote effects e.g. within optics only?

or it's better increase the range globally / like new server-setting to definite range ?

Updated by Suma over 3 years ago

Fixed in 87646 (fix is server side only)

Attached automated DS repro for easier verification (was useful for debugging as well)

Repro steps:
- start DS with a mission copied into MPMissions
- connect a client
- choose mission distantBulletHit.Desert_E and start it
- watch the AI firing at the car behind the drilling tower

Expected result:
- bullet hits of the AI soldier visible

Updated by l0ckandl0ad over 3 years ago

Hello again. Really glad that this thing got fixed, and hope it is really fixed now :)

Btw, I still have 85680 beta build. And I used your repro mission to show you it was working and that I was right. Here's the video.

http://youtu.be/OvbPfG0cavI

Thanks for fixing it, again.

Updated by kju over 3 years ago

All AI on a hosted server is local and NOT remote.

So again it was never working up until now.

Updated by Suma over 3 years ago

It would work before if someone had used very low values of MinErrorToSend / MinErrorToSendNear. If anything, with 1.60 one could perhaps see the hits a bit further away because of lower default value of MinErrorToSend.

Updated by l0ckandl0ad over 3 years ago

Oh, well, now I know what "DS" means. XD

Okay, here's another video I made on DS with my bro. Hope ~1800 meters is not just "a bit further away" for you and this might be considered as a valid proof. It WAS working there. Really :)

http://youtu.be/7krBDky-Ujk?hd=1

Anyway, we'd be testing this new beta patch tonight, big big THANK YOU for your work. Peace.

Updated by Suma over 3 years ago

  • Assignee changed from Suma to Dwarden

Updated by Suma about 3 years ago

  • Status changed from Resolved to Closed

Assuming fixed.

Updated by kju almost 3 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Also available in: Atom PDF